Tag Archives: löschen

Wenn du nach den Sternen greifst, solltest du die Achselhaare rasieren.

Ich öffne eine PivotTabelle. Erstaunlich: Neben den Monatsnamen befinden sich auch die Zahlen der Monate als Vorschlag. Aber beim Einblenden wird nichts angezeigt:

Auch in der Ursprungsliste befinden sich diese Werte nicht. Ein Blick auf die Datenherkunft zeigt, dass in der Liste eine Formel steht:

=WENN(ISTZAHL(A2);TEXT(DATUM(JAHR(A2);MONAT(A2);1);“MMM“);““)

Wahrscheinlich wurde eine alte Formel, wie beispielsweise:

=WENN(ISTZAHL(A2);MONAT(A2);““)

durch diese Formel ersetzt.

Ein Aktualisieren der Pivottabelle nützt nichts, um die alten, nicht mehr vorhandenen Werte, zu löschen. Auch ein Entfernen der Spalte „Monat“ nützt nichts. Man muss beides machen: das Feld entfernen, aktualisieren und erneut einfügen. Dann sind die „überflüssigen“ Werte weg:

Nicht zu löschen!

Heute in der VBA-Schulung fragte mich eine Teilnehmerin, warum sie eine UserForm nicht löschen dürfe. Im ersten Moment war ich verblüfft.

Wo bitte ist "entfernen"?

Wo bitte ist „entfernen“?

Dann fiel mein Blick auf die Titelzeile. Aha – der Fehler war schnell gefunden: an einer anderen Stelle lief noch ein Makro, das gerade unterbrochen war:

Ah!

Ah!

#BEZUG!

Ich weiß nicht mehr, was ich gemacht habe. Ich sollte in einer Tabelle einer Kollegin die Formel für den Unterstützungsbeitrag unserer Firma anpassen. Irgendwann entdecke ich jedoch in einer Zelle die Fehlermeldung #BEZUG! Kann ich den Fehler lokalisieren? Oder die Formel wieder auf eine korrekte Form bringen?

#BEZUG!

#BEZUG!

Die Antwort: Leider nein! Wahrscheinlich haben Sie irgendwo etwas gelöscht (beispielsweise eine Zeile), die an anderer Stelle noch verwendet wurde. Menschen rechnen oft kreuz und quer in Excel; schreiben irgendwelche Konstanten in irgendwelche Zellen. Fremde Tabellenblätter zu analysieren ist schwierig und mühsam:

Tipp 1: Speichern Sie die Originaldatei unter einem anderen Namen ab.

Tipp 2: Bevor Sie etwas löschen, von dem Sie denken, dass es nicht mehr benötigt wird – überprüfen Sie mit der Spur zum Nachfolger, ob irgendwo eine andere Formel mit dieser weiter rechnet.

Alles ist weg!

So schnell geht es nicht! Es gibt allerdings mehrere Möglichkeiten, was Sie gemacht haben:

1. Sie haben aus Versehen eine neue Datei geöffnet (beispielsweise mit [Strg]+[N]). Die Liste aller zur Zeit offenen Dateien finden Sie in Ansicht / Fenster / Fenster wechseln

Alle offenen Dateien

Alle offenen Dateien

2. Oder aus Versehen die Datei ausgeblendet. Vielleicht wollten Sie etwas anderes ausblenden. Man kann eine Datei über Ansicht / Fenster /Ausblenden, beziehungsweise Einblenden herholen, beziehungsweise unsichtbar machen.

3. Oder Sie haben aus Versehen das Tabellenblatt ausgeblendet. Sie können es über die rechte Maustaste auf ein vorhandenes Tabellenblatt wieder einblenden (Oder auch: Start / Zellen / Format / Ausblenden & Einblenden / Blatt einblenden)

Das Blatt wurde ausgeblendet.

Das Blatt wurde ausgeblendet.

4. Oder das Blatt wurde außerhalb des sichtbaren Bereiches verschoben. Sie können mit der rechten Maustaste auf die Pfeilchen am linken Rand klicken, um eine Übersichtsliste aller sichtbaren Tabellenblätter zu erhalten (und sehen so beispielsweise, dass „September“ vor dem „Januar“ steht.

Das Blatt wurde verschoben.

Das Blatt wurde verschoben.

5. Oder Sie haben alles markiert und eine Taste gedrückt. Dafür gibt es ja die Rückgängig-Funktion!

6. Oder Sie haben aus Versehen zwei Mal Excel geöffnet. Werfen Sie mal einen Blick in die Taskleiste unten!

Hier wurde Excel 2013 und Excel 2010 geöffnet ...

Hier wurde Excel 2013 und Excel 2010 geöffnet …

Nicht mehr rückgängig machen kann man allerdings das Löschen des Blattes. Wenn Sie die Datei bereits gespeichert haben, können Sie diese schließen ohne noch einmal zu speichern.

Wenn Sie das Blatt löschen UND die Löschung bestätigen - dann kann man Ihnen leider nicht mehr helfen (außer: Datei schließen ohne zu speichern).

Wenn Sie das Blatt löschen UND die Löschung bestätigen – dann kann man Ihnen leider nicht mehr helfen (außer: Datei schließen ohne zu speichern).