Tag Archives: Zeilen

Schuhe können Dein Leben verändern, denk an Cinderella!

Perfide! Wenn man in einer (intelligenten) Tabelle eine Formel verwendet, die den Tabellenblattnamen verwendet – beispielsweise

=WENN(Tabelle1!D7=“m“;20;10)

Wenn man anschließend die Tabelle in einen normalen Bereich konvertiert:

Wenn man schließlich die neue Liste sortiert:

So erhält man Chaos! Die Zeilenbezüge werden nach der Sortierung nicht mitgenommen!

Danke an Andreas Thehos, der auf den Excellent Days 2018 diesen Bug vorgestellt hat.

Für Mädchen ist es besser nicht zu heiraten, aber Junx brauchen jemanden zum Putzen.

Ein Vortrag von Martin Weiß über Bedingte Formatierungen auf den Excellent Days. Er zeigt, wie man mit der Funktion ZÄHLENWENN alle Zahlen einfärben kann, mehr als drei mal vorkommen. Die Formel in der Bedingte Formatierungen lautet:

=ZÄHLENWENN($A$3:$O$32;A3)>3

Alle machen brav mit. Mein Nachbar wundert sich, warum bei ihm keine Zelle rot eingefärbt wird. Er schaut in den Manager für Regeln zur Bedingten Formatierung und wundert sich über die Formel:

=ZÄHLENWENN($A$3:$O$32;XEQ1048550)>3

Der Grund ist einfach: Er hat den Bereich von rechts unten nach links oben markiert. Deshalb wird ein relativer Bezug A3 in der Zelle A3 umgesetzt in: 30 Zeilen nach oben und 15 Spalten nach links. So kommt XEQ1048550 zustande.

Damit so etwas Nervendes nicht passiert, schlage ich ein anderes Vorgehen vor:

Ich beginne im ersten Schritt mit einer Zelle, beispielsweise A3 (oder O32) und aktiviere dort die Bedingte Formatierung:

Im zweiten Schritt aktiviere ich erneut den Regelmanager (Start / Bedingte Formatierung / Regeln verwalten) und dehne nun den Bereich aus:

Das klappt:

Okay – ein Schritt mehr – aber ich bin auf der sicheren Seite. Damit Excel nicht mehr nervt!

 

Loading…… ….. …. … .. .

Immer wieder erstaunt.

Auf der Seite

https://www.fakenamegenerator.com

kann man über „Order in Bulk“ Zufallsnamen generieren lassen. Tolle Sache: 100.000 Deutsche, 100.000 Schweizer und ebenso viele Österreicher. Ich bereite die Daten auf, lösche einige Informationen, ersetze sie durch andere. Lösche die Leerzeilen zwischen dem Datensatz Nummer 100.000 und 100.001, bzw. 100.000 Zeilen weiter unten noch einmal, indem ich zwei Zeilen markiere und [Strg] + [-] drücke.

„Der Vorgang, den Sie gerade ausführen möchten, wirkt sich auf eine große Anzahl von Zellen aus und kann viel Zeit in Anspruch nehmen.“ Dieser Satz könnte von meiner Mutter sein, als ich noch zu Hause gewohnt habe …

Übrigens: der Vorgang des Zeilenlöschens dauert genauso lange wie sonst auch: ratz-fatz – und weg sind sie.

Die Sünde ist der beste Teil der Reue

Schon seltsam.

Eine Liste enthält Texte und Zahlen. Ich möchte herausfinden, wie viele Zellen gefüllt sind. Ich versuche ZÄHLENWENN. Wir wissen, das zwei Anführungszeichen innerhalb eines Textes als ein Anführungszeichen interpretiert wird. Also versuche ich:

=ZÄHLENWENN(C2:C15;“<>“““““)

Es scheitert!

Obwohl die Bedingung <>““ korrekt arbeitet, muss man die Bedingung folgendermaßen formulieren:

=ZÄHLENWENN(C2:C15;“<>“)

Analog werden die Anzahl der leeren Zellen ermittelt:

=ZÄHLENWENN(C2:C15;“=“)

Dann klappt es.

Beim nächsten Mal verwende ich wieder:

=ANZAHL2(C2:C15)

oder:

=ZEILEN(C2:C15)-ANZAHLLEEREZELLEN(C2:C15)

Ich kann auch nett – bringt aber nix!

Doch, manche Dinge begeistern mich:

Wird in einer intelligenten Tabelle (in einer formatierten Tabelle) eine ganze Zeile markiert und diese am Rand heruntergezogen, wird die darunterliegende Zeile überschrieben. Abhilfe schafft das Drücken der Shift-Taste:

ganze Zeile verschieben

ganze Zeile verschieben

Markiert man dagegen nur die Zellen einer Zelle bis zum Ende der Tabelle, kann man ohne weitere Taste diese Zeile herunterziehen:

20161123tabelle02

Ein dummer Mensch macht zu allem eine Bemerkung … ein Kluger bemerkt alles.

Ich versuche mich mit den „intelligenten Tabellen“ (den formatierten Tabellen) anzufreunden. Aber sie machen es mir verdammt schwer.

Ich habe eine Artikelliste – umgewandelt als „intelligente Tabelle“. Soweit, so gut. Wenn ich neue Daten unterhalb der Liste eintrage, wird die Liste automatisch erweitert. Prima.

Wenn ich allerdings statt eines Wertes eine Formel eintrage – beispielsweise um aus dem Bruttowert den Nettowert zu berechnen, so beendet Excel die Liste und zeigt mir die Formale als Formel unterhalb der Tabelle an. Das will ich aber nicht!

DAS will ich nicht!

DAS will ich nicht!

Excel zwingt mich zuerst mindestens einen Wert in die neue Zeile einzutragen – DANN erst erlaubt er Formeln …

Auf einmal ist er weg …

Ist Ihnen folgendes amüsante (?) Phänomen schon aufgefallen? Sie haben eine kleine Liste, beispielsweise sieben Zeilen (Rubriken) und zwei Spalten (Reihen). Daraus erstellen Sie ein Balkendiagramm. Das Symbol „Zeile/Spalte wechseln“ ist aktiv.

noch klappt es ja.

noch klappt es ja.

Wechseln Sie nun über das Symbol „Daten auswählen“ in den zugehörigen Dialog und vertauschen die Reihenfolge der Reihen:

Die Reihen werden vertauscht.

Die Reihen werden vertauscht.

Danach ist das Symbol „Zeile/Spalte wechseln“ nicht mehr aktiv:

jetzt klappt es nicht mehr.

jetzt klappt es nicht mehr.

Die Lösung für dieses Problem: Im Dialog „Daten auswählen“ muss man nun erneut den Diagrammdatenbereich festlegen. Dann darf man wieder Zeilen und Spalten vertauschen ?!?

aber so geht es wieder ...

aber so geht es wieder …