Tag Archives: ANZAHL2

Die Sünde ist der beste Teil der Reue

Schon seltsam.

Eine Liste enthält Texte und Zahlen. Ich möchte herausfinden, wie viele Zellen gefüllt sind. Ich versuche ZÄHLENWENN. Wir wissen, das zwei Anführungszeichen innerhalb eines Textes als ein Anführungszeichen interpretiert wird. Also versuche ich:

=ZÄHLENWENN(C2:C15;“<>“““““)

Es scheitert!

Obwohl die Bedingung <>““ korrekt arbeitet, muss man die Bedingung folgendermaßen formulieren:

=ZÄHLENWENN(C2:C15;“<>“)

Analog werden die Anzahl der leeren Zellen ermittelt:

=ZÄHLENWENN(C2:C15;“=“)

Dann klappt es.

Beim nächsten Mal verwende ich wieder:

=ANZAHL2(C2:C15)

oder:

=ZEILEN(C2:C15)-ANZAHLLEEREZELLEN(C2:C15)

Ich bin nicht perfekt. Aber trotzdem sehr gut gelungen.

Hallo Herr Martin,

nach meinem Urlaub komme ich nun endlich dazu diverse Dinge aus unserer Schulung umzusetzen. Wie es der Teufel will, komme ich an einer Stelle absolut nicht weiter.

Ich möchte ein dynamisches Diagramm erstellen. Dies funktioniert auch für die Werte darin (also die Linien) und für die Beschriftung sofern diese ein Datum oder eine Zahl ist. Ich habe nun aber häufiger den Fall, dass die Achsenbeschriftung ein Text ist. Das bekomme ich nicht hin! Es ergibt mir schon kein korrektes Ergebnis bei der Formel, wodurch das Diagramm natürlich auch nicht funktioniert.

Ich habe eine beispielhafte Datei angehängt. Es wäre super wenn Sie sich das mal ansehen und mir kurz Rückmeldung geben könnten. Ich finde einfach keine Lösung. Auch die Kolleginnen sind ratlos.

Herzlichen Dank im Voraus & viele Grüße,

SK.

Hallo Frau K.,

da waren drei Fehlerchen drin:

Sie müssen drei Namen anlegen: zwei für die Linien (hatten Sie) und einen weiteren für die Datenbeschriftung (der hat gefehlt). Und den verwenden Sie in Daten auswählen / horizontale Achsenbeschriftung.

Und: Sie müssen bei der Formel BEREICH.VERSCHIEBEN übers Ziel rausschießen: Sie zählen mit ANZAHL wie viele Daten Sie erfasst haben im Bereich (ich habe nun $A$6:$A$1700 verwendet).

Und: bitte ermitteln Sie die Anzahl der Texte mit der Funktion ANZAHL2 – nicht mit ANZAHL. Dann klappt es.

schöne Grüße

Rene Martin

 

Leerzeichen finden

Hallo. Ich habe schon eine ganze Weile gesucht, bis ich herausgefunden habe, warum er die gallischen Tiere falsch zählt. Eigentlich müsste die Formel ANZAHL2 die Zahl 2 ergeben und nicht 4:

ANZAHL2 zählt falsch

ANZAHL2 zählt falsch

Die Antwort habe ich nach langem Suchen gefunden: In einigen Zellen habe ich aus Versehen ein Leerzeichen eingegeben. Klar – das sehe ich nicht; das wird als Text mitgezählt.

Die Wurzel des Übels

Die Wurzel des Übels

Aber nun meine Frage: Wenn ich die Liste filtere – warum zeigt der Autofilter nicht an, dass einige Zellen Leerzeichen enthalten?

Die Antwort: Ja – Sie haben recht – der Autofilter übergeht zum Glück (oder leider?) die Leerzeichen. Der Vorteil: „Asterix“ und „Asterix “ (mit einem Leerzeichen am Ende) werden vom Filter als gleicher Text behandelt. Der Nachteil: Der Filter hilft nicht diese Leerzeichen, die an anderen Stellen Probleme verursachen, aufzufinden.

Der Autofilter übergeht Leerzeichen am Ende des Textes.

Der Autofilter übergeht Leerzeichen am Ende des Textes.

Man kann die Texte mit Suchen ([Strg]+[F]) auffinden. Oder mit Funktionen:

=LÄNGE(C2)

=WENN(LINKS(C2;1)=“ „;“x“;““)

Oder mit [Strg]+[↓] können Sie den Cursor nach unten versetzen; er springt nun zur ersten Zelle, in der etwas steht; stoppt also auch bei den Zellen, die mit einem Leerzeichen gefüllt sind.