Tag Archives: ANZAHLLEEREZELLEN

Die Sünde ist der beste Teil der Reue

Schon seltsam.

Eine Liste enthält Texte und Zahlen. Ich möchte herausfinden, wie viele Zellen gefüllt sind. Ich versuche ZÄHLENWENN. Wir wissen, das zwei Anführungszeichen innerhalb eines Textes als ein Anführungszeichen interpretiert wird. Also versuche ich:

=ZÄHLENWENN(C2:C15;“<>“““““)

Es scheitert!

Obwohl die Bedingung <>““ korrekt arbeitet, muss man die Bedingung folgendermaßen formulieren:

=ZÄHLENWENN(C2:C15;“<>“)

Analog werden die Anzahl der leeren Zellen ermittelt:

=ZÄHLENWENN(C2:C15;“=“)

Dann klappt es.

Beim nächsten Mal verwende ich wieder:

=ANZAHL2(C2:C15)

oder:

=ZEILEN(C2:C15)-ANZAHLLEEREZELLEN(C2:C15)