Tag Archives: Spalten

Papa, bekomme ich eine Delfintherapie? – Im Kühlschrank steht ein Glas Rollmöpse. Die kannst du aufwickeln und streicheln.

Nicht konsequent.

Will man in einer Tabelle in PowerPivot mehrere Spalten ausblenden, muss man sie einzeln markieren., wenn sie nicht nebeneinander liegen. Man kann sie dort nicht mit gedrückter [Strg]-Taste markieren.

Wechselt man jedoch von der Datensicht in die Diagrammsicht, ist es ohne Weiteres möglich mit gedrückter [Strg]-Taste mehrere Spalten zu selektieren.

Für Mädchen ist es besser nicht zu heiraten, aber Junx brauchen jemanden zum Putzen.

Ein Vortrag von Martin Weiß über Bedingte Formatierungen auf den Excellent Days. Er zeigt, wie man mit der Funktion ZÄHLENWENN alle Zahlen einfärben kann, mehr als drei mal vorkommen. Die Formel in der Bedingte Formatierungen lautet:

=ZÄHLENWENN($A$3:$O$32;A3)>3

Alle machen brav mit. Mein Nachbar wundert sich, warum bei ihm keine Zelle rot eingefärbt wird. Er schaut in den Manager für Regeln zur Bedingten Formatierung und wundert sich über die Formel:

=ZÄHLENWENN($A$3:$O$32;XEQ1048550)>3

Der Grund ist einfach: Er hat den Bereich von rechts unten nach links oben markiert. Deshalb wird ein relativer Bezug A3 in der Zelle A3 umgesetzt in: 30 Zeilen nach oben und 15 Spalten nach links. So kommt XEQ1048550 zustande.

Damit so etwas Nervendes nicht passiert, schlage ich ein anderes Vorgehen vor:

Ich beginne im ersten Schritt mit einer Zelle, beispielsweise A3 (oder O32) und aktiviere dort die Bedingte Formatierung:

Im zweiten Schritt aktiviere ich erneut den Regelmanager (Start / Bedingte Formatierung / Regeln verwalten) und dehne nun den Bereich aus:

Das klappt:

Okay – ein Schritt mehr – aber ich bin auf der sicheren Seite. Damit Excel nicht mehr nervt!

 

Dumme Gedanken hat jeder. Nur der Weise verschweigt sie.

Hallo Herr Martin,

ich würde gerne in einer Pivottabelle eine Spalte sortieren, aber es klappt nicht. Warum?

Sortieren - geht nicht!

Sortieren – geht nicht!

Die Antwort: Sie haben in Ihrem Beispiel eine Abhängigkeit zwischen dem Ort und dem Firmenname. Eine Firma ist in einem Ort. Deutlicher wird es, wenn Sie Daten verwenden, bei denen n Firmen in m Orten auftauchen. Beispielsweise Artikel und Verkäufer:

Hier geht es!

Hier geht es!

Hier wird deutlich, was sortieren bedeutet. Innerhalb der ersten Kategorie wird die zweite Kategorie sortiert. Aber pro Gruppe wird erneut sortiert. Da im ersten Beispiel nur ein Wert pro erste Kategorie vorhanden ist, „sieht man die Sortierung“ nicht.

Auf einmal ist er weg …

Ist Ihnen folgendes amüsante (?) Phänomen schon aufgefallen? Sie haben eine kleine Liste, beispielsweise sieben Zeilen (Rubriken) und zwei Spalten (Reihen). Daraus erstellen Sie ein Balkendiagramm. Das Symbol „Zeile/Spalte wechseln“ ist aktiv.

noch klappt es ja.

noch klappt es ja.

Wechseln Sie nun über das Symbol „Daten auswählen“ in den zugehörigen Dialog und vertauschen die Reihenfolge der Reihen:

Die Reihen werden vertauscht.

Die Reihen werden vertauscht.

Danach ist das Symbol „Zeile/Spalte wechseln“ nicht mehr aktiv:

jetzt klappt es nicht mehr.

jetzt klappt es nicht mehr.

Die Lösung für dieses Problem: Im Dialog „Daten auswählen“ muss man nun erneut den Diagrammdatenbereich festlegen. Dann darf man wieder Zeilen und Spalten vertauschen ?!?

aber so geht es wieder ...

aber so geht es wieder …

 

Mein Pivot hat nur eine Spalte zur Auswahl

Warum zeigt die Feldliste nur eine Spalte zur Auswahl an und nicht – wie sonst auch – alle Spalten der Tabelle?

Heute: Pivot light?!

Heute: Pivot light?!

Die Antwort: Sicherlich haben Sie in der Tabelle einige Zellen markiert. Sie können es mit Pivottable-Tools / Analysieren / Daten / Datenquelle ändern herausfinden: Dort zeigt Excel an, auf welchen Bereich die Pivottabelle zugreift:

In der Liste wurden zwei Zellen markiert.

In der Liste wurden zwei Zellen markiert.

Wahrscheinlich haben Sie beim Erstellen der Pivottabelle einige Zellen markiert – das hätte Ihnen auffallen können. Also: Entweder NICHTS markieren oder die gesamte Liste!

Hier hätte man es merken können.

Hier hätte man es merken können.

Einfügen nicht möglich

Haben Sie das einmal versucht? Schreiben Sie in die letzte Zelle der Zeile 1, also in Zelle XFD1 einen Wert. Versuchen Sie nun irgendwo ein Spalte einzufügen – das wird natürlich nicht funktionieren und mit einer Fehlermeldung quittiert werden.

Klar: Beim Einfügen von Spalten werden neue Spalten vor die aktuelle Spalte eingefügt und beim Einfügen von Zeilen werden neue Zeilen vor die aktuelle Zeile eingefügt. Deshalb wird alles nach rechts, beziehungsweise nach unten verschoben.

Fazit: Füllen Sie Excel nicht „randvoll“!

In Zelle XFD1 steht ein Wert - deshalb kann keine Spalte eingefügt werden.

In Zelle XFD1 steht ein Wert – deshalb kann keine Spalte eingefügt werden.