Tag Archives: aktualisieren

Manchmal komme ich mir vor wie in einem Asterix-Comic: Umzingelt von den Kollegen Denktnix, Machtnix, Weissnix und Kannnix.

Hallo Rene,

Ein anderes Problem tritt bei der Planung noch auf seit wir das neue Office 365 im Einsatz haben und zwar werden Bildinhalte von anderen Tabellen dargestellt (siehe Screenshot; blau markiert)

Man kann die Zellen dahinter aber ganz normal füllen usw.?

Gibt es da einen Trick damit Excel die Ansicht aktualisiert?

#####

Hallo Mario,

so etwas (ähnliches) kenne ich: ab und zu hat Excel eine Meise bzgl. Bildschirmdarstellungen:

* bei Datei / Drucken

* bei Kommentaren

Ich habe es auch schon beim Programmieren erlebt: ich erzeuge per VBA eine neue Datei; schreibe Informationen aus einer anderen Datei hinein – und am Bildschirm passieren „komische“ Dinge. Ich vermute, wenn du die Datei zu- und dann wieder aufmachst, klappt es, oder? Sieht alles okay aus?

Und sorry: nein! – ich weiß dafür leider keine Lösung – bin immer mal wieder drüber gestolpert; habe ein bisschen gesucht und nichts gefunden

 

Wenn du nach den Sternen greifst, solltest du die Achselhaare rasieren.

Ich öffne eine PivotTabelle. Erstaunlich: Neben den Monatsnamen befinden sich auch die Zahlen der Monate als Vorschlag. Aber beim Einblenden wird nichts angezeigt:

Auch in der Ursprungsliste befinden sich diese Werte nicht. Ein Blick auf die Datenherkunft zeigt, dass in der Liste eine Formel steht:

=WENN(ISTZAHL(A2);TEXT(DATUM(JAHR(A2);MONAT(A2);1);“MMM“);““)

Wahrscheinlich wurde eine alte Formel, wie beispielsweise:

=WENN(ISTZAHL(A2);MONAT(A2);““)

durch diese Formel ersetzt.

Ein Aktualisieren der Pivottabelle nützt nichts, um die alten, nicht mehr vorhandenen Werte, zu löschen. Auch ein Entfernen der Spalte „Monat“ nützt nichts. Man muss beides machen: das Feld entfernen, aktualisieren und erneut einfügen. Dann sind die „überflüssigen“ Werte weg:

Pivottabelle rechnet nicht richtig

Warum taucht in der Pivottabelle noch die Kategorie „Forschung“ auf? Die haben wir doch längst mit der Abteilung „Forschung und Entwicklung“ zusammengelegt.

Pivottabelle nicht korrekt

Pivottabelle nicht korrekt

Wenn der Bereich der Datenquelle korrekt ist, so wurde die Pivottabelle möglicherweise nicht aktualisiert. Sie können (und müssen!) den Refresh erzeugen über das Kontextmenü, über Analysieren / Daten / Aktualisieren. Oder indem Sie in Analysieren / PivotTable / Optionen / Optionen / Daten die Option einschalten „Aktualisieren beim Öffnen der Datei“.

Pivottabellen müssen aktualisiert werden.

Pivottabellen müssen aktualisiert werden.