Tag Archives: Monatsname

Ziele habe ich genug im Leben – nur wenig Munition.

Amüsant. Einer der Verkäufer – Herr Sonntag – wird in einer Pivottabelle nach oben sortiert:

Die Vermutung liegt nahe, dass Excel zuerst Monatsnamen und Wochentage sortiert und dann den „Rest“ alphabetisch. Schön und gut – aber wie bekommt man den Sonntag einsortiert?

Die Antwort findet sich in den „weiteren Sortieroptionen“: Dort muss „Sortiert nach“ – der richtigen Spalte eingeschaltet sein. Und anschließend schaltet man über den Befehl „weitere Optionen“ „bei jeder Berichtsaktualisierung automatisch sortieren“ aus.

Ein weiteres Dankeschön an Pia Bork, die nicht nur das Problem kannte, sondern auch seine Lösung.

Wenn du nach den Sternen greifst, solltest du die Achselhaare rasieren.

Ich öffne eine PivotTabelle. Erstaunlich: Neben den Monatsnamen befinden sich auch die Zahlen der Monate als Vorschlag. Aber beim Einblenden wird nichts angezeigt:

Auch in der Ursprungsliste befinden sich diese Werte nicht. Ein Blick auf die Datenherkunft zeigt, dass in der Liste eine Formel steht:

=WENN(ISTZAHL(A2);TEXT(DATUM(JAHR(A2);MONAT(A2);1);“MMM“);““)

Wahrscheinlich wurde eine alte Formel, wie beispielsweise:

=WENN(ISTZAHL(A2);MONAT(A2);““)

durch diese Formel ersetzt.

Ein Aktualisieren der Pivottabelle nützt nichts, um die alten, nicht mehr vorhandenen Werte, zu löschen. Auch ein Entfernen der Spalte „Monat“ nützt nichts. Man muss beides machen: das Feld entfernen, aktualisieren und erneut einfügen. Dann sind die „überflüssigen“ Werte weg: