Tag Archives: Wochentag

Es ist gut, dass nicht jeder ein Smartphone hat. Wir brauchen Menschen, die hupen, wenn es grün wird.

Hallo Herr Martin,

ich habe eine Art Kalender, also beginnend mit dem 01.01.2018, endend mit
dem 31.12.2018.
Bei der Aufziehung des Datums lasse ich das Wochenende weg.
In einer Extra-Spalte soll vor jedem Montag die Kalenderwochenzahl stehen.
Wenn ich diese Funktion anwende, wird die Kalenderwochenzahl auch vor den
Tagen Dienstag bis Freitag eingefügt.
Gibt es eine Möglichkeit, z. B. über die Bedingte Formatierung, daß die
Kalenderwochenzahl nur neben dem Montag gezeigt wird?
Herzliche Grüße

####

Hallo Herr F.,
ich würde es mit einer WENN-Funktion lösen. Beispielsweise so (wenn in B1) das Datum steht:
=WENN(WOCHENTAG(B1;2)=1;ISOKALENDERWOCHE(B1);„“)
schöne Grüße
Rene Martin

####

Hallo Herr Martin,

das ging aber recht schnell mit Ihrer Antwort. Vielen Dank.

Ich habe etwas herum experimentiert und diese Lösung benutzt.

Einzig beim Übergang von 2018 zu 2019 scheint dies nicht zu funktionieren, denn der 31.12.2018 ist zwar noch zum alten Jahr gehörig, müßte aber dennoch mit der 1 beginnen, macht es aber nicht:

Herzliche Grüße

####

Hallo Herr F.,
ich bin nicht sicher, ob in Excel 2010 bereits der Parameter 21 in der Funktion KALENDERWOCHE vorhanden war. Schauen Sie mal bitte nach – ich habe hier kein Excel 2010. Wenn das nicht der Fall ist, müssen Sie die Funktion ISOKALENDERWOCHE nachbauen. Anleitungen finden Sie im Internet.
schöne Grüße
Rene Martin

####

Hallo Herr Martin,
vielen Dank für Ihre letzte Antwort. Sie haben natürlich recht: mit ISOKALENDERWOCHE läßt sich das Problem beheben.
Wie ist es aber, wenn man Excel 2010 benutzt. Da gibt es diese Funktion nicht. Wie ließe ich hier das Problem lösen, also nur daß vor dem Montag die Kalenderwochenzahl steht?
Herzliche Grüße

####

Hallo Herr Martin,

den Parameter 21 hat Excel 2010 nicht.

Mal sehen, was ich im Internet finde, bisher habe ich nichts gefunden.

Dennoch vielen Dank.

Herzliche Grüße

####

Hallo Herr Martin,

ich muß mich korrigieren. Der Parameter 21 ist in Excel 2010 vorhanden.

Ich habe wie folgt die Funktion geschrieben:

=WENN(WOCHENTAG(B1;2)=1;KALENDERWOCHE(C1;21);„“)

Und es funktioniert auch der Wechsel von der 52. KW 2018 zur KW 1 2019.

Herzliche Grüße

####

Wer nervt mehr? Excel oder Menschen?

Echte Freunde hören nicht nur, was du sagst, sondern verstehen auch, was du meinst.

Letzte Woche in der libreOffice-Calc-Schulung.

Wir üben die Technik des Ziehens und erstellen einen Kalender.

Ein Teilnehmer sagt, dass es bei ihm nicht funktioniere. Ich ahne, was er falsch gemacht hat.

Richtig: er hat nicht „Montag“ in die Zelle eingetragen, sondern „Montag “ – also mit einem Leerzeichen hinter dem Wochentag.

Schnell nachgeschaut: Excel übergeht freundlicherweise diesen Eingabefehler. Und schreibt die weiteren Wochentage ohne Leerzeichen in die Tabelle. Ist hat doch besser als Calc.

Wie doof ist denn das immer noch?

Ich habe es noch einmal ausprobiert: anderer Rechner, anderes Betriebssystem – gleiches Phänomen.

Ich versuche es von Neuem: In A1 steht das Jahr 2017, in B1 der Monat 5. In C1 die Formel

=DATUM($A$1;$B$1;SPALTE()-2)

Rüberziehen bis AG1.

Die Datumsangaben werden als Tag mit TT formatiert.

In C1:AG38 wird folgende bedingte Formatierung verwendet:

=WOCHENTAG(C$1;2)>5

Sieht so aus:

Monatszahl in B1 ändern. Sieht so aus:

Ziele habe ich genug im Leben – nur wenig Munition.

Amüsant. Einer der Verkäufer – Herr Sonntag – wird in einer Pivottabelle nach oben sortiert:

Die Vermutung liegt nahe, dass Excel zuerst Monatsnamen und Wochentage sortiert und dann den „Rest“ alphabetisch. Schön und gut – aber wie bekommt man den Sonntag einsortiert?

Die Antwort findet sich in den „weiteren Sortieroptionen“: Dort muss „Sortiert nach“ – der richtigen Spalte eingeschaltet sein. Und anschließend schaltet man über den Befehl „weitere Optionen“ „bei jeder Berichtsaktualisierung automatisch sortieren“ aus.

Ein weiteres Dankeschön an Pia Bork, die nicht nur das Problem kannte, sondern auch seine Lösung.

Jetzt muss ich mal was Nettes sagen – kann ich auch!

Heute habe ich LibteOffice Calc unterrichtet.

Ein Teilnehmer kopiert eine Liste und fügt sie nicht AUF einer Zelle, sondern IN einer Zelle ein. Das Ergebnis sieht wie folgt aus:

20160919kopieren

Eine Teilnehmerin schreibt „Montag “ (an Ende ein Leerzeichen) in eine Zelle, zieht es nach rechts und wundert sich, warm Calc die Wochentage nicht weiterzählt.

20160919ziehen

Und nun mein Lob an Excel: DIESE beiden Fehler tauchen in der Tabellenkalkulation Excel nicht auf!