Tag Archives: #NULL!

Wenn du beim ersten Date nicht so aussiehst wie die Fotos, die du auf der Dating-Plattform hochgeladen hast, zahlst du so lange die Cocktails, bis du den Fotos ähnlich siehst.

Excelschulung. Wir erstellen Diagramme. Bei mir funktioniert es nicht lautet der Kommentar einer Teilnehmerin:

Ich habe eine Weile gesucht, um herauszufinden, warum die Linie auf dem Nullwert liegt. Die Lösung finde ich in den Optionen:

Die Teilnehmerin hat als Dezimaltrennzeichen den Punkt aktiviert. Dadurch wird die Zahl nicht als Zahl erkannt, sondern als Text. Und da sie die Zellen rechtsbündig formatiert hat … Also – Option ausschalten – und schon funktioniert es:

Wenn ein Mädchen Prinzessin werden will, zeige ich ihr ein Foto von Prinz Charles. Dann will es nicht mehr.

Formatiert man in Word oder PowerPoint ein Zeichen tiefgestellt, markiert anschließend mehrere Zeichen, wird das Kontrollkästchen in den dritten Status (Null) gesetzt – weder tiefgestellt noch nicht tiefgestellt. Erstaunlicherweise auch die Option hochgestellt.

Macht man das in Excel wird nur die Option „hochgestelllt“ „ausgegraut“ ?!?! Übrigens auch bei hochgestellt …


Frauen können das Wort „aha“ auf 42 verschiedene Arten betonen. Neun davon sind sogar tödlich.

Sehr geehrter Herr Martin,  Sie zeigen im Video „Feld einfügen“ wie eine Ja/Nein Spalte bzw. Feld hinzugefügt werden kann. Leider ist mir nicht klar, wie ich den Wert wieder entferne, wenn ich mich „verklickt“ habe. Also weder Ja noch Nein, sondern wieder ein leeres Feld. Diese Info wäre sehr hilfreich. Vielleicht als kleine Ergänzung zum Video.  Vielen DANK! Gruß

Hallo Herr R. weenn Sie in Excel einen Text schreiben, einen Teil markieren und durchgestrichen formatieren, anschließend die Zelle markieren, dann stellen Sie im Zellen-Formatieren-Dialog fest, dass die Option (das Kontollkästchen) „durchgestrichen“ ausgegraut ist – also weder ja noch nein – sondern den dritten Status null verwendet. Dies kann man per Programmierung erreichen – ich wüsste kein System, wo man ja und nein wieder deaktiviert – in Outlook-Formularen leider auch nicht.
sorry
schöne Grüße
Rene Martin

Ich bin heute so romantisch. Ich könnte alle Menschen drücken. Gegen eine Wand. Mit dem Gesicht zuerst.

Amüsant: Überprüft man, ob in einer leeren Zelle der Wert 0 steht, also =A1=0, so lautet das Ergebnis WAHR. Leer wird als 0 interpretiert. Das gleiche Ergebnis erhält man bei der Funktion SUMMENPRODUKT:

=SUMMENPRODUKT((B2:B17>=0)*1)

Die leeren Zellen werden als 0 interpretiert. Anders dagegen ZÄHLENWENN, SUMMEWENN & co – dort ist 0 etwas anderes, wie

=ZÄHLENWENN(B2:B17;“>=0″)

zeigt:

Danke an Dominic Dauphin für diesen Hinweis.

Von Nichts kommt nichts

Ich habe in meinem Beitrag über das „Nichts“ in Excel schon darauf hingewiesen: Excel ist nicht konsequent in der Behandlung von 0, leeren Zelle und „“. Bedauerlicherweise fehlt auch ein Wert NULL, wie er aus Datenbanken bekannt ist. Das stiftet Verwirrung und produziert Probleme.

Ein Liniendiagramm zu erstellen ist nicht schwierig:

Ein einfaches Liniendiagramm

Ein einfaches Liniendiagramm

Schwierig wird es jedoch, wenn die Werte nicht – wie oben – eingegeben wurden, sondern berechnet wurden. Liefert die Formel „“ oder 0, so wird dieser Wert als 0 interpretiert und auf der Achse als 0 angezeigt.

Ich wüsste nur zwei Lösungen, um dies zu umgehen: Per Programmierung (VBA) alle Formeln suchen, die den Wert 0 oder „“ liefern und diese Formeln löschen oder im Diagramm alle Datenpunke durchlaufen. Sollten sie den Wert 0 besitzen, werden sie ausgeblendet (transparent formatiert). Beides ist mit einem Aufwand verbunden, wenn man nicht die Werte oder das Diagramm manuell anpassen möchte.

Ein "unglückliches" Liniendiagramm - Unglücklich, weil in den Jahren 2008 - 2011 keine Werte für den Cash Flow vorlagen. 0 ist also falsch!

Ein „unglückliches“ Liniendiagramm – Unglücklich, weil in den Jahren 2008 – 2011 keine Werte für den Cash Flow vorlagen. 0 ist also falsch!

SUMME rechnet nicht

Kann ich mit der Summe nicht mehrere getrennte Bereiche addieren?

Doch. Aber die Bereiche werden nicht mit einem Leerzeichen, sondern mit einem Semikolon (;) getrennt.

Also – nicht so:

=SUMME(G5:G18 G30:G42 G56:G71 G80:G93)

sondern so:

=SUMME(G5:G18;G30:G42;G56:G71;G80:G93)

Übrigens: das Leerzeichen hat auch eine Funktion – es bedeutet: Schnittmenge. Man könnte berechnen:

=SUMME(C5:H21 G5:G26)

Damit würde die Summe über die Zelle G1:G21 gezogen werden.

Meine Empfehlung – tun Sie das nicht – das versteht kein Mensch, was Sie da tun! Und: wenn die Schnittmenge leer ist, quittiert Excel dies mit der Fehlermeldung #NULL!

Summe rechnet nicht.

Summe rechnet nicht.

Richtige Schreibweise: ; statt Leerzeichen!

Richtige Schreibweise: ; statt Leerzeichen!

Leerzeichen bedeutet Schnittmenge!

Leerzeichen bedeutet Schnittmenge!

Das würde funktionieren; ist aber unverständlich!

Das würde funktionieren; ist aber unverständlich!