Tag Archives: leer

Am zuverlässigsten unterscheiden sich Fernsehprogramme immer noch durch den Wetterbericht. (Woody Allen)

Vor vier Wochen war ich in einer Rechtsanwaltskanzlei und habe gefühlte 15.000 Diagramme bearbeitet. Dabei sind mir eine Reihe an Dingen aufgefallen. Beispielsweise:

Die Daten werden auf Basis anderer Daten erhoben und berechnet. Auf diesen Daten wird ein (Linien-)Diagramm aufgesetzt, das die Entwicklung abbilden soll. Erstaunlicherweise zeigt der Trend im Jahr 2020 nach unten. Der Grund ist einfach: es liegen noch keine Daten für Dezember vor; die Berechnung ergibt 0; die Trendlinie zeigt nach unten. Nein – DIESER Datenpunkt darf nicht verwendet werden.

Sex im Bett ist schon irgendwie eklig. Ich meine, das ist doch der Ort, wo ich esse!

Hallo Rene,
merci für den Screen und deinen Text. Kurz der Hintergrund zu meiner Frage: Ein Kunde fragte vorletzte Woche:
„Wenn er das Dropdown-Dreieck sehe, so würde er dann mindestens zwei Optionen erwarten.
x und ein leerer Eintrag.“
Vermutlich nehme ich deine Lösung: Somit nur das „X“ auswählen, ansonsten muss er den Eintrag eben löschen.
Es wäre überaus nett gewesen, wenn das ganze über das Zellenfeature gegangen wäre …
… ich wollte ggf. auf den Name verzichten.
Dann sind wir ‚mal gespannt, was uns nächste Woche so erwartet.
Ich wünsche dir also einen guten Wochenstart
Jürgen

Hallo Jürgen,
der Kunde ist König!
Meiner gibt sich mit DIESER Lösung zufrieden.

Man könnte aber auch eine Auswahl machen.
Datenüberprüfung: keine Angabe;x

Und dann mit einer Bedingten Formatierung das „keine Angabe“ ausblenden (benutzerdefiniertes Zahlenformat: ;;;

„Und wo bist Du gerade?“ „In der Bredouille!“ „Hach, Frankreich, wie schön!“

Och, Leute – nö! Wie oft muss ich es sagen! Und ich sehe es immer wieder! Gestern zu Beispiel:

Wird in VBA deklariert:

Dim strDateiImport, strDateiExport As String

dann ist strDateExport vom Datentyp String, strDateiImport dagegen vm Typ Variant. Und dies kann zu Problemen führen. Beispielsweise beim Befehl Dir, der zwar „“ verarbeiten kann, aber nicht Leer (Null):

Also bitte:

Dim strDateiImport As String, strDateiExport As String

oder:

Dim strDateiImport As String
Dim strDateiExport As String

Umgekehrt: Quizfrage: was liefern folgende Meldungsfenster:

Dim i, j, k As String

i = 12
j = 3
k = “ Excel kann nerven“

MsgBox i & j
MsgBox i + j

MsgBox i + j & k
MsgBox i + j + k

Ich bin heute so romantisch. Ich könnte alle Menschen drücken. Gegen eine Wand. Mit dem Gesicht zuerst.

Amüsant: Überprüft man, ob in einer leeren Zelle der Wert 0 steht, also =A1=0, so lautet das Ergebnis WAHR. Leer wird als 0 interpretiert. Das gleiche Ergebnis erhält man bei der Funktion SUMMENPRODUKT:

=SUMMENPRODUKT((B2:B17>=0)*1)

Die leeren Zellen werden als 0 interpretiert. Anders dagegen ZÄHLENWENN, SUMMEWENN & co – dort ist 0 etwas anderes, wie

=ZÄHLENWENN(B2:B17;“>=0″)

zeigt:

Danke an Dominic Dauphin für diesen Hinweis.