Tag Archives: Leerer String

Ich spüre das Tier in mir. Es ist ein kleines Faultier.

Manchmal verblüfft mich Excel. Beziehungsweise Phänomene, die ich noch nie bemerkt habe.

Man erstelle eine Funktion, die einen leeren Wert zurückgibt, beispielsweise

=WENN(A1=“Januar“;1;““)

Man markiere die Spalte mit den Formeln, kopiere sie und fügen sie als Werte ein.

Mit [Strg] + [↓] springt Excel zu letzten (leeren?) Zelle. Stoppt nicht bei den Zahlen. Überspringt die vermeintlich leeren Zellen. Man sieht zwar nichts, aber die Funktion =ISTLEER liefert den Wert FALSCH. Diese Zellen sind nicht leer.

Headlines nerven

In der letzten Excelschulung.

Wir verknüpfen zwei Arbeitsblätter. Ich ziehe den Bezug =ErstesBlatt!ErsteZelle herunter. Da ich nicht weiß wie weit, schieße ich weit übers Ziel hinaus. Das Ergebnis sind Nullen.

Ich frage die Teilnehmer, wie man die Nullen unterdrücken kann. Ich erhalte die Antwort: „in den Optionen“. Richtig: Dort kann man in Datei / Optionen / Erweitert in der Kategorie „Optionen für dieses Arbeitsblatt anzeigen“ die Einstellung „In Zellen mit Nullwert eine Null anzeigen“ ausschalten.

Ich erkläre, dass diese Option nicht immer geschickt ist, denn so werden SÄMTLICHE Nullen unterdrückt. Ich möchte es gerne lokal unterbinden.

Wenn ich solche Fragen stelle, erwarte ich eine Antwort. Erwarte ich WENN(=““. Ein Teilnehmer meldet sich und antwortet: „Mit der Funktion ISTLEER“. Ich bin verblüfft. Damit habe ich nicht gerechnet. Stimmt – ISTLEER prüft das Gleiche wie =““. Wirklich? Wir testen es und stellen natürlich kleine Unterschiede fest. Wenn in der Zelle ein Fehler ist. Oder beispielsweise ein leerer String:

=““

Wir lernen – was auf den ersten Blick gleich aussieht, muss nicht unbedingt gleich sein …

Von Nichts kommt nichts

Ich habe in meinem Beitrag über das „Nichts“ in Excel schon darauf hingewiesen: Excel ist nicht konsequent in der Behandlung von 0, leeren Zelle und „“. Bedauerlicherweise fehlt auch ein Wert NULL, wie er aus Datenbanken bekannt ist. Das stiftet Verwirrung und produziert Probleme.

Ein Liniendiagramm zu erstellen ist nicht schwierig:

Ein einfaches Liniendiagramm

Ein einfaches Liniendiagramm

Schwierig wird es jedoch, wenn die Werte nicht – wie oben – eingegeben wurden, sondern berechnet wurden. Liefert die Formel „“ oder 0, so wird dieser Wert als 0 interpretiert und auf der Achse als 0 angezeigt.

Ich wüsste nur zwei Lösungen, um dies zu umgehen: Per Programmierung (VBA) alle Formeln suchen, die den Wert 0 oder „“ liefern und diese Formeln löschen oder im Diagramm alle Datenpunke durchlaufen. Sollten sie den Wert 0 besitzen, werden sie ausgeblendet (transparent formatiert). Beides ist mit einem Aufwand verbunden, wenn man nicht die Werte oder das Diagramm manuell anpassen möchte.

Ein "unglückliches" Liniendiagramm - Unglücklich, weil in den Jahren 2008 - 2011 keine Werte für den Cash Flow vorlagen. 0 ist also falsch!

Ein „unglückliches“ Liniendiagramm – Unglücklich, weil in den Jahren 2008 – 2011 keine Werte für den Cash Flow vorlagen. 0 ist also falsch!