Tag Archives: leere Zelle

Meine Oma ist Griechin. Fetalicherseits.

Hallo René,

jetzt mein kleines Excel-Phänomen, ein etwas interessantem Verhalten von Excel im Bezug auf Leerzellen, die nicht leer sind.

Natürlich habe ich deinen Artikel „Excel und das Nichts“ gelesen, ich denke, das folgende Phänomen geht in diese Richtung.

Bin mal gespannt, ob du das auch schon so gesehen hast.

Wir wollten ein paar ganz simple X-Y-Punktdiagramme erstellen bzw. ein Kollege ruft mich an, „Ich kann kein korrektes Punkt-Diagramm erstellen, das gibt’s doch nicht!“.

Der Datenbereich für die Y-Achse weist einige Leerzellen auf (die sind aber egal), die X-Achse hatte zunächst eine durchgehende Datenreihe, also ohne Lücken.

Dann wollten wir für ein 2. Diagramm eine andere Spalte als X-Achse nehmen (Spalte I). Excel erstellte nun aber nicht ein Punktdiagramm, welches die beiden Datenreihen als X-Y-Kombination zeigte, sondern „zählte“ sozusagen hoch, begann bei 1 und endete bei 54 (Ende der Datenreihe).

Beispiel: 66,67 wäre der eigentlich Wert, es wurde aber die 37 (es war der 37ste Wert in der Spalte) als X-Wert genommen.

Die Ursache war recht schnell gefunden, es gab eine leere Zelle in der Datenreihe, die aber doch nicht ganz leer war: Tippe in Zelle I16 und drücke „entf“ und beobachte, wie sich das Diagramm verändert.

Die Entstehungsgeschichte der Leerzelle, die nicht ganz leer ist, ist auch ganz interessant:

  1. Mittels „Wennfehler(XXX, ““) zu einem „Gänsefüßchen-Leer gemacht
  2. Mittels Powerquery à Aus Datei à Aus Ordner abgerufen und zusammengeführt (PowerQuery zeigt auch nicht „null“ für die Zelle an)
  3. Mittels copy+paste irgendwo anders hin kopiert.

Dominic Dauphin

####

Hübsch! Sehr hübsch!

Hallo Dominic,

das „Hochzählen“ kommt daher, dass Excel keine Werte mehr erkennt, sondern Texte. Wenn du die Werte der x-Achse a, b, c, … nennst, vergibt Excel auch eine fortlaufende Nummer.

Du hast eine Funktion vergessen:

=ISTTEXT

Sie liefert WAHR!

Ich erhalte deine Zelle auch, indem ich in eine Zelle

=““

Schreibe, die Zelle kopiere und dann als Wert einfüge …

Wirklich sehr hübsch!

Liebe Grüße Rene

Männer schnarchen, um ihre Frauen vor wilden Tieren zu beschüzen. Frauen habe kalte Füße, um die wilden Tiere direkt zu töten.

Gestern habe ich ein Referat über „leere Zellen“ gehalten. Ich habe gezeigt, dass man eine leere Zelle durch einen Wert ersetzen kann – beispielsweise durch 0:

Klappt: der Suchen und Ersetzen-Dialog tut gute Dienste:

Sieben leere Zellen werden mit der Zahl 0 gefüllt.

Auch umgekehrt funktioniert es: Ersetze 0 durch „nichts“, also leere Zellen, in denen die Zahl 0 steht:

Ich stutze: warum werden jetzt zehn Änderungen vorgenommen?

Klar – ersetzt werden nicht die Zellen, in denen die Zahl 0 steht, sondern die Ziffer 0 wird gelöscht. Auch 70 wird 7. Kurz überlegt.

Klar: man muss die Option „Gesamten Zellinhalt vergleichen“ aktivieren:

Dann funktioniert auch das.

Schaue immer auf Deinen Charakter, denn um Deinen schlechten Ruf kümmern sich schon die Anderen

Eine Liste mit Zahlen, die im Zahlenformat „Standard“ gespeichert sind, mit mehr Nachkommastellen zu formatieren ist nicht schwierig. Schwierig wird es dagegen, wenn die erste markierte Zelle (also die aktive Zelle) leer ist – dann verweigert Excel dieses Zahlenformat.

Dabei ist es gleichgültig, ob man die leere Zelle darüber oder darunter verwendet. Man muss zuerst das Zahlenformat „Zahlenformat“ einschalten (früher hieß es „Zahl“). Dann klappt es. Ich wollte schon über leere Zellen schimpfen – allerdings: befindet sich in der aktiven Zelle Text, verweigert Excel ebenso Dezimalstellen hinzuzufügen oder zu entfernen.

Und das ist der Grund, warum man bei langen Kolonnen mit einer Überschrift zuerst das Zahlenformat ändern muss, bevor man mehr (oder weniger) Dezimalstellen hinzufügen kann.

Headlines nerven

In der letzten Excelschulung.

Wir verknüpfen zwei Arbeitsblätter. Ich ziehe den Bezug =ErstesBlatt!ErsteZelle herunter. Da ich nicht weiß wie weit, schieße ich weit übers Ziel hinaus. Das Ergebnis sind Nullen.

Ich frage die Teilnehmer, wie man die Nullen unterdrücken kann. Ich erhalte die Antwort: „in den Optionen“. Richtig: Dort kann man in Datei / Optionen / Erweitert in der Kategorie „Optionen für dieses Arbeitsblatt anzeigen“ die Einstellung „In Zellen mit Nullwert eine Null anzeigen“ ausschalten.

Ich erkläre, dass diese Option nicht immer geschickt ist, denn so werden SÄMTLICHE Nullen unterdrückt. Ich möchte es gerne lokal unterbinden.

Wenn ich solche Fragen stelle, erwarte ich eine Antwort. Erwarte ich WENN(=““. Ein Teilnehmer meldet sich und antwortet: „Mit der Funktion ISTLEER“. Ich bin verblüfft. Damit habe ich nicht gerechnet. Stimmt – ISTLEER prüft das Gleiche wie =““. Wirklich? Wir testen es und stellen natürlich kleine Unterschiede fest. Wenn in der Zelle ein Fehler ist. Oder beispielsweise ein leerer String:

=““

Wir lernen – was auf den ersten Blick gleich aussieht, muss nicht unbedingt gleich sein …

Heute lebe ich. Morgen putze ich vielleicht.

Ich habe mich heute sehr amüsiert. Ich war in einer großen Firma, die Sie auch kennen. Dort haben mir Mitarbeiter eine große Exceltabelle gezeigt, mit der Bitte, ihnen die Formeln zu erklären und möglicherweise zu verbessern. Das Grundproblem tauchte an sehr vielen Stellen auf: In zwei unterschiedlichen Spalten stehen Datumsangaben. Allerdings: nicht in jeder Zelle.

Es sollen die Datumsdifferenzen berechnet werden. Allerdings nicht Ende – Anfang, da die leeren Zellen ein Ergebnis verfälschen würden. Nun hat ein Kollege – wahrscheinlich über Jahre – verschiedene Formeln eingetragen:

  • =WENN(D2>=1;D2-C2;““)

Ist okay – hier habe ich nichts zu nörgeln.

  • =WENN(D2>=1;D2-C2;“ „)

Das Leerzeichen stört mich; würde ich nicht machen – besser: „“.

  • =WENN(D2>=1;DATEDIF(C2;D2;“d“);““)

Warum einfach, wenn es auch umständlich geht. D2-C2 entspricht DATEDIF(C2;D2;“d“).

  • =WENNFEHLER(D2-C2;““)

Ganz schlecht: D2-C2 liefert keinen Fehler, wenn eine der beiden Zellen leer ist. Das Ergebnis ist beispielsweise -42780.

  • =WENN(ISTFEHLER(D2-C2);““;D2-C2)

Bis Excel 2003 gab es noch nicht die Funktion WENNFEHLER – bis dahin musste man WENN(ISTFEHLER(… schreiben. Falsch und überflüssig!

  • =WENN(UND(C2<>““;D2<>““);D2-C2;““)

Gut: beide Zellen werden überprüft!

Die Funktion ISTZAHL habe ich in der Tabelle nicht gefunden.

Wir haben uns amüsiert, weil das gleiche Problem von einem Anwender auf verschiedene Arten gelöst wurde. Das ist nicht konsistent und auch nicht nachzuvollziehen. Aber man kann ja mal vermuten, was die Ursache des Formelwandels war …