Von Nichts kommt nichts

Ich habe in meinem Beitrag über das „Nichts“ in Excel schon darauf hingewiesen: Excel ist nicht konsequent in der Behandlung von 0, leeren Zelle und „“. Bedauerlicherweise fehlt auch ein Wert NULL, wie er aus Datenbanken bekannt ist. Das stiftet Verwirrung und produziert Probleme.

Ein Liniendiagramm zu erstellen ist nicht schwierig:

Ein einfaches Liniendiagramm

Ein einfaches Liniendiagramm

Schwierig wird es jedoch, wenn die Werte nicht – wie oben – eingegeben wurden, sondern berechnet wurden. Liefert die Formel „“ oder 0, so wird dieser Wert als 0 interpretiert und auf der Achse als 0 angezeigt.

Ich wüsste nur zwei Lösungen, um dies zu umgehen: Per Programmierung (VBA) alle Formeln suchen, die den Wert 0 oder „“ liefern und diese Formeln löschen oder im Diagramm alle Datenpunke durchlaufen. Sollten sie den Wert 0 besitzen, werden sie ausgeblendet (transparent formatiert). Beides ist mit einem Aufwand verbunden, wenn man nicht die Werte oder das Diagramm manuell anpassen möchte.

Ein "unglückliches" Liniendiagramm - Unglücklich, weil in den Jahren 2008 - 2011 keine Werte für den Cash Flow vorlagen. 0 ist also falsch!

Ein „unglückliches“ Liniendiagramm – Unglücklich, weil in den Jahren 2008 – 2011 keine Werte für den Cash Flow vorlagen. 0 ist also falsch!

4 comments

  • Michaela

    Lieber Kollege,

    schon mal an #NV gedacht? Auch in einer Berechnung als Textausgabe perfekt für zu Null laufende Daten im Liniendiagramm.

    Ansonsten köstlich Dein Input.
    Ich amüsiere mich sehr.

    Ganz liebe Grüße

    • Medardus

      Guter Gedanke, Michaela,
      allerdings: in diesem Beispiel ging es dem Kunden um Daten, die er regelmäßig bekommt. Okay – Du wirst jetzt sagen – „aufbereiten muss er sie halt irgendwie“. Okay. Und ein bisschen gruselig: einen Fehler als nix und Null zu verwenden. Umgekehrt: der Gedanke hat etwas. Danke für den Hinweis.
      lG :: Rene

    • Raffo

      Ich hatte auch genau dieses Problem wie im Artikel beschrieben. Mit den Liniendiagrammen und der fehlenden Option, bei einer Berechnung (z.B: =WENN(A1=A2;A1;..nichts?…)) einen echten Leer-/NULL-Wert zu verwenden. Danke für den Tipp im Kommentar Michaela. Mit #NV sieht zwar jetzt meine Tabelle grausam aus, aber das Diagramm tut, was es soll!! 😀

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.