Tag Archives: Englisch

Entschuldigt bitte meine Fehler, es ist mein erstes Leben .

Inga meint, dass es gefährlich ist mit VBA bedingte Formatierungen zu programmieren. Warum? Ich zeichne mit dem Makrorekorder auf – wie lautet der Befehl: „färbe die aktuelle Zelle blau, wenn in A1 das heutige Datum steht“?

Sub HeuteMachenWirBlau()
Selection.FormatConditions.Add Type:=xlExpression, Formula1:=“=A1=HEUTE()“
Selection.FormatConditions(Selection.FormatConditions.Count).SetFirstPriority
With Selection.FormatConditions(1).Interior
.PatternColorIndex = xlAutomatic
.Color = 12611584
.TintAndShade = 0
End With
End Sub

Ich teste – klappt! Ich überlege mir: es wäre besser statt HEUTE TODAY zu schreiben; teste – klappt nicht mehr.

Das heißt: die Formeln laufen nur lokal – man müsste nun die einzelnen Sprachen unterscheiden, damit das Makro mehrsprachig funktioniert. Das ist die Hölle.

Danke an Inga Birk für den Hinweis.


Gestern war hier noch aufgeräumt. Echt schade, dass du’s verpasst hast.

Das ist widerlich, böse und gemein!

Ich finde auf meiner Festplatte eine Dummy-Datei, die die Firma Microsoft zur Verfügung stellt: ORGDATA.XLS. Darin sind einige Namen enthalten. Ich öffne sie:

In dieser Datei war festgelegt, dass die Z1S1-Bezugsart verwendet werden soll (Datei / Optionen / Formeln). Ich schließe die Datei, beende Excel und starte Excel erneut. Die Einstellung dieser Datei wird mir nun als Grundeinstellung angezeigt – statt

A  |  B  |  C  |  D  |  E …

in den Spaltenköpfen erhalte ich:

1  |  2  |  3  |  4  |  5 …

Ich muss über Datei / Optionen / Formeln die Bezugsart ändern oder eine meiner „deutschen“ Dateien öffnen – dann ist der Spuk weg.

Ich habe es ausprobiert – umgekehrt genauso: ich ändere die Sprache auf englisch, schalte auf Z1S1 um, öffne eine deutsche, sprich: A1-Datei, – schwupp – und weg ist der Z1S1-Quatsch.

 

Jeden Morgen stelle ich mit die gleiche Frage: „Wer bin ich und wieso so früh?“

Nö – da müssen die noch einmal ran! Entweder Deutsch oder Englisch. Aber bitte nicht beides.

Bitte nicht Fett – italic – Unterstrichen

Bitte nicht das $-Symbol als Zeichen für Währung oder Buchhaltung:

Und bitte kein Komma als Tausendertrennzeichen. In Europa verwenden wir den Punkt (oder das Leerzeichen oder das Apostroph)

Gesehen: in Excel online

i am not weird i am a limited edition

Es ist so schrecklich! Eigentlich ist das Problem einfach: eine Mitarbeiterin möchte wissen, ob beim Anwender Excel die deutsche oder englische Oberfläche eingeschaltet hat. Per VBA wäre dies kein Problem; allerdings wollen wir eine Lösung entwickeln, die auf Formeln basiert.

Wir beginnen:

=WENN(TEXT(DATUM(2018;1;1);“MMMM“)=“Januar“;“de“;“en“)

Wenn der erste Monat des Jahres „Januar“ heißt, bin ich Deutsch. Test: Excel wird auf englisch umgestellt:

Klar. die Ländereinstellung der Systemsteuerung ist noch immer „deutsch“ – deshalb ist der erste Monat Januar. Blöd zum Testen!

Zweiter Versuch:

=IF(ISERROR(TEXT(TODAY();“dddd“));“de“;“en“)

zeigt „en“ an. Bei der deutschen Oberfläche ebenso. Der Grund:

TEXT(HEUTE();“dddd“)

liefert „dddd“?!? Und eben keinen Fehler.

Noch ein Versuch:

=IF(ISERROR(INFO(„DIRECTORY“));“de“;“en“)

Auch hier weigert sich Excel hartnäckig „deutsch“ zu werden. Der Grund:

INFO(„DIRECTORY“)

funktioniert auch im Deutschen korrekt. Erst

=WENN(ISTFEHLER(INFO(„VERZEICHNIS“));“en“;“de“)

klappt. Das englische Excel kennt „VERZEICHNIS“ nicht. Zum Glück ist diese Funktion volatil, das heißt: wird beim Start von Excel neu berechnet.

Mehrsprachige Umgebungen sind die Hölle! Nicht nur in Excel … Und: das oben genannte Beispiel ist nur Spitze des Eisberges.

Breakfast is the most important drink of the day!

Hallo Renè,

kannst du mir bitte wieder helfen?

Es dreht sich um das Datum.

Aus dem Internet habe ich diese Tabelle kopiert. Einmal wird ein richtiges Datum und dann ein Datum in Textformat angezeigt. Bei der Textform fehlt nach dem Tag der Punkt.

Die Formatierung soll natürlich österreichisch sein ;-).  Datum und Uhrzeit von dir haben mir bei dieser Tabelle auch nicht weiter geholfen. Zumindest habe ich nichts entdeckt.

Die Liste wird mit einer anderen verglichen um zu sehen ob der Start gemeldet wurde.

Bedanke mich für deine Unterstützung,

mit bestem Gruß

Peter

Hallo Peter,

hübsche Fingerübung. Kommst du mit der Lösung klar?

In Spalte E steht das Datum als Datum; in F als Text.

Übrigens: Hübsches Problem – da im Englischen April, August, September und November genauso heißen wie bei uns, machen diese Monate keine Probleme.

schöne Grüße aus dem Land, wo die Jänners Januare heißen

Rene

Die rechte Formel sieht wie folgt aus:

{=TEXT(WENN(ISTZAHL(D2);D2;DATUM(RECHTS(D2;4);VERGLEICH(TEIL(D2;SUCHEN(“ „;D2)+1;LÄNGE(D2)-8);{„January“;“February“;“March“;“April“;“May“;“June“;“July“;“August“;“September“;“October“;“November“;“December“};0);LINKS(D2;2)));“TT.MMM JJJJ“)}

die linke ohne die Funktion TEXT.

Pia ist sehr genervt. Und ich amüsiere mich. Nicht über Pia, sondern über Microsoft. Und über Excel.

Pia hat mich darauf aufmerksam gemacht. Auf der Microsoft-Seite

Excel-Funktionen

findet sich folgende amüsante Sortierung:

20161211sortfunktion

Wieso findet man PIVOTDATENZUORDNEN, gefolgt von VARIATIONEN, bei dem Buchstaben G? Nicht nur dort – das ganze Alphabet ist „korrupt“. Ein Blick auf die englischen Funktionsnamen (man erhält sie mit dem Makrorekorder oder auf der Seite Mit dem Excel Translator oder einer beliebigen anderen Seite, die die Begriffe mehrsprachig auflistet. Sie heißen: GETPIVOTDATA und GROWTH.

Kommentar: Und nebenbei: was soll eigentlich diese Schwachsinnsseite? Da kommt genau der gleiche Mini-Kurz-Text wie bei der Funktion. Das sind keine „Weiteren Hinweise“, das ist überflüssig wie ein Kropf. WIE genervt ich bin!