Tag Archives: #Wert!

Bei Hagenbeck gewesen. Drei Stunden im Streichelzoo gestanden – nix passiert! Selbst die dicke Ziege wurde mehr befummelt als ich!

Man muss einfach immer genau hinschauen. Immer!

Ich habe eine Excelliste, in der trage ich Informationen zu meinen Schulungen ein. Ich habe eine Spalte „Stunden außerhalb“, in der ich bislang Texte eingetragen habe wie „2 x 24“ oder „3 x 10“. Nun hätte ich gerne die Summe der Tage ermittelt, also die Zahlen, die vor dem „x“ stehen summiert. Nichts leichter als das:

=LINKS(I351;SUCHEN(„x“;I351)-2)

liefert die Zahlen. Allerdings: steht kein Text in der Zelle, so liefert SUCHEN(„x“;I351) einen Fehler. Der kann bequem mit WENNFEHLER abgefangen werden:

=WENNFEHLER(LINKS(I351;SUCHEN(„x“;I351)-2);““)

Das Ergebnis:

Darauf setzte ich eine Pivottabelle auf und ändere den Vorschlag „ANZAHL“ in „SUMME“:

Eine Fehlermeldung ist die Folge. Vielleicht hängt es mit dem „“ der Funktion WENNFEHLER zusammen? Ich ändere die Formel in:

=WENNFEHLER(LINKS(I351;SUCHEN(„x“;I351)-2);0)

Die leeren Zellen werden mit einer „0“ aufgefüllt. Sieht nicht schön aus. Also ändere ich das Zahlenformat in ein benutzerdefiniertes:

0;-0;;

Und wundere mich erneut. Alles ist weg!

Langsam dämmert es mir: klar – die Funktion LINKS liefert einen Text. Das heißt: der Text „2“ wird durch das benutzerdefinierte Zahlenformat weggeblendet. Und: Excel erkennt keine Zahlen für die Pivottabelle, die summiert werden könnten. Also noch einmal die Formel anpassen. Der Text muss in eine Zahl konvertiert werden: mit WERT, mit „–“ oder mit „*1“

=WENNFEHLER(WERT(LINKS(I351;SUCHEN(„x“;I351)-2));0)

Und dann kann die Pivottabelle auch summieren:

Aktualisieren nicht vergessen!

Ich muss nich immer im Mittelpunkt stehen … sitzen is auch okay

Schon perfide: Ich verbinde zwei Zellen miteinander („verbinden und zentrieren“). Ich speichere die Datei unter dem Namen „RenesTest.xlsx“. Ich verweise von einer anderen Datei auf die verbunden Zelle(n) und erhalte als Bezug:

=[RenesTest.xlsx]Tabelle1!$B$5

Ich speichere die Datei unter dem Namen „Test Rene.xlsx“. Erneut ein Bezug auf die verbundenen Zellen. Nun erhalte ich:

='[Test Rene.xlsx]Tabelle1′!$B$5:$C$5

was nach Bestätigung mit dem Fehler #WERT! quittiert wird. Erstaunlich, dass bei einem Leerzeichen im Dateiname der Bezug auf die verbunden Zellen aufgelöst wird, während bei einem Dateinamen ohne Leerzeichen der Bezug auf eine Zelle erfolgt!

Fazit: Besser nicht „verbinden und zentrieren!“ Das bringt nur Ärger!

Ich bin schon mit dem Besten zufrieden…

Manche Übersetzungen sind wirklich sehr merkwürdig.

In der letzten Excel-Schulung fragte eine Teilnehmerin, was folgende Erklärung bedeutet:

Text: „ist die Zeichenfolge mit den Zeichen, die Sie kopieren wollen“

Noch erstaulicher ist die Beschreibung für die Funktion T:

T „wandelt die Argumente in Text um.“ T benötigt  einen Wert, „den Sie überprüfen wollen. Wenn der Wert kein Text ist, werden zwei Anführungsstriche (leerer Text) zurück gegeben.“

Versteht ihr das?

Microsoft hat Besserung gelobt – mal sehen …

Was denn Excel zusammengefügt hat, soll ein Mensch nicht scheiden.

Hallo. Ich brauche einen Tipp. Ich erhalten einige Male im Jahr eine Tabelle mit vielen Zahlen. Da die Zeilen keine eindeutige ID haben, habe ich mit der Funktion VERKETTEN mehrere Felder konkateniert (zusammengefasst), so dass ich eine ziemlich eindeutige ID habe. Ich wollte diese Formel weiter runterziehen, weil sich die Liste ab und zu erweitert. Jedoch – Excel zeigt in den leeren Zeilen Fehler. Das verstehe ich nicht: leer & leer & leer müsste doch leer sein, oder?

VERKETTEN - klappt gut, aber irgendwann mit Fehler

VERKETTEN – klappt gut, aber irgendwann mit Fehler

Die Antwort: Sie haben die Tabelle in eine „intelligente Tabelle“ verwandelt (Einfügen / Tabellen / Tabelle). Die Formel in der Zelle lautet:

=VERKETTEN(Tabelle1[@ProdH];Tabelle1[@[BG Cd]];Tabelle1[@[BD / BU]];Tabelle1[@[Main Hier. Name]];Tabelle1[@[Sold-to party]];Tabelle1[@[MAT15 Nbr]];Tabelle1[@[DQ Conf]])

also: Tabellenname Tabelle1[Spaltenname]. Das impliziert: gleiche Zeile wie Formelzelle.

Allerdings befindet sich keine Tabelle neben den neuen Zellen unterhalb der Tabelle. Wenn es Sie stört, können Sie um die Funktion die Formel WENNFEHLER bauen, also:

=WENNFEHLER(VERKETTEN(Tabelle1[@ProdH];Tabelle1[@[BG Cd]];Tabelle1[@[BD / BU]];Tabelle1[@[Main Hier. Name]];Tabelle1[@[Sold-to party]];Tabelle1[@[MAT15 Nbr]];Tabelle1[@[DQ Conf]]);““)

Oder Sie schreiben den Zellbezug „per Hand“ in die Formel:

=VERKETTEN(B1;C1;D1;G1;J1;L1;T1)

Dann erhalten Sie auch keine Fehler.