Tag Archives: Funktionsassistent

Lieber Gott, schmeiß Hirn vom Himmel, oder Steine. Hauptsache du triffst.

Man hat mich wieder gezwungen libreOffice Calc zu unterrichten. Je häufiger ich es unterrichte, desto mehr liebe ich Microsoft Excel. Beispiel:

Ich erkläre den Funktionsassistenten. Ich wundere mich, dass dort die Tastenkombination [Umschalt] + [Strg] + [↑] nicht funktioniert. In der Tabelle erlaubt diese Tastenkombination größere Bereiche zu markieren.

Es gehen weitere Tasten leider auch nicht: [Umschalt] + [F4] um von einem relativen Bezug zu einem absoluten umzuschalten. Oder folgendes Ärgernis: Klickt man auf eine Zelle, muss man den Cursor danach explizit hinter die Markierung setzen, sonst wird sie bei dem nächsten Zeichen (beispielsweise „>“) überschrieben:

Eine amüsante Anmerkung: Gestern schrieb eine Teilnehmer*in in die Beurteilung:
»Das Thema ist für einen Unterrichtstag sehr komplex, man sollte gut ausgeschlafen sein.«

Ich brauche keinen Mittelfinger, ich kann das mit den Augen.

Heute in der Excel-Schulung. Ein Teilnehmer zeigt mir seine Lösung, wie er die Anzahl der Zahlen im 90er-Bereich ermittelt hat: Er berechnet die Differenz zweier ZÄHLENWENN-Funktionen:

=ZÄHLENWENN(C8:C37;“<100″)-ZÄHLENWENN(C8:C37;“<90″)

Ich zeige seinen Ansatz der Gruppe. Mit dem Funktionsassistenten rufe ich Zählenwenn auf:

Schritt 1

Schritt 1

Normalerweise trägt Excel im Funktionsassistenten um die Bedingung <100 automatisch die Anführungszeichen ein. Jedoch ein Klick in die Bearbeitungsleiste lehrt mich eines Besseren:

Schritt 2

Schritt 2

Ich fahre fort: tippe ein Minus und rufe erneut den Funktionsassistenten auf:

Schritt 3

Schritt 3

Der Blick in die Bearbeitungsleiste zeigt mir, dass die Anführungszeichen in der ersten Funktion fehlen. Und richtig: Das Bestätigen der Funktion wird mit einer Fehlermeldung quittiert:

Schritt 4

Schritt 4

Schade – denn gerade der Funktionsassistent nimmt Anwendern und Anwenderinnen, die mit Formeln noch nicht so sehr geübt sind, die Arbeit an vielen Stellen ab …

Also doch: Ich zeige dem Teilnehmer ZÄHLENWENNS, die ihm sehr gut gefällt …

kon·se·quent [ˌkɔnzeˈkvɛnt]

Nein, konsequent ist Excel nicht. An einigen Stellen muss man bei Texten Anführungszeichen eintragen, bei einigen kann man an anderen Stellen wiederum darf man nicht.

Ich habe im Artikel

Die bedingte Formatierung funktioniert nicht

darauf hingewiesen. Bei der Funktionseingabe ist Excel auch inkonsequent:

Während man bei Tippen einer Funktion immer die Anführungszeichen eingeben muss, muss man es im Funktions-Assistenten nicht. Das Wort Achtung wird beim Verlassen des Textfeldes umgewandelt in „Achtung“. Jedoch: Wenn man im Funktionsassistenten eine innere Funktion einträgt, beispielsweise

und(B2=Fotografie;G2>100)

wird dies mit einer Fehlermeldung quittiert. Nicht konsequent, oder?

Manchmal muss man, manchmal muss man eben nicht.

Manchmal muss man, manchmal muss man eben nicht.

Meine Empfehlung: Wenn Sie nicht wissen, ob man muss oder nicht: Tragen Sie die Anführungszeichen ein.