Tag Archives: Bedinung

Ich bin Neptun, Herr des Wassers! Spürt meine Macht, ihr Untertanen! – Alter, hör auf, meine Goldfische mit einer Gabel zu jagen!

Einfach nicht aufgepasst. Dabei weiß ich das eigentlich!

In einem großen, langen VBA-Programm werden Daten aus verschiedenen Dateien des gleichen Ordners, in dem sich die Datei mit dem Code befindet, zusammengefasst. Diese Dateien soll geöffnet werden, Inhalt herauskopiert und danach wieder geschlossen werden.

Ich überprüfe im ersten Schritt, ob es sich um eine XLSM oder XLSB-Datei handelt, denn nur dort liegen die gesuchten Daten:

If Right(strDatei, 4) = "xlsm" Or Right(strDatei, 4) = "xlsb" Then

Klappt wunderbar.

Fast.

Denn auch die Datei, in der sich der Code befindet, wird bearbeitet, also geschlossen. Das ist nicht Sinn der Sache. Also schließe ich aus:

If Right(strDatei, 4) = "xlsm" Or Right(strDatei, 4) = "xlsb" And strDatei <> ThisWorkbook.Name Then

und wundere mich, warum es nicht funktioniert. Die aktuelle Datei wird immer noch geschlossen. Seltsam.

Ich prüfe:

der Inhalt von strDatei entspricht ThisWorkbook.Name. Warum fließt diese Abfrage in die Bedingung, warum wird sie ausgewertet, oder genauer: warum liefert die IF-Verzweigung den Wert Wahr? Es dauert ein paar Sekunden, dann dämmert es mir:

AND ist stärker als OR. Die IF-Verzeigung überprüft, ob die Datei strDatei die Endung XLSB hat UND die gleiche Datei ist. Nein – ich laufende Datei habe die Endung XLSM. Oder: hast du die Endung XLSM? ja – DAS ist korrekt. Also wird die Bedingung ausgewertet. *ggrrrrr* Also noch einmal – diesmal mit Klammer:

If (Right(strDatei, 4) = "xlsm" Or Right(strDatei, 4) = "xlsb") And strDatei <> ThisWorkbook.Name Then

Und das funktioniert! Ich bin glücklich!

Ich brauche keinen Mittelfinger, ich kann das mit den Augen.

Heute in der Excel-Schulung. Ein Teilnehmer zeigt mir seine Lösung, wie er die Anzahl der Zahlen im 90er-Bereich ermittelt hat: Er berechnet die Differenz zweier ZÄHLENWENN-Funktionen:

=ZÄHLENWENN(C8:C37;“<100″)-ZÄHLENWENN(C8:C37;“<90″)

Ich zeige seinen Ansatz der Gruppe. Mit dem Funktionsassistenten rufe ich Zählenwenn auf:

Schritt 1

Schritt 1

Normalerweise trägt Excel im Funktionsassistenten um die Bedingung <100 automatisch die Anführungszeichen ein. Jedoch ein Klick in die Bearbeitungsleiste lehrt mich eines Besseren:

Schritt 2

Schritt 2

Ich fahre fort: tippe ein Minus und rufe erneut den Funktionsassistenten auf:

Schritt 3

Schritt 3

Der Blick in die Bearbeitungsleiste zeigt mir, dass die Anführungszeichen in der ersten Funktion fehlen. Und richtig: Das Bestätigen der Funktion wird mit einer Fehlermeldung quittiert:

Schritt 4

Schritt 4

Schade – denn gerade der Funktionsassistent nimmt Anwendern und Anwenderinnen, die mit Formeln noch nicht so sehr geübt sind, die Arbeit an vielen Stellen ab …

Also doch: Ich zeige dem Teilnehmer ZÄHLENWENNS, die ihm sehr gut gefällt …