Tag Archives: LÄNGE

Schau mich nicht in diesem Ton an!

Hallo Her Martin,

ich bin auf der Suche nach einer Info zu Excel auf ihre Seite „https://www.excel-nervt.de/das-nichts-in-excel/

gekommen und habe folgende (aus meiner Sicht) falsche Aussage gefunden: 

zuerst der betreffende Textabschnitt:

———–

Text, leerer Text oder kein Text

Ähnlich wie bei Zahlen geht Excel bei Texten vor. Eine Zelle kann leer sein, kann Text oder eine leere Zeichenkette beinhalten. Letzteres kann das Ergebnis einer Funktion sein oder auch direkt eingegeben werden:

=““

Die folgenden drei Abfragen liefern dann WAHR als Ergebnis:

=WENN(ISTLEER(A1);…

=WENN(A1=““;…

=WENN(ISTTEXT(A1);…

———–

Wenn ich aber einer Zelle A1 den Wert „“ (also leeren String) zugewiesen habe, liefert mir die Formel

=WENN(ISTLEER(A1);…

leider nicht den Wert wahr, sondern falsch. Die Zelle wird nicht als „leer“ erkannt.

Hiermit habe ich übrigens genau ein Problem. Ich habe nämlich das „ISTLEER“ oft benutzt und zu spät bemerkt, daß es nicht wie erwartet funktioniert. Jetzt versuche ich, die Formeln zu ändern (z.B. durch Abfrage auf Länge = 0) und die vorhandenen „“ aus Wertfeldern zu eliminieren. Leider habe ich für beides bisher noch keine ganz einfache, schnelle und sichere Vorgehensweise gefunden.

Mit freundlichen Grüßen

Michael Richter

Hallo Herr Richter,

    ich freue mich immer sehr, wenn Leserinnen und Leser auf meine Artikel reagieren – Kritik äußern, Dinge korrigieren, die ich falsch behauptet habe oder Lob äußern.

    Sie haben recht – die Artikel, die Sie unter „über“ und „schade“ finden, sind recht alt und sollten überarbeitet werden. Umgekehrt: wenn Sie „ISTLEER“ in das Suchfeld eintragen, finden Sie weitere Artikel von mir zu diesem Thema.

    Liebe Grüße

    Rene Martin

Hallo Herr Martin,

Und jetzt noch Lob:

Ihre Antwort auf meine Zuschrift find ich vorbildlich.  Außerdem freue ich mich immer, wenn jemand im Internet nützliche Informationen zur Verfügung stellt, und Ihre  Seiten sehen „recht gut gemacht“ aus (ich habe sie allerdings bisher noch nicht näher angesehen, daher nur eine Beurteilung des Eindrucks auf den ersten Blick). 

Liebe Grüße

Michael Richter

In der Potsdamer Konferenz von 1945 beschlossen die Siegermächte des Zweiten Weltkriegs die Aufteilung von Deutschland in die Besatzungszonen der USA, UdSSR, Großbritannien, Aldi Nord und Aldi Süd.

Amüsant. Ist Ihnen das schon aufgefallen? Wenn ich in einer intelligenten (dynamischen/formatierten/strukturierten) Tabelle eine Überschrift lösche, wird sie – je nach Spracheinstellung – durch eine andere (beispielsweise „Spalte1“) ersetzt:

Wenn Sie allerdings eine Überschrift eingeben, die länger ist als 255 Zeichen, wird dieser Text gelöscht. DFie maximale Anzahl der Zeichen einer Überschrift beträgt 255 Zeichen.

Das hat Auswirkungen auf PowerQuery, der Daten als intelligente Tabelle zurückgibt. Ist eine Überschrift länger, wird der restliche Text abgeschnitten. Werden gleiche Überschriften importiert, werden sie durchnummeriert.

Ein Text ist ein Text ist ein Text

Was passieren kann, wenn man einen Text als Text formatiert – darauf habe ich schon hingewiesen. Auch was passiert, wenn man einen (langen) Text als Buchhaltung formatiert:

Amüsant ist dagegen auch folgendes Phänomen: Wenn man einen Text als Datum, Prozentwert oder Währung formatiert:

und dann mit der Funktion LÄNGE weiter rechnet – allerdings mit mindestens zwei Rechenoperationen (beispielsweise LÄNGE – 1 oder LÄNGE x 1), dann wird das Zahlenformat übernommen:

Erstaunlicherweise: FINDEN und SUCHEN liefern auch Zahlen – sie übernehmen jedoch nicht das Zahlenformat.

Ich wär auch lieber reich als sexy – aber was soll ich machen….?I

Eine Funktion liefert einen Wert.

Schnell entdeckt man jedoch, dass auch Formatierungen übernommen werden. Meistens korrekt:

Steht in A1 eine Zahl, die als Währung oder Buchhaltung formatiert ist, dann wird eine Berechnung

=A1*19% als Währung oder Buchhaltung formatiert.

Stehen in A1 und A2 Datumsangaben, dann liefert die Differenz eine Zahl und kein Datum. Wird jedoch

=A1+30 berechnet, so ist das Ergebnis als Datum formatiert.  Die Summe, Mittelwert, Max und Min von mit Währung oder Buchhaltung formatierten Zellen, werden korrekt wieder in diesem Format angezeigt. So weit, so gut.

Allerdings liefert

=WENN(WOCHENTAG(A1;2)>5;A1+3;A1+1)

leider kein Datum, sondern eine Zahl.

(Erklärung: Ermittle zu einem Datum den nächsten Arbeitstag)

Und schließlich: Steht in A1 ein Text, beispielsweise „Excel nervt“. Ist diese Zelle als Text formatiert (okay – nicht nötig; aber stört eigentlich nicht), so liefert:

=LÄNGE(A1)

die Zahl 11.

Jedoch liefert:

=LÄNGE(A1)*1

den Text „11“ (linksbündig). Editiert man die Zelle, so steht die Formel nun als Formel in der Zelle. Irgendwie doof …

Texte zerschneiden

Ich habe in der letzten Excelschulung gelernt, dass man mit Textfunktionen Texte „manipulieren“ kann. Das wollte ich ausprobieren.

Ich habe eine Liste mit Vor- und Zunamen. Die Vornamen löse ich mit:

=LINKS(A2;FINDEN(“ „;A2)-1)

heraus. Klappt prima. Bei den Nachnamen bei der Formel

=RECHTS(A2;FINDEN(“ „;A2)-1)

macht er aber bei einigen Namen Blödsinn. Warum?

RECHTS klappt nicht!

RECHTS klappt nicht!

Das Problem: Die Funktion FINDEN (oder auch SUCHEN) findet einen Text innerhalb eines anderen VON LINKS. Das bedeutet: Sie schneiden aus dem Text VON RECHTS so viele Buchstaben heraus wie der Vorname lang ist. Das kann zufälligerweise funktionieren, normalerweise aber nicht. Sie lösen das Problem entweder mit der Gesamtanzahl der Buchstaben LÄNGE:

=RECHTS(A2;LÄNGE(A2)-FINDEN(“ „;A2))

oder mit der Funktion TEIL, die ab einem bestimmten Zeichen herausschneidet:

=TEIL(A2;FINDEN(“ „;A2)+1;999)

(zugegeben: die Zahl 999 ist „geschummelt“ – Sie schneiden nach dem Leerzeichen 999 (oder eine noch höhere Anzahl Buchstaben heraus) – aber es funktioniert)

Oder Sie löschen die ersten Buchstaben weg:

=ERSETZEN(A2;1;FINDEN(“ „;A2);““)

All das funktioniert.

So funktioniert es - drei Varianten

So funktioniert es – drei Varianten