Tag Archives: ISTTEXT

Mal sollte öfter mal einen Mutausbruch haben.

Hallo Herr Martin,

vielen Dank für die schnelle Beantwortung meiner Frage.

Ich werde bei den großen Uhrzeiten versuchen in der Formel für den Durchschnittswert die Minuten zu kürzen so dass nur noch mit den Stunden gerechnet wird. Wie ich die Formel erstelle weiss ich noch nicht aber ich werde mal rumprobieren.

Hallo Herr Martin,

ich habe es mit Runden, Kürzen und Ganzzahl versucht und bekomme weiterhin einen Fehler #Wert. Ich denke, ich brauche hier doch noch einmal ihre Hilfe.

Hallo Herr J.,

wenn Sie in Excel etwas in eine Zelle eintragen, müssen Sie die Eingabe mit [Enter] abschließen. Der Grund: Excel prüft, ob Sie Text oder Zahl eingetragen haben: Text steht linksbündig, Zahlen rechtsbündig. Die Eingabe von 1oo oder 1,,50 oder 31-11-2020 wird zu Text und steht linksbündig. Auch: 1000000:30. Das ist keine Zahl; Excel kann damit nicht rechnen; die Funktion ISTTEXT kann das prüfen. Und diese müssen Sie auch verwenden.

Wenn die „zu lange Uhrzeit“ Text ist, müssen Sie sie als Text behandeln, sonst als Uhrzeit.

=WENN(ISTTEXT(B3);WERT(LINKS(B3;SUCHEN(„:“;B3)-1));STUNDE(B3))

Übrigens: Sie haben Ihre „Texte“ rechtsbündig formatiert …

schafft Abhilfe.

Hilft da?

schöne Grüße Rene Martin

Woran erkennt man, dass man zu viel mit Excel gearbeitet hat? Wenn man die Augen schließt und sich das Excel-Grid in die Netzhaut eingebrannt hat (Daniel Kogan – excelhero)

Verblüffend!

Man schreibe in eine Zelle den Text ‚WAHR. Das Ergebnis wird linksbündig als Text angezeigt. Das Gleiche passiert, wenn man eine Zelle als Text formatiert und anschließend mit den Buchstaben WAHR füllt.

Soweit so gut. Die Überprüfung mit der Funktion ISTTEXT bestätigt, dass ein Text in der Zelle steht; ISTLOG verneint die Existenz eines booleschen Wertes (WAHR oder FALSCH). Auch die Überprüfung mit =Zelle=WAHR und =ZELLE=“WAHR“, verneint das erste und bestätigt das zweite:

Irritierend ist nun, dass die Funktion ZÄHLENWENN 0 liefert, wenn man den TEXT „WAHR“ zählt:

Der Blick in den Funktionsassistenten irritiert:

Verblüffend!

…. loading… ███████████████] 99,99%

Eigentlich schade. Wer den Konjunktor XOR aus dem Physikunterricht oder aus der bitweisen Verknüpfung aus dem Informatikunterricht kennt, der wird enttäuscht sein, dass man ihn in Excel dafür leider nicht einsetzen kann. Der Grund: Wandelt man eine Zahl mit der Funktion DEZINBIN um, so ist der Binärwert leider keine Zahl mehr, sondern ein Text. Und damit kann man SO nicht weiterrechnen. Dann halt umständlich …

Tschüss Niveau – bis Montag

Vielleicht sollte ich nicht so viel nachprüfen. Aber manchmal will ich es einfach wissen.

Ich trage in eine Spalte unterschiedliche Dinge ein: ganze Zahlen, Dezimalzahlen, Datumsangaben, Uhrzeiten, Text. Ich überprüfe ihre Existenz mit den beiden Funktionen ISTZAHL und ISTTEXT. Die Ergebnisse sind komplementär. Jedoch bei den beiden Gebilden WAHR und FALSCH liefert Excel: ISTZAHL: nö! ISTTEXT: keine Spur!

Ja – was ist es denn?