Mal sollte öfter mal einen Mutausbruch haben.

Hallo Herr Martin,

vielen Dank für die schnelle Beantwortung meiner Frage.

Ich werde bei den großen Uhrzeiten versuchen in der Formel für den Durchschnittswert die Minuten zu kürzen so dass nur noch mit den Stunden gerechnet wird. Wie ich die Formel erstelle weiss ich noch nicht aber ich werde mal rumprobieren.

Hallo Herr Martin,

ich habe es mit Runden, Kürzen und Ganzzahl versucht und bekomme weiterhin einen Fehler #Wert. Ich denke, ich brauche hier doch noch einmal ihre Hilfe.

Hallo Herr J.,

wenn Sie in Excel etwas in eine Zelle eintragen, müssen Sie die Eingabe mit [Enter] abschließen. Der Grund: Excel prüft, ob Sie Text oder Zahl eingetragen haben: Text steht linksbündig, Zahlen rechtsbündig. Die Eingabe von 1oo oder 1,,50 oder 31-11-2020 wird zu Text und steht linksbündig. Auch: 1000000:30. Das ist keine Zahl; Excel kann damit nicht rechnen; die Funktion ISTTEXT kann das prüfen. Und diese müssen Sie auch verwenden.

Wenn die „zu lange Uhrzeit“ Text ist, müssen Sie sie als Text behandeln, sonst als Uhrzeit.

=WENN(ISTTEXT(B3);WERT(LINKS(B3;SUCHEN(„:“;B3)-1));STUNDE(B3))

Übrigens: Sie haben Ihre „Texte“ rechtsbündig formatiert …

schafft Abhilfe.

Hilft da?

schöne Grüße Rene Martin

3 comments

  • Heinz-Jürgen Ladberg

    Ein interessantes Thema
    Das hat mich nicht losgelassen und ich habe auch ein wenig herumprobiert.
    Meine Lösung:
    Zellen B2 – F2: Anzahl der Mitarbeiter eingeben wie gehabt
    Zellen B3 – F3: Überstunden eingeben wie gehabt (Zellformat: Uhrzeit [h]:mm)
    Zelle B4: =WENN(ISTTEXT(B3);(WERT(LINKS(B3;FINDEN(„:“;B3)-1))*60+WERT(RECHTS(B3;2)))/(24*60*B2);B3/B2)
    Zellformat auch hier: Uhrzeit [h]:mm
    Anschließend die Formel von B4 nach F4 ziehen

    Sieht anschließend gut aus (leider kann ich keinen Screenshot einfügen oder die Datei anhängen). Und schon hat man die EXCEL-Grenzen überlistet, jedenalls so lange, bis der Durchschnittswert auch wieder zu groß wird…

    • Medardus

      Ich bin begeistert, Heinz-Jürgen: Leute, die meine Seite lesen, ganz genau lesen, mitdenken, mitknobeln und weitere Lösungen finden und vorstellen.

      Danke.
      Ich darf Screenshot:
      Uhrzeit

  • Heinz-Jürgen Ladberg

    Kurzer Nachtrag:
    Bei dem Format muss es natürlich Benutzerdefiniert [h]:mm heißen.
    Und 0,001 Mitarbeiter bei 20000 Überstunden funktioiniert bei mir auch. Dem Mitarbeiter möchte ich allerdings nicht begegnen.
    Eines noch: Die Überschriften sind einfach topp…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.