Tag Archives: Index

Ich lese „SPÜLMASCHINENFEST“. Aber nicht wann, wo, Kosten? Weiß jemand mehr darüber?

Guten Tag Herr Martin,

ich hatte schon lange kein Problem mehr mit Excel, sicherlich auch dank Ihrer Kurse, die ich mir in LINDEDIN Learning immer wieder einmal ansehe.

Heute nun habe ich ein Problem, bei dem Sie mir vielleicht helfen können. Wenn es allerdings nicht so nebenher geht, dann können Sie mir dies gerne mitteilen, dann muss ich weiter forschen.

Ich möchte mir hervorgehobene Zellen zählen lassen, genau genommen, möchte ich beim Wahlverfahren D’Hondt sofort sehen, wie viele Sitze hat Liste 1, 2…

Möglicherweise geht es auch nicht mit dem Zählen der hervorgehobenen Zellen sondern anders.

Ich habe es mit SVERWEIS versucht, was leider dann ab der 5. Zeile ein „NV“ brachte – mir leider unverständlich. Mit INDEX und VERGLEICH komme ich auch nicht weiter, weil ich ja keine genaue Zeilen oder Spalenzahl angeben kann. Diese kann ja – je nach Höchstwert – variieren.

Ich sende Ihnen die Datei einmal zu und freue mich auf Ihre Antwort, kann aber auch verstehen, wenn Sie schreiben: Kann ich Ihnen nun leider nicht mitteilen, dauert zu lange…

Trotzdem danke für Ihr offenes Ohr.

Ich wünsche Ihnen noch einen schönen Tag.

Hallo Frau P.,

das ist eine hübsche Fingerübung.

Ein paar Anmerkungen:

1. man kann Farben in Excel nicht zählen. Und wenn ich jetzt von Ihnen die Funktion ZELLE höre – mit Einschränkungen ja. Aber – diese Funktion reagiert nicht auf Formatänderungen. Und: zeigt auch nicht alle Formate an!

2. Ich würde es klassisch mit SUMMEWENN lösen. SVERWEIS, INDEX & co greifen auf mehrere Spalten zu. Mit der neuen Funktion XVERWEIS kann man es auch lösen – aber ich weiß nicht, ob sie diese schon haben. Werfen Sie einen Blick auf meine Lösung in Spalten M:O, bzw. zusammengefasst in Spalte Q.

=KGRÖSSTE($B$6:$E$10;ZEILE(A1))
=SUMMENPRODUKT((M6=$B$6:$E$10)*ZEILE($A$1:$A$5))
=INDEX($A$6:$A$10;N6)

3. Für welches Beispiel/Land verwenden Sie das? Ich lese bei wikipedia, dass noch die Schweiz, Spanien, Portugal, Belgien, Polen und Finnland dieses Verfahren verwenden. Sie wissen, dass dies in Deutschland 1985 durch das Hare-Niemeyer-Verfahren abgelöst wurde. Ich hätte es nämlich fälschlicherweise in meinem Excel-Formelbuch erläutert … und dann gemerkt, das wir so (in Deutschland) gar nicht mehr rechnen.

zusammengefasst

Hallo Herr Martin,

herzlichen Dank für Ihre schnelle Rückmeldung und Ihren Vorschlag der Berechnung.

Ich habe es jetzt noch einmal nachgebaut und verstanden, obwohl ich niemals auf die Formel gekommen wäre.

Zu Nr. 3:

Ich weiß nur, dass die Hochschule Furtwangen den Vorschlag unserer Justiziarin aus Stuttgart aufgegriffen hat und diesen in ihrer Wahlordnung nun festgelegt hat. Wir haben bisher mit Hare-Niemeyer gewählt. Aber leider soll es auch bei D’Hondt bleiben, obwohl wir eine Hochschule mit drei Standorten sind und unserer kleinster Standort mit diesem Wahlverfahren ernste Schwierigkeiten bekommen könnte. Ich hatte das (als Wahlleitung) angemerkt, es bleibt trotzdem bei D’Hondt.

Ich wünsche Ihnen noch einen schönen Tag und weiterhin viel Erfolg bei Ihrer Arbeit.

SVERWEIS ist eine Erfindung des Teufels !!!!!!!!!!!!!!!!!!!!!

Hi Rene,

wahrscheinlich wirst du jetzt von mir das CALC Zeugnis zurück verlangen, aber mich macht der SVERWEIS noch wahnsinnig in EXCEL2016.

Es ist eine völlig simple Datei, aber trotzdem verweigert SVERWEIS den Dienst.

Ich hab dir die Datei im Original angehängt. Schau dir mal meine SVERWEIS Formal an und zeig mir bitte den Fehler. Die Boulesche Variable hab ich auch in allen Variationen ausprobiert à IMMER #NV.

Die Formel:

=SVERWEIS(A2;$I:$K;1)

Hi Jo,

SVERWEIS sucht immer in der ersten Spalte einer Liste.

Dein Pin steht aber in der dritten Spalte.

Du kann es lösen mit den Funktionen INDEX und VERGLEICH:

=INDEX(J:J;VERGLEICH(A2;K:K;0))

Hilft das?

LG aus Hamburg

Rene

Stirb nicht als Jungfrau, sonst erwarten dich im Himmel nur Terroristen.

Schon irgendwo doof. Zumindest ein bisschen.

Ich erstelle eine Pivottabelle. In der zweiten Spalte befindet sich eine ID. Diese ID soll mit INDEX- und VERGLEICHS-Funktionen in einer anderen Tabellen gefunden werden und weitere Informationen geliefert werden, beispielsweise die Gesellschafterin und die Geschäftsbezeichnung Spalte A und B):

Filtert man die Pivottabelle werden jedoch die Zeilen außerhalb der Pivottabelle nicht ausgeblendet. Das bedeutet: ich erhalte eine Reihe Fehlerwerte:

Und nein – ich kann und will die anderen Daten nicht zu den Daten der Pivottabelle hinzufügen. Und ja: natürlich habe ich anschließend diesen Fehler mit WENNFEHLER abgefangen.

Schon irgendwie seltsam: ein Filtern der Pivottabelle wirkt sich nicht auf die Zeilen außerhalb aus. Anders als beim „normalen“ Filtern mit Autofilter.

Schützt die Bäume – esst mehr Biber!

Manchmal stolpert man (ich) über seine eigenen Füße.

Heute. Excelschulung. Ich erkläre die Funktion INDEX. Ich verweise mit INDEX vom zweiten Tabellenblatt auf das erste Blatt „Diäten“. Ich ziehe mit der Maus den Bereich auf. Bei den ersten beiden Spalten lautet die Formel:

=INDEX(Diäten!A1:B24

füge ich die Spalte C hinzu lautet die Formel jedoch:

=INDEX(Diäten

Schließe ich Spalte D ein finde ich nun folgende Formel:

=INDEX(Diäten!A1:D24

Ich grüble eine Weile über das seltsame Phänomen, bis ich dahinter komme, dass ich ja den Bereich A1:C24 benannt habe: er heißt „Diäten“.

Man sollte nicht Tabellenblätter so beschriften wie die Namen, die in der Datei vergeben wurden. Das führt zu Chaos!