Tag Archives: Dezimalzahl

Ei rät nicht. Eiweiß.

Excel nervt mal wieder. Kennst du das? Die Funktion DEZINBIN, die Dezimalzahlen in Binärzahlen verwandelt hat eine Obergrenze. Nach 511 ist Schluss:

Auf der Seite

https://im-coder.com/dezimal-zu-binaer-konvertierung-fuer-grossen-zahlen-in-excel.html

Findet man eine Lösung zur Erweiterung:

=DEZINBIN(REST(QUOTIENT($A$13;256^4);256);8)&DEZINBIN(REST(QUOTIENT($A$13;256^3);256);8)&DEZINBIN(REST(QUOTIENT($A$13;256^2);256);8)&DEZINBIN(REST(QUOTIENT($A$13;256^1);256);8)&DEZINBIN(REST(QUOTIENT($A$13;256^0);256);8)

Nicht sehr komfortabel, denkt Christian Neuberger, der auf unserem Excelstammtisch andere Lösungen vorgestellt hat.

Wenn die Anzahl der Stellen fest sein soll, beispielsweise 40, könnte man die Zahl mit der Funktion SEQUENZ umwandeln:

=TEXTKETTE(KÜRZEN(REST(A15/2^SEQUENZ(40;;40-1;-1);2)))

In A15 befindet sich die Zahl, die konvertiert werden soll.

Kann man das variabel halten, fragt er sich? Klar – mit einer Hilfszelle (hier: A16):

Die Formel:

=TEXTKETTE(KÜRZEN(REST(A15/2^SEQUENZ(A16;;A16-1;-1);2)))

oder auch ohne Hilfszelle:

=TEXTKETTE(KÜRZEN(REST(A15/2^SEQUENZ(KÜRZEN(LOG(A15;2)+1);;KÜRZEN(LOG(A15;2));-1);2)))

Eine sehr, sehr clevere Lösung!

Vielen Dank an Christian Neuberger, der mithilft, dass Excel nicht mehr ganz so nervt …

Das wichtigste am Knackarsch ist das „n“!

Word-Schulung. Wir erstellen einen Serienbrief. Ich beginne mit einer einfachen Liste – Punkte für das Zertifikat, das die Azubis erreicht haben. Ich frage sie nach ihrer Punktzahl, sie witzeln; einer sagt: „0,1“. Ich trage es in Excel ein und speichere die Datei.

Ich erstelle einen Serienbrief und verwende diese Liste:

Die Vorschau offenbar Erstaunliches:

Auch hier ein Rundungsfehler! Natürlich kann man ihn in Word mit den entsprechenden Schaltern wegformatieren ( \# „0,00“) oder in Excel in einen Text umwandeln =WENN(B2<1;TEXT(B2;“0,00″);TEXT(B2;“0″))

Erstaunlich ist es trotzdem …