Ich achte auf meine Ernährung: Was schmeckt, wird gegessen.

Excelschulung. Eine junge Teilnehmerin. Azubi.

Sie zeigt mir Beispiele von ihrem Lehrer, die sie verstehen und können muss, da ähnliche Beispiele Teile der Prüfung von Excel sind. Geübt werden sollen einige Formeln:

Der prozentuale Anteil wird berechnet:

=WENN(UND(A15<>"";B15<>"");D15*100/$D$25;"")

Okay, mit der Funktion

UND(A15<>"";B15<>"")

wird überprüft, ob die Zellen der Spalte A und B gefüllt sind. Eine hübsche Übung, um UND und WENN zu üben.

Dennoch: WENNFEHLER wäre sicherlich besser gewesen, um ALLE Fehler abzufangen.

Aber noch mehr irritiert mich die Berechnung

D15*100/$D$25

Warum wird mit 100 multipliziert? Ich hätte den Anteil von einer Dezimalzahl in eine Prozentzahl formatiert. Und damit weitergerechnet.

Wäre das nicht eher im Sinne von Excel gewesen?

2 comments

  • Max

    Ich finde die Lösung mit 100 leichter verständlich, man muss keine Formatierung im Blick behalten und wenn man es von Hand rechnet, macht man es genau so. Was hab ich mir in solchen Szenarien schon einen Wolf gesucht. In der Firma wurde das irgendwann auch als Standard definiert, weil es immer wieder zu unschönen Effekten kam. Nicht alles in old-school ist antiquiert.

    • Medardus

      Hallo Max,
      es gibt natürlich für alle Techniken Argumente und Gegenargumente.
      Mathematisch gesehen ist das nicht korrekt, weil ja ein halb der Zahl 0,5 entspricht, also 50 von Hundert ist oder 50% Zwar multipliziere ich 0,5 im Kopf oder auf dem Papier mit 100, aber korrekt ist es nicht. Das mit dem Formatieren ist so eine Sache – stimmt: es gruselt mich auch, wenn 1.4000.000 zu 1,4 Mio formatiert wird.
      Wie gesagt: wenn man den Standard klar erklärt und deutlich definiert und konsequent einhält, ist dies okay. Ich hoffe, dass die Lehrerin oder der Lehrer das so gemacht hat. Und: ich hoffe, dass du nciht der Lehrer bist, der hier meinen Spott abbekommen hat.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.