Tag Archives: Durchschnitt

Kunden, die die Schreibtischlampe gekauft haben, haben auch Verlängerungskabel gekauft.

Vor vier Wochen war ich in einer Rechtsanwaltskanzlei und habe gefühlte 15.000 Diagramme bearbeitet. Dabei sind mir eine Reihe an Dingen aufgefallen. Beispielsweise:

Wir erstellen ein Diagramm, das die durchschnittlichen Prozesskosten berechnet. Und zwar der Jahre 2013 – 2018 und 2019 – 2020. Und daneben der Gesamtdurchschnitt. Das Diagramm sah wie folgt aus:

Einer der Rechtsanwälte warf einen Blick darauf und sagte, dass die Berechnung (und die Darstellung) nicht stimmen könne: der Durchschnitt der beiden Durchschnitte sei doch der Mittelwert. Im Diagramm sei er viel zu gering.

Mein Bauchgefühl sagte, dass dies nicht stimmen könne. Ich nahm ein Blatt Papier und rechnete:

Der Durchschnitt von 2 und 4 ist 3. Der Durchschnitt von 10 und 20 ist 15. Der Durchschnitt von 3 und 15 ist 9; ebenso wie der Durchschnitt von 2, 4, 10 und 20. Sollte der Rechtsanwalt doch recht haben? Zweiter Versuch:

Ich berechne den Durchschnitt von 1, 2, 3, 4 und 5. Er lautet 3. Der Durchschnitt von 10 und 20 beträgt 15. Mittelwert von 3 und 15 ist 9; jedoch: Durchschnitt von 1, 2, 3, 4, 5, 10 und 20 lautet 6,42857

Stimmt: wenn die Anzahl unterschiedlich ist, ist der Durchschnitt zweier Duchschnitte eben nicht der Mittelwert aller Zahlen. Der Rechtsanwalt hat sich geschlagen gegeben. Wäre doch gelacht!

Nicht vergessen: heute werden die Waagen um fünf Kilo zurückgestellt – auf Weihnachtszeit!

manchmal freue ich mich auch über Excel. Kennt ihr das? Probleme, die nicht lösbar scheinen, finden doch eine Lösung.

Kennt ihr die neuen Array-Funktionen in Excel 365? Beispielsweise ZUFALLSMATRIX:

=ZUFALLSMATRIX(10;1;1;10;WAHR)

generiert zehn zufällige ganze Zahlen zwischen einschließlich 1 und 10. Okay.

=SUMME(ZUFALLSMATRIX(10;1;1;10;WAHR))

summiert zehn zufällige Zahlen und liefert ein Ergebnis zwischen 10 und 100. Okay.

Vor einer Weile wollte ein Kunde aus einer Liste von zirka 100.000 Werten 100 Werte zufällig herausgreifen und von diesen den Durchschnitt berechnen. Mit einer Hilfsspalte ist das kein Problem. Jedoch scheinen die Matrixformeln zu versagen, weil {…ZUFALLSBEREICH …} 100 Mal die gleiche Zufallszahl liefert und nicht 100 verschiedene. Die Lösung für dieses Problem liefert ZUFALLSMATRIX:

In A2:A100000 stehen Zahlen. Die Funktion

=MITTELWERT(BEREICH.VERSCHIEBEN($A$1;ZUFALLSMATRIX(100;1;1;100000;WAHR);0))

berechnet einen Durchschnitt für diese 100 zufällig gefundenen Werte. [F9] zum Neuberechnen liefert einen anderen Wert. Markiert man einen Teil der Formel, dann zeigt [F9], dass tatsächlich zufällige Werte ermittelt wurden. Die Zahl 100 kann ausgelagert und erhöht werden. Je mehr man sich 100000 nähert, umso mehr nähert sich der Zufalls-Mittelwert dem echten Mittelwert.

Und wer sich nun fragt: „wer braucht denn so etwas?“ – Das Teilchen heißt Monte-Carlo-Simulation und wird in Mathematik, Physik, Finanzwesen, … seit über 60 Jahren angewandt. Weite Infos – beispielsweise Wikipedia.

Und ich bin begeistert – Excel rechnet so wie ich will!

Betrunken flirten ist nicht anders als hungrig einkaufen gehen. Du kommst mit Sachen nach Hause – die braucht kein Mensch!

Vorgestern in der Excelschulung haben wir über den Mittelwert in Pivottabellen diskutiert: Pünktchen verkauft 200 und 300 Streichholzschachteln; Anton 10, 20 und 30. Die Summe der fünf Verläufe beträgt 560, die Anzahl 5, also der Mittelwert liegt bei 112. Anton hat im Durchschnitt 20 verkauft, Pünktchen 250. Ich darf nun – um den Gesamtmittelwert zu berechnen – nicht 270 durch 2 teilen, sondern muss die Gesamtsumme (560) durch die Gesamtanzahl (5) teilen – sonst erhalte ich einen „schiefen“ Mittelwert. Excel rechnet hier korrekt; wenn etwas anderes gewünscht ist, muss man mit Hilfsspalten arbeiten.

Ein Kompromiss ist nur dann gerecht, brauchbar und dauerhaft, wenn beide Parteien damit gleich unzufrieden sind. (Henry Kissinger)

Wir wissen, dass Excel eine Rechenungenauigkeit hat. Aber so ungenau?

Man nehme drei Zahlen (beispielsweise Körpergrößen) und berechne den Mittelwert (C6). Von jeder der drei Körpergrößen wird die Differenz zum Durchschnitt berechnet (D2:D4). Diese drei Zahlen werden summiert (D6) – das Ergebnis sollte eigentlich 0 ergeben. Eigentlich …

Sehr ungenau

Sehr ungenau