Tag Archives: Monte-Carlo-Simulation

Nicht vergessen: heute werden die Waagen um fünf Kilo zurückgestellt – auf Weihnachtszeit!

manchmal freue ich mich auch über Excel. Kennt ihr das? Probleme, die nicht lösbar scheinen, finden doch eine Lösung.

Kennt ihr die neuen Array-Funktionen in Excel 365? Beispielsweise ZUFALLSMATRIX:

=ZUFALLSMATRIX(10;1;1;10;WAHR)

generiert zehn zufällige ganze Zahlen zwischen einschließlich 1 und 10. Okay.

=SUMME(ZUFALLSMATRIX(10;1;1;10;WAHR))

summiert zehn zufällige Zahlen und liefert ein Ergebnis zwischen 10 und 100. Okay.

Vor einer Weile wollte ein Kunde aus einer Liste von zirka 100.000 Werten 100 Werte zufällig herausgreifen und von diesen den Durchschnitt berechnen. Mit einer Hilfsspalte ist das kein Problem. Jedoch scheinen die Matrixformeln zu versagen, weil {…ZUFALLSBEREICH …} 100 Mal die gleiche Zufallszahl liefert und nicht 100 verschiedene. Die Lösung für dieses Problem liefert ZUFALLSMATRIX:

In A2:A100000 stehen Zahlen. Die Funktion

=MITTELWERT(BEREICH.VERSCHIEBEN($A$1;ZUFALLSMATRIX(100;1;1;100000;WAHR);0))

berechnet einen Durchschnitt für diese 100 zufällig gefundenen Werte. [F9] zum Neuberechnen liefert einen anderen Wert. Markiert man einen Teil der Formel, dann zeigt [F9], dass tatsächlich zufällige Werte ermittelt wurden. Die Zahl 100 kann ausgelagert und erhöht werden. Je mehr man sich 100000 nähert, umso mehr nähert sich der Zufalls-Mittelwert dem echten Mittelwert.

Und wer sich nun fragt: „wer braucht denn so etwas?“ – Das Teilchen heißt Monte-Carlo-Simulation und wird in Mathematik, Physik, Finanzwesen, … seit über 60 Jahren angewandt. Weite Infos – beispielsweise Wikipedia.

Und ich bin begeistert – Excel rechnet so wie ich will!