Tag Archives: ZUFALLSMATRIX

Mut ist, wenn du morgens um 4 Uhr knallvoll nach Hause kommst, deine Frau mit dem Besen in der Ecke steht und du sie fragst: „Bist du am Putzen oder fliegst du noch weg?“

Ich habe bereits darüber geschrieben. Bill Jelen hat einen Artikel darüber geschrieben:

https:// www .youtube.com/watch?v=iaJv6E0GRC4

Auch auf der Seite von Microsoft ist zu lesen:

https: // support.microsoft.com/en-us/office/-spill-volatile-size-05aad07c-947e-4c9b-bd6f-7b1f8ae6a7dc?fbclid=IwAR3-mdf2DsQoMOTCOt5Z2m2i2ib5_rVYLikGthKeQllPdFZM94Bfbxz_2bc

Eben:

Dynamic array resizes may trigger additional calculation passes to ensure the spreadsheet is fully calculated. If the size of the array continues to change during these additional passes and does not stabilize, Excel will resolve the dynamic array as #SPILL!.

Nochmal langsam:

This error value is generally associated with the use of RAND, RANDARRAY, and RANDBETWEEN functions. Other volatile functions such as OFFSET, INDIRECT, and TODAY do not return different values on every calculation pass.

Ich probiere es aus: In einer Spalte stehen Zufallswerte:

=ZUFALLSBEREICH(„1.1.2020″;“31.12.2020“)

Die beiden Funktionen SORTIEREN und SORTIERENNACH funktionieren problemlos:

Jedoch erzeugen die beiden Funktionen FILTER und EINDEUTIG regelmäßig einen Fehler:

=FILTER(A3:A100;A3:A100>44000)
und
=EINDEUTIG(A3:A100)

Allerdings nicht immer:

Die Funktion ZUFALLSMATRIX, welche die Funktion ZUFALLSBEREICH in den Parametern min und max verwendet, bleibt erstaunlicherweise stabil:

=ZUFALLSMATRIX(5;5;MIN(A2:A100);MAX(A2:A100);WAHR)

Verwendet ZUFALLSMATRIX jedoch die Funktion ZUFALLSBEREICH in den Zeilen oder Spalten, ist #Überlauf ein häufiger Fehler:

=ZUFALLSMATRIX(M11;M12)
In M11 und M12 steht:
=ZUFALLSBEREICH(1;10)

Und schließlich kann auch die Funktion SEQUENZ nicht mit ZUFALLSBEREICH zusammen arbeiten:

=SEQUENZ(M11;M12)

Fazit: Finger weg von den neuen Arrayfunktionen im Zusammenhang mit den Zufallsfunktionen
ZUFALLSBEREICH
ZUFALLSZAHL
ZUFALLSMATRIX

Eben: Dynamic array resizes may trigger […] #SPILL!.

Nicht vergessen: heute werden die Waagen um fünf Kilo zurückgestellt – auf Weihnachtszeit!

manchmal freue ich mich auch über Excel. Kennt ihr das? Probleme, die nicht lösbar scheinen, finden doch eine Lösung.

Kennt ihr die neuen Array-Funktionen in Excel 365? Beispielsweise ZUFALLSMATRIX:

=ZUFALLSMATRIX(10;1;1;10;WAHR)

generiert zehn zufällige ganze Zahlen zwischen einschließlich 1 und 10. Okay.

=SUMME(ZUFALLSMATRIX(10;1;1;10;WAHR))

summiert zehn zufällige Zahlen und liefert ein Ergebnis zwischen 10 und 100. Okay.

Vor einer Weile wollte ein Kunde aus einer Liste von zirka 100.000 Werten 100 Werte zufällig herausgreifen und von diesen den Durchschnitt berechnen. Mit einer Hilfsspalte ist das kein Problem. Jedoch scheinen die Matrixformeln zu versagen, weil {…ZUFALLSBEREICH …} 100 Mal die gleiche Zufallszahl liefert und nicht 100 verschiedene. Die Lösung für dieses Problem liefert ZUFALLSMATRIX:

In A2:A100000 stehen Zahlen. Die Funktion

=MITTELWERT(BEREICH.VERSCHIEBEN($A$1;ZUFALLSMATRIX(100;1;1;100000;WAHR);0))

berechnet einen Durchschnitt für diese 100 zufällig gefundenen Werte. [F9] zum Neuberechnen liefert einen anderen Wert. Markiert man einen Teil der Formel, dann zeigt [F9], dass tatsächlich zufällige Werte ermittelt wurden. Die Zahl 100 kann ausgelagert und erhöht werden. Je mehr man sich 100000 nähert, umso mehr nähert sich der Zufalls-Mittelwert dem echten Mittelwert.

Und wer sich nun fragt: „wer braucht denn so etwas?“ – Das Teilchen heißt Monte-Carlo-Simulation und wird in Mathematik, Physik, Finanzwesen, … seit über 60 Jahren angewandt. Weite Infos – beispielsweise Wikipedia.

Und ich bin begeistert – Excel rechnet so wie ich will!