Tag Archives: Bereiche

SVERWEIS rechnet nicht

Seit einer Weile arbeite ich mit dem SVERWEIS. Ich habe ihn schon recht gut verstanden. Aber manchmal rechnet er nicht richtig. Warum?

SVERWEIS rechnet nicht richtig.

SVERWEIS rechnet nicht richtig.

Dazu muss man sich die Formel genau ansehen:

=SVERWEIS(K2;$A$1:$A$32;3;FALSCH)

Sie suchen den Wert, der in der Zelle K2 steht in der Spalte A – genauer in den Zellen A1 bis A32. Soweit so gut. Sie möchten den Wert der dritten Spalte (3), also den Last Name wissen. Sie müssen den Bereich ändern: Es ist richtig – Sie suchen zwar in A1:A32, aber in der Spalte A steht nicht der Wert den Sie haben möchten. Sie müssen in der Matrix (in der Informationstabelle, in der die Daten gesucht werden), auch den Bereich einschließen, in dem sich die Daten befinden, also Spalte C. Sie können dabei gerne übers Ziel schießen, beispielsweise:

=SVERWEIS(K2;$A$1:$H$32;3;FALSCH)

Dann funktioniert es.

Seltsame Pivottabelle

Warum macht Excel so komische Pivottabellen?

Komischer Bereich

Komischer Bereich

Excel benötigt für die Erstellung einer Pivottabelle einen zusammenhängenden und rechteckigen Bereich. Jede Spalte dieses Bereichs muss eine Überschrift (selbstredend in der ersten Zeile) haben. In diesem Beispiel werden die Spalten A bis D als Überschriften identifiziert. Spalten e bis Q haben keine Überschrift in Zeile 1. Dass der Bereich eine Überschrift in Zeile 7 hat, kann Excel nicht erkennen.

Die Lösung: Trennen Sie die den Kopf von dem Datenbereich durch eine Leerzeile. Oder markieren Sie nur den unteren Bereich. Besser: zwei getrennte Bereiche!

Wo ist das Kästchen?

Manchmal taucht das Kästchen nicht auf, mit dessen Hilfe ich eine Formel nach unten ziehen kann. Warum ist es manchmal verschwunden?

Das Kästchen ist verschwunden.

Das Kästchen ist verschwunden.

Die Antwort: Wenn Sie getrennte Bereiche mit gedrückter [Strg]-Taste markieren, dann können sie nicht unabhängig voneinander runtergezogen werden. Excel kann nur einen einzigen zusammenhängenden Bereich runterziehen.

So erscheint das Kästchen.

So erscheint das Kästchen.