Heinrich! Mir graut’s vor dir. (Goethe; Faust I)

Gestern in der Excelschulung kam eine Teilnehmerin mit einer Datei. Ob ich sie mir mal ansehen könne? – Klar! Mein erstes Erstaunen: Die Datei hatte eine Größe von fast 10 MByte!

Ziemlich groß!

Ziemlich groß!

Das Öffnen dauerte – wie befürchtet – sehr lange.

Ein Blick in die Statuszeile zeigte mir an, dass die Datei 58.300 Seite lang war!

58.300 Seiten ?!?

58.300 Seiten ?!?

Mit [Strg] + [Ende] zur letzten Zelle U1048576. Diese Spalte war leer!

20161006batch03

Also zurück zu U1. Von dort markierte ich mit [Shift]+[Strg]+[Ende] bis zur letzten Zelle und löschte Inhalt und Format der nicht benötigten Spalten.

Alles muss raus!

Alles muss raus!

Ein Blick: „nur“ noch 29.150 Seiten

nur noch halb so viele Blätter

nur noch halb so viele Blätter

Meine Nachfrage, ob sie denn alle Blätter benötigt, wurde verneint. Also: Ab A10000 wurde der „Rest“ der Tabelle nach unten markiert und ebenfalls gelöscht.

Raus damit!

Raus damit!

Und schließlich habe ich festgestellt, dass unterschiedliche Linienstärken und Zellformate verwendet wurden. Raus mit den Formaten; alles markieren und neu und einheitlich formatieren.

Doch nicht so!

Doch nicht so!

Und schließlich müssen nicht alle fortlaufenden Nummern der ersten vier Spalten bereits eingetragen sein – dies kann man mit Hilfe einer Formel erledigen, die man elegant runterziehen kann:

20161006batch08

Das Ergebnis: 230 Seiten und eine Datei, die nur noch 610 Byte groß ist.

Das sieht schon besser aus.

Das sieht schon besser aus.

2 comments

  • Nur „U1048576“? Du Glücklicher! Ich krieg ja regelmäßig XFD1048576 auf den Schreibtisch *heul*
    Der UsedRange gehört eigentlich in jeder Schulung von Anfang an vermittelt – und es gehört erklärt, wie dieser zu groß wird. Und wie man den schon während der Entwicklung möglichst klein hält. Und die Auswirkungen auf Konstrukte wie =ZÄHLENWENN(A:A;B1) . Und… und…. und….
    Aber vor allem und ganz besonders: Am.Ende.Sollte.Man.IMMER.Aufräumen!!!

    Excel ist wie ne geile Party: am Ende war’s ja alles ganz toll aber ist das Wohnzimmer ist verwüstet. 😛
    Ich darf so einen Rotz dann nämlich validieren und darf aus „politischen Gründen“ bei solchen Punkten nix sagen – weil: es funktioniert ja doch. So irgendwie jedenfalls. *heul*

    • Medardus

      *lach*
      Hübscher Kommentar – danke.
      Ich vermute, dass der Ersteller der Datei seiner Kollegin helfen wollte und „die Spalte schon mal ausgefüllt hat, damit nur die Daten noch eingetragen werden können“. Oder Ähnliches. Und: jep – nur bis Spalte U.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.