Was für ein Gefühl muss der Tropfen haben, der das Fass zum Überlaufen bringt. (Nikolaus Cybinski)

Die Idee ist gut – sie funktioniert nur leider nicht.

Ein Teilnehmer einer Excelschulung möchte eine fortlaufende Reihe erzeugen. Er möchte, dass „Lücken übersprungen“ werden und dass die Reihe bequem fortgesetzt werden kann.

Kein Problem, oder:

Die Formel

=WENN(B2="";"";MAX($A$1:A1)+1)

hilft hierbei.

Damit unter der Liste neue Daten mit einer fortlaufenden Nummer eingetragen werden können, wandle ich die Liste in eine (intelligente) Tabelle um:

Ein neuer Name:
Lücke und ein weiterer Name:

Klappt.

Wird eine Zeile gelöscht:

funktioniert der Mechanismus hervorragend:

Jedoch: wird eine Zeile eingefügt:

Dann versagt der Mechanismus leider:

Was man feststellen kann, wenn man einen Namen einträgt:

Schade!

One comment

  • Ernst-Albrecht Börgener

    Hallo Rene,

    Wenn in deinem Beispiel statt der Formel

    =WENN(B2=““;““;MAX($A$1:A1)+1)

    die Formel

    =WENN([@Name]=““;““;MAX($A$1:INDEX(tblNamen[[#Alle];[ID]];ZEILE()-ZEILE($A$1)))+1)

    eingegeben wird, können auch neue Zeilen hinzugefügt werden.

    Ernst

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.