Tag Archives: laufende Nummer

Was für ein Gefühl muss der Tropfen haben, der das Fass zum Überlaufen bringt. (Nikolaus Cybinski)

Die Idee ist gut – sie funktioniert nur leider nicht.

Ein Teilnehmer einer Excelschulung möchte eine fortlaufende Reihe erzeugen. Er möchte, dass „Lücken übersprungen“ werden und dass die Reihe bequem fortgesetzt werden kann.

Kein Problem, oder:

Die Formel

=WENN(B2="";"";MAX($A$1:A1)+1)

hilft hierbei.

Damit unter der Liste neue Daten mit einer fortlaufenden Nummer eingetragen werden können, wandle ich die Liste in eine (intelligente) Tabelle um:

Ein neuer Name:
Lücke und ein weiterer Name:

Klappt.

Wird eine Zeile gelöscht:

funktioniert der Mechanismus hervorragend:

Jedoch: wird eine Zeile eingefügt:

Dann versagt der Mechanismus leider:

Was man feststellen kann, wenn man einen Namen einträgt:

Schade!

Sport gibt dir das Gefühl nackt besser auszusehen. Tequila übrigens auch.

Zugegeben: ein bisschen suspekt sind mit die Tabellen, die intelligente Tabellen oder formatierte Tabellen immer noch. Wenn Sie beispielsweise eine fortlaufende Nummerierung erzeugen möchten, können Sie auf eine Zahlenspalte zugreifen und dort beispielsweise die Formel eintragen:

=ANZAHL($C$1:C2)

20161212tabelle01

Die Liste wird korrekt gefüllt:

20161212tabelle02

Wird jedoch ein neuer Datensatz eingetragen, dann „zerschießt“ Excel die vorletzte Formel:

20161212tabelle03

Abhilfe schafft bei der Eingabe der Formel

=ANZAHL($C$1:C2)

anstelle des Zellnamens C2 ein Klick auf die Zelle C2. Dann wird aus der Formel:

=ANZAHL($C$1:[@Alter])

Und damit funktioniert es.

20161212tabele04

Ein großes Dankeschön an Christian für diesen Hinweis.