Tag Archives: casting

Wer die Wahrheit nicht weiß, der ist bloß ein Dummkopf. Wer die Wahrheit kennt und sie eine Lüge nennt, der ist ein Verbrecher. (B. Brecht)

Die Datentypen (oder auch nicht vorhandenen Datentypen) in Excel bringen mich um.

Hintergrund: Ich schreibe ich drei Zellen die Texte ‚1, ‚2 und ‚3. Die Formel =A1+A2+A3 wandelt die Texte in Zahlen um und rechnet richtig. Die Funktion =SUMME(A1:A3) interpretiert die Texte als 0. Ebenso schafft =JAHR(„28.01.2019“) den Text in ein Datum, also in eine Zahl, zu verwandeln und liefert die korrekte Jahreszahl.

In der Zelle C2 steht WAHR. Ein Vergleich =C2*1 liefert 1. =C2=1 liefert FALSCH – der Wahrheitswert WAHR entspricht also 1, ist aber nicht 1. Die Funktionen ISTZAHL und ISTLOG liefern FALSCH und WAHR. Wahr ist ein logischer Wert und keine Zahl, kann aber in eine Zahl verwandelt werden.

So weit, so gut. Deshalb kann die Funktion

=SUMME(C2:C12)

nicht korrekt rechnen, wenn in der Spalte C nur Wahrheitswerte stehen. Multipliziert man jeden Wert mit 1, dann klappt die Summe (als Matrixfunktion):

{=SUMME(C2:C12*1)}

Sie kennen sicherlich dieses Problem bei der Funktion SUMMENPRODDUKT.

Und jetzt mein Erstaunen:

=WAHR+WAHR+WAHR

liefert 3, ebenso wie =“1″+“2″+“3″ die Zahl 6 liefert.

=SUMME(WAHR;WAHR;WAHR)

liefert aber auch 3. Liegen die Werte in Zellen, klappt die Typkonvertierung nicht!

Nachtrag: Bei Programmiersprachen heißt die Umwandlung „casting“. Sollen wir mal Excel casten?