Lass mich – ich muss mich da erst mal reinsteigern!

Hallo Herr Martin,

Ich bin dabei, Stunden zu analysieren, dabei bin ich auf ein Problem gestoßen.

Ich habe Stundenzahlen im 2, 3, 4 und 5 stelligen Bereich, die ich durch Mitarbeiterzahlen dividieren muss,

Obwohl mein Zahlenformat [hh]:mm bei den Stundenwerten nach meiner Ansicht korrekt ist, bekomme ich beim dividieren von 5 stelligen Stundenzahlen immer einen Fehlerwert. Könnten Sie mir bei meinem Problem helfen?

Hallo Herr J.,

werfen Sie mal einen Blick auf die Seite „Spezifikationen und Beschränkungen in Excel“:

https://support.microsoft.com/de-de/office/spezifikationen-und-beschr%C3%A4nkungen-in-excel-1672b34d-7043-467e-8e27-269d656771c3

Dort steht:

Maximale Uhrzeit, die eingegeben kann: 9999:59:59

Ich habe es ausprobiert:

=ZEIT(32000;0;0) -> funktioniert

=ZEIT(33000;0;0) -> liefert einen Fehler

Wie komme ich darauf? Ich habe Ihre Uhrzeiten mit dem Zahlenformat Standard formatiert. 1490:18 -> klappt; 11773:26 -> nichts passiert.

Schade!

Vor einigen Jahren hatte ich einen Teilnehmer in meiner Excelschulung; ein Mitarbeiter des Katasteramts der Stadt München, der Gebäudedaten eintragen wollte. Ein Gebäude in Schwabing wurde am 01.01.1875 eingeweiht. Keine Chance in Excel.

Schade, war meine Antwort.

schöne Grüße

René Martin

3 comments

  • Ernst-Albrecht Börgener

    Hallo Herr Martin.

    Ich vermute, dass Herr J den Wert 11773:26 direkt in die Zelle C3 eigetragen hat. Wenn die Zelle C3 nun mit dem Format [hh]:mm und rechtbündig formatiert wird, steht aber doch nur Text in der Zelle.

    Gibt man allerding die Werte in C3 in Form von

    =11773 * „01:00:00“ + 26 * „00:01:00“

    ein und formatiert die Zelle nun mit [hh]:mm und rechtsbündig, ergibt sich scheinbar die gleiche Anzeige.
    Allerdings ist dies eine echter Zeitangabe mit der man auch rechen kann.

    =C3/C2 ergibt dann 214:03

    Salü

    Ernst A. Börgener

    • Medardus

      Danke für den sehr guten Hinweis!
      Ich vermute auch, dass er die Uhrzeitangaben getippt hat (oder von einem System erhalten hat).

      • Andreas Jensen

        Hallo,
        Ja, ich habe die Zeitangabe eingegeben.
        Nun habe ich jedoch meine komplette Auswertung umgestellt und alle Angaben direkt aus dem Zeiterfassungssystem kopiert, dabei erhalte ich zwar die in der Zeiterfassung angezeigte Zeit als Zahl, diese ändere ich jedoch mit Hilfe einer zusätzlichen Spalte und der Formel =WENN(C12<0;"-";"")&TEXT(ABS(C12/1440);"[hh]:mm").

        Über die Autofilterfunktion und einige Teilergebnisse komme ich dann auf das gewünschte Ergebnis.
        Ich brauche nun nur noch monatlich die benötigten Werte aus der zeiterfassung per copy & Paste in meine Auswertung übertragen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.