Tag Archives: Negative Uhrzeit

Alexa, wie verhindere ich, dass meine Daten ins Internet kommen?

Hallo, ich habe auch so ein Problem in meinem Kalender zur Arbeitszeitberechnung mit den Rauten. Excel gibt mir aber den Hinweis, das entweder die Zelle zu klein ist, oder ein Negativ Wert darin enthalten ist. Bei mir scheint es wohl der Negativ Wert zu sein da eine Formel in der Zelle enthalten ist bei der ich zb. 8 von 9 in meinem Fall Stunden abziehen möchte. Da ich die Zeiten über Dropdown Listen eingebe, habe Rauten in den Zellen solange ich noch keine Werte eingegeben habe. Das sieht natürlich nicht so gut aus. Nun meine Frage. Kann man diese Rauten auch einfach nur ausblenden ohne das die darin enthaltenen Formeln auch ausgeblendet sind? Ich hoffe das ich mein Problem verständlich erklären konnte.

Gruß Uli.

Hallo Uli?

Ich würde um die Formel (wie sieht sie aus?) beispielsweise
=C2-B2
eine WENN-Funktion bauen:

=WENN(C2-B2<0;““;C2-B2)

Hilft das?

Liebe Grüße

René Martin

Hallo Herr Dr.Martin,

Danke Ihnen nochmal für ihre Hilfe, es hat geklappt mit der Formel.

War für Sie bestimmt eine Logische und einfache Sache, aber für mich als Blutiger Anfänger ein Riesen Problem. Würde mich freuen wenn ich mal wieder so ein Problem hätte, mich an Sie wenden dürfte.

Mit freundlichen Grüßen U.

Klar, Uli,

einfach schreiben! Ich helfe gerne

Liebe Grüße aus dem verregneten München

Rene Martin

PS: ich mag den Begriff „logisch“ nicht. Es läuft eine gewisse erlernbare Mechanik ab. Jeder von uns hat ein bestimmtes Wissen und erkennt Lösungen „intuitiv“ und kann sie sicherlich auch beschreiben, warum dieser oder jeder Weg der richtige (oder der geeignete) ist. Also: Kopf hoch, dranbleiben, schmunzeln – ich halte Excel für wichtig – nicht, weil ich häufig damit arbeite, sondern weil sehr, sehr viele Menschen häufig damit arbeiten.

Ungeschoren bleiben ist der Wunsch aller Schafe

Sehr geehrter Herr Martin!

Ich verfolge begeistert Ihre V2B Kurse!

Ich bin Anfänger in Excel und habe für ein  spezifisches Problem bislang keine passende Lösung gefunden.

Wär fein, wenn Sie mir weiterhelfen können.

Ich möchte die negativen Stunden in Spalte F mit Vorzeichen „minus“ und in roter Farbe angezeigt bekommen. Formatiert als Zeit, so dass ich die Spalte summieren kann.

Rechenvorgang: D44-G44-E44 bzw. AZ IST minus AZ SOLL minus Mittagspause 30 Minuten (nur bei AZ IST größer als 6 Stunden, bis größer gleich 6 Stunden, keine Mittagspause).

Wäre nett, wenn Sie mir hier weiterhelfen können.

Vielen Dank im Voraus!

Mit freundlichem Gruß

######

Hallo Herr D.,

eigentlich geht das nicht.

Excel beginnt bei den Datumsangabe am 01.01.1900. Das heißt: 12:00 Uhr wird intern behandelt wir ein halber Tag seit dem 01.01.1900 – also 0,5. Wenn Sie nun -06:00 Stunden haben möchten, wird dies als 31. Dez. 1899 18:00 Uhr behandelt – das geht eigentlich nicht.

Und jetzt zum „eigentlich“:

Sie können in den Optionen /Erweitert den beginn auf 1904 „hochsetzen“ – dann haben Sie zwischen 199 und 1904 vier Jahre „Puffer, in denen Sie mit negativen Uhrzeiten rechnen können.

Ich rate allerdings davon ab, weil dann alle Datumsangaben in dieser Datei um vier Jahre verschoben werden. Und ich sehe in Ihrer Liste 28.05.2016

Alternative: Ich würde Hilfsspalten verwenden: +/- AZ pos:

=WENN(D8-G8-E8>0;D8-G8-E8;0)

+/- AZ neg:

=WENN(D8-G8-E8<0;ABS(D8-G8-E8);0)

Hilft Ihnen das?

######

Hallo Herr Martin!

Ja, so mach ich`s.

Vielen herzlichen Dank für Ihre Hilfe!

Schöne Grüße nach München!