Tag Archives: Multiplikation

Früher waren es Mickey-Maus Hefte. Dann folgten Yps und Bravo. Anschließend der Playboy. Und heute ist es die Apotheken-Umschau.

Einfach nicht aufgepasst!

Excel-VBA-Schulung. Eine Teilnehmerin möchte ein kleines Programm mit mir geschrieben haben: Jede Woche erhält sie eine Liste und jede Woche muss sie in dieser Liste Berechnungen durchführen. Eine bestimmte ID (beispielsweise Idefix) wird gesucht, sämtliche Werte (hier drei) werden wie folgt berechnet:

Die Anzahl der Römer wird mit der Anzahl der Piraten multipliziert und die einzelnen Produkte summiert. Das Ergebnis wird durch die Summe der Römer dividiert. Aber nur dann, wenn keine Hinkelsteine vorhanden sind. Alles klar? – Klar!

Ich beginne Schritt für Schritt. Multipliziere und addiere – hierfür bietet sich doch SUMMENPRODUKT an, oder?. Also: los geht’s:

=SUMMENPRODUKT((A:A=G5)*(B:B)*(C:C))

Ich habe drei Mal überlegen müssen, woher die Fehlermeldung rührt. Die Antwort:

Klar: ich multipliziere jede Zelle jeder Spalte. Und das funktioniert bei der Überschrift (Text!) natürlich nicht!

Ich muss ändern. Entweder so:

=SUMMENPRODUKT((A:A=G5)*1;(B:B);(C:C))

Oder indem ich auf den Bereich ohne Überschrift verweise:

=SUMMENPRODUKT((A2:A40=G5)*(B2:B40)*(C2:C40))

Oder indem ich den Fehler mit WENNFEHLER abfange, oder oder oder.

Und DANN ist der Rest auch kein Problem – beispielsweise so:

=SUMMENPRODUKT((A2:A40=G9)*1;(B2:B40);(C2:C40);(D2:D40<>"Hinkelstein")*1)/SUMMEWENNS(B2:B40;A2:A40;G9;D2:D40;"<>Hinkelstein")

Gerechnet wird also:

(10 x 31 + 40 x 50) / (10 + 40) = 46,2

Und diese Formel kann man mit dem Makrorekorder aufzeichnen und über alle Zellen „laufen lassen“. Das Ganze wird in der Datei Personal.xlsb gespeichert.

Schade, das es so teuer ist, Leute auf den Mond zu schießen. Ich hätte da ein paar.

Hallo René,

ich habe ein für mich unerklärliches Excel Phänomen in der Version 365.

In der Zelle C1 habe ich berechnet: 6*7=42 (s. Anlage).

Dieses Ergebnis habe ich zum Datum 18.07.2017 addiert und erhalte das Datum 24.01.6837.

Addiere ich 42 als Zahlenwert zum Datum 18.07.2017, erhalte ich das richtige Ergebnis 29.08.2017.

Hast Du eine Erklärung?

Liebe Grüße
  Traudl

Hi Traudl,

du MULTIPLIZIERST das Datum (18.07.2017 = 42.934) mit 42

42.934 x 42 = 1.803.228 = 24.1.6837

Stimmt schon!

Rene

Oh je René, danke. 

Dass ich multipliziert habe, ist mir gar nicht aufgefallen. Zudem habe ich die Berechnung mehrfach wiederholt.

Wahrscheinlich Corona Blackout.

Sorry, dass ich Dich mit so einer Lapalie belästigt habe.

Liebe Grüsse 

Traudl 

ich hätte es nicht geglaubt

Manchmal bin ich selbst verblüfft. Heute habe ich Excel 2007 unterrichtet. Doch, doch, es gibt viele Firmen in Deutschland und anderen Ländern, die Office 2007 einsetzen.

Und ich hätte felsenfest behauptet, dass es nicht stimmt, was eine Teilnehmerin behauptete. Sie fragte mich: In einer Spalten stehen Mengenangaben, in einer anderen Preise. Die Preise sind als Euro formatiert. Warum wird bei =B4*D4 das Ergebnis nicht auch als Währung oder Buchhaltung formatiert?

Format wird nicht mitgenommen

Format wird nicht mitgenommen

Tatsächlich: Während in „meinem“ Excel 2016 das Ergebnis korrekt formatiert wird, war dies in Excel 2007 noch nicht der Fall. Übrigens: bei =B4+D4 wurde das Ergebnis mit einem Eurozeichen angezeigt. Schön, dass dieses Fehlen behoben wurde.

Excel multipliziert nicht

Warum klappt die Multiplikation nicht?

Auf manchen Tastaturen sieht das Multiplikationszeichen über dem Zahlenblock auch wie der Buchstabe „x“. Sie dürfen eine Formel jedoch nicht in der Form

=F8xE8

eingeben, weil Excel das „x“ als Buchstaben interpretiert.

Richtig:

=F8*E8

Übrigens: Auch die Division wird mit dem Schrägstrich „/“ durchgeführt und nicht mit einem Doppelpunkt, wie wir es in der Schule gelernt haben.

Excel multipliziert nicht.

Excel multipliziert nicht.