Tag Archives: MITTELWERTWENN

Als Baby wirst du für ein Bäuerchen gelobt; dann perfektionierst du es jahrelang und dann bekommst du Schelte!

Hallo René,

Frage am Rande:

Den Mittelwert Teilnahme über alle Spalten Teilnahme, die >0 bekomme ich wie am schicksten? Mittelwertwenn geht nur über einen zusammenhängenden Bereich, zählenwenn auch,…

Am Ende ist die Tabelle so:

Hallo Florian,

ja, das ist richtig: ZÄHLENWENN, MITTELWERTWENN kann keine getrennten Bereiche verarbeiten. Der Grund:

Wie soll man ZÄHLENWENN(A2:A5;C2:C5;“>0“)

verstehen?

Also muss du den MITTELWERT „nachbauen“. Mittelwert ist ja Summe/Anzahl

Also beispielsweise so:

=SUMME(A2:A6;D2:D6;G2:G6)/(ZÄHLENWENN(A2:A6;“>0″)+ZÄHLENWENN(D2:D6;“>0″)+ZÄHLENWENN(G2:G6;“>0″))

die Spalten A, D und G

Oder:

{=SUMME(A2:A6;D2:D6;G2:G6)/SUMME((A2:A6>0)*1;(D2:D6>0)*1;(G2:G6>0)*1)}

als Matrixfunktion mit Umschalt+Strg+Enter beendet.

Zu Erklärung der zweiten Funktion: A2:A6>0 liefert WAHR;WAHR;FALSCH;WAHR;WAHR;WAHR

diese Wahrheitswert kann ich jedoch nicht summieren. Multipliziere ich sie mit 1, so erhalte ich

1;1;0;1;1;1

Und das kann ich summieren.

Es gibt noch weitere Ansätze.

Liebe Grüße

Rene u