Das Auge liest mit!

Die Frage ist interessant: Aus einer Geburtstagsliste sollen all diejenigen angezeigt werden, die in dieser (laufenden Kalender-)Woche Geburtstag haben. Eine kleine Fingerübung, oder:

Zuerst wird das Geburtsdatum in ein Datum des aktuellen Jahres „transformiert“. Dann wird von diesem Datum und vom aktuellen Tag die ISOKALENDERWOCHE berechnet. Und schließlich beides miteinander verglichen:

Hallo Wolfgang,

und so geht es:

=WENN(ISOKALENDERWOCHE(HEUTE())=ISOKALENDERWOCHE(DATUM(JAHR(HEUTE());MONAT(K2);TAG(K2)));“x“;““)

Schau dir mal die Schritt in der angefügten Tabelle an

Viel Spaß mit KW und Geburtstag

Rene

Lieber René,

vielen Dank. Ich hatte es gleich gestern Abend noch nachgetüfftelt und bin zum Ergebnis gekommen, allerdings hatte ich das Datum anders umgewandelt.

Da sah dann so aus: =WENN(ISOKALENDERWOCHE(TAG(A1)&“.“&MONAT(A1)&“.“&JAHR(HEUTE()))=ISOKALENDERWOCHE(HEUTE());“Happy Birthday“;““)
Viele Grüße
Wolfgang

Ist auch richtig, Wolfgang – meine Lösung ist natürlich besser *lach*

Im Ernst: ich mag es nicht, wenn du ein Datum (intern eine Zahl) in einen Text umwandelst und diese implizit wieder in ein Datum konvertieren lässt. Bei sehr vielen Datensätzen dauert es länger als meine Lösung, die ein Datum als Datum lässt.

Liebe Grüße Rene

2 comments

  • Odo

    Moin Rene,

    warum „ISOKALENDERWOCHE(DATUM(JAHR(HEUTE());MONAT(K2);TAG(K2))“.
    Es reicht doch =ISOKALENDERWOCHE(K2), also

    =WENN(ISOKALENDERWOCHE(HEUTE())=ISOKALENDERWOCHE(K2);“x“;““)

    Viele Grüße
    Odo

    • Medardus

      hm, Odo – die Bemerkung ist richtig und interessant. Wenn Max am Montag, den 12. Oktober 1964 in KW 42 geboren ist, so fällt er diese Jahr durch das Raster, weil wir am 12. Oktober 2019 in KW 41 sind.
      Ich muss noch einmal Wolfgang fragen, was er will …
      Danke für den Hinweis
      Rene

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.