Tag Archives: Iteration

Nach den bisher bekannten physikalischen Gesetzen der Aerodynamik ist es unmöglich, dass die Hummel fliegt. Die Hummel weiß das aber nicht. Sie fliegt einfach!

Excel-Schulung. Eine Teilnehmerin präsentiert eine Liste. In einer Spalte stehen Geldbeträge. Jeweils unter einer bestimmten Gruppe befinden sich Zwischensummen. Manche Summenbeträge sind positiv, manche negativ. Sie möchte gerne nur die positiven Zwischensummen und die dazugehörigen darüberstehenden Werte sehen. Das funktioniert mit einem einfachen Filter nicht. Man muss mit einer Hilfsspalte arbeiten. Dort wird überprüft, ob die Spalte eine Zwischenspalte ist – ob der Wert positiv oder negativ ist. Dann wird es als solches gekennzeichnet. Falls nicht, wird der untenstehende Wert übernommen:

=WENN(UND(B2=““;D2<=0);“neg“;WENN(UND(B2=““;D2>0);“pos“;H3))

Jede Formel bezieht sich auf die darunter stehende Zelle. Excel rechnet von links nach rechts, von oben nach unten. Eigentlich muss der letzte, unterste Wert zuerst berechnet werden, dann den zweiten Wert von unten. Auf diesen bezieht sich die Formel darüber … und so weiter bis zur zweiten Zeile.

Wie rechnet Excel? Iterativ? Wahrscheinlich!

Die Hummel besitzt 0,7 qcm Flügelfläche bei 1,2 Gramm Gewicht.
Nach den bisher bekannten physikalischen Gesetzen der Aerodynamik, sowie unserem physikalischen Verständnis ist es unmöglich, bei diesem Verhältnis zu fliegen!

Die Hummel weiß das aber alles nicht. Sie fliegt einfach!

Vielleicht weiß Excel das auch nicht – und rechnet einfach.