Tag Archives: dynamisches Diagramm

ABC-Analyse im Diagramm

Mein Chef möchte unbedingt mit eines Diagramms eine ABC-Analyse visualisiert haben. Das Problem: Ich erhalte jede Woche neue Daten unserer Produkte. Das bedeutet: Ich müsste jede Woche die Daten neu sortieren, berechnen, das Diagramm erstellen und die kumulierten Bereich <80%, beziehungsweise <95% neu formatieren.

ABC-Analyse

ABC-Analyse

Die Antwort: Wenn Sie sich mit Funktionen ein wenig auskennen, funktioniert es auch dynamisch:

* Berechnen Sie mit der Funktion =KGRÖSSTE die größte Zahl. Verwenden Sie hierzu die Funktion ZEILE(), damit Sie die Funktion nach unten ziehen können.

* Lassen Sie sich mit VERGLEICH die Zeilennummer anzeigen

* Ermitteln Sie die Artikelbezeichnung mit INDEX

* Berechnen Sie den Prozentwert

* Berechnen Sie den kumulierten Prozentwert

* Lassen Sie sich mit einer WENN-Funktion in einer neuen Spalte die Zahlen anzeigen, die <80% sind. Die übrigen erhalten den Wert 0.

* Lassen Sie sich mit einer WENN-Funktion in einer neuen Spalte die Zahlen anzeigen, die sowohl >=80% als auch <95% sind (mit einem UND). Die übrigen erhalten den Wert 0.

* Lassen Sie sich mit einer WENN-Funktion in einer neuen Spalte die Zahlen anzeigen, die >=95% sind. Die übrigen erhalten den Wert 0.

Die berechneten Werte

Die berechneten Werte

Wenn Sie nun neue Werte erhalten, wird das Diagramm „neu gezeichnet“.

Veränderte Werte

Veränderte Werte

Bedingte Formatierung bei Diagrammen

Hallo Du. Ich liebe die bedingte Formatierung. Klasse Sache. Kann ich die eigentlich auch bei Diagrammen einsetzen?

Die Antwort: Nicht direkt. Aber mit einem kleinen Trick funktioniert es.

Bedingte Formatierung bei Diagrammen

Bedingte Formatierung bei Diagrammen

Man muss zusätzlich zu der Spalte der Werte noch eine berechnete Spalte einfügen. Wenn man beispielsweise das Maximum und das Minimum farblich kennzeichnen möchte, kann man berechnen:

=WENN(B2=MAX($B:$B);B2;0)

=WENN(B2=MIN($B:$B);B2;0)

Diese Reihen übernimmt man in das Diagramm und legt sie vor die anderen Balken. Die Werte 0 befinden sich ja am Boden – sind also nicht sichtbar. Werden nun die drei Reihen mit jeweils unterschiedlichen Farben formatiert, erkennt man gut den oder die Spitzenwerte und das Minimum oder die kleinsten Werte.

Mit einem Trick funktioniert es.

Mit einem Trick funktioniert es.

Übrigens: Mit einem ähnlichen Trick kann man sich auch nur den größten und den kleinsten Wert als Zahl anzeigen lassen. Leider funktioniert die bedingte Formatierung hier nicht. Werden die Zahlen jedoch benutzerdefiniert mit

0;0;““;““

formatiert, dann werden die Nullwerte ausgeblendet. Und die Diagramme übernehmen es als Beschriftung.

Nur die größten und kleinsten Zahlen werden angezeigt.

Nur die größten und kleinsten Zahlen werden angezeigt.

Selbstverständlich ist das Diagramm dynamisch. Das heißt: Nach Ändern eines Wertes erscheinen die entsprechenden Zahlen und Farben.

Das Diagramm ist dynamisch.

Das Diagramm ist dynamisch.

Diagramm zeigt nicht die Datenquelle an

Wenn ich ein Diagramm selektiere und über Entwurf / Daten / Daten auswählen den Bereich ansehen möchte, woher Excel die Daten bezieht, erhalte ich nur den lakonischen Kommentar „Der Datumsbereich ist zu komplex, um angezeigt zu werden. Wenn ein neuer Bereich ausgewählt wird, werden alle Reihen im Bereich ‚Reihe‘ ersetzt.“ Was heißt denn das?

Seltsamer Datenbereich

Seltsamer Datenbereich

Die Antwort: Über ein Dropdownfeld in Zelle AB12 wird das Jahr ausgewählt. In Zelle AC12 wird mit einer Formel die Zeile berechnet, aus der Daten gezogen werden. Im Register Formeln / Definierte Namen / Namensmanager werden zwei Namen definiert („Frauen“ und „Männer“), die ausgehend von A1 einen Bereich berechnen, der um so viele Zeilen nach unten versetzt liegt wie in AC12 berechnet wurde. Diese beiden Bereiche wurden nun im Exceldiagramm verwendet, so dass der Anwender das Jahr auswählen kann und das Diagramm dynamisch den Bereich darstellt. Erstaunlicherweise kann Excel diese Formel in der Datenquelle nach einem erneuten Öffnen nicht mehr anzeigen.

Ein dynamisches Diagramm

Ein dynamisches Diagramm