Tag Archives: <

Excel hält sich nicht an die Theoreme der Prädikatenlogik

Kennen Sie das: Ich benötige eine Liste, die sich dynamisch fortsetzt. In einer Zelle wird ein Wert eingetragen – die Nummer eines Zählers soll nur bis nur eingetragenen Nummer angezeigt werden.

Die Formel:

=WENN(A9=$B$4;A9+1;““)

funktioniert problemlos –

=WENN(A9=$B$4;““;A9+1)

jedoch nicht.

Einer geht und einer nicht.

Einer geht und einer nicht.

20160626weiter01

Der Grund ist offensichtlich. Befindet sich in einer Zelle ein leerer String („“), kann Excel zwar problemlos den Ausdruck

12 = „“

auswerte und FALSCH zurückgeben. Jedoch bei den Operatoren der Ungleichheit (<, >, <= und >=):

12 < „“

liefert Excel einen Fehler. Also aufpassen: man darf nicht immer einfach rumdrehen!