Meine Lust ist gerade losgegangen meine Motivation zu suchen. Jetzt sind beide weg!

Hallo zusammen,

ich möchte folgendes in Excel durchführen.

Ich habe verschiedene Spalten in Excel mit Daten.

Spalte A:

Name

Spalte B:

Vorname

Spalte C:

Geburtsdatum

Spalte D:

Organisation

Excel soll mir jetzt die Einträge markieren die doppelt sind, jedoch nur wenn Name und Vorname identisch sind sprich Spalte A UND B.

Wie kann ich das am besten lösen.

Doppelte Werte anzeigen ist ja an sich nicht schwierig jedoch weiss ich nicht wie ich in dem o.g. Fall vorgehen muss.

Habt ihr da zufällig eine Lösung

Hallo Jörg,

hast du XVERGLEICH?

Dann könntest du es mit folgender Formel in der bedingten Formatierung lösen:

=WENNNV(XVERGLEICH($A2&$B2;$A3:$A$27&$B3:$B$27;0);0)+WENNNV(XVERGLEICH($A2&$B2;$A1:$A$1&$B1:$B$1;0);0)

wenn in A und B Name und Vorname stehen. Ich fange immer in einer Zelle an; trage dort die Bed. Formatierung ein und erweitere ANSCHLIESSEND den Bereich.

cool. Die Funktion xVergleich kenne ich gar nicht. Vielen Dank für den Tipp

XVERWEIS und XVERGLEICH erweitern SVERWEIS und VERGLEICH. Umgekehrt: ich habe es zuerst mit

=Zählenwenn(A:A&B:B;“Rene Martin“)

versucht – geht aber leider nicht … ZÄHLENWENN versagt hier … Schade!

3 comments

  • Ernst-Albrecht Börgener

    Hallo Rene,

    da ich mit der Desktop-Version Excel 2019 arbeite und mir somit die Funktion XVERGLEICH() nicht zur Verfügung steht, würde ich diese Formel anwenden.

    =WENN(SUMME(WENN($A2&$B2=$A$2:$A$10&$B$2:$B$10;1;0))>1;WAHR)

    Auch Ich fange immer in einer Zelle an und trage dort die Bedingte-Formatierung ein. Erst danach erweitere den Bereich.

    Salü

    Ernst

    • Medardus

      stimmt, Ernst – SO kann man auch denken.
      Danke für die Lösung.
      Allerdings: wenn wir Name | Vorname haben – was machen wir mit
      Martin | Irene
      Martini | Rene
      oder bei Vorname | Zuname:
      Andreas | Auer
      Andrea | Sauer
      ???

      • Ernst-Albrecht Brgener

        Rene dein Einwand ist richtig, Die Formel muss geändert werden um auch solche Fälle abzudecken
        Das einfachste ist wirklich die von dir vorgeschlagene Lösung, dass Einfügen eines Trennzeiche. Ich habe die Formel mit einem Ausrufungszeichen „!“ als Trennzeichen erweitert.

        =WENN(SUMME(WENN($A2&“!“&$B2=$A$2:$A$10&“!“&$B$2:$B$10;1;0))>1;WAHR)

        Salü
        Ernst

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.