Manchmal, wenn mir langweilig ist, kaufe ich Kondome, fülle sie mit Tapetenkleister und werfe sie durchs offene Schlafzimmerfenster auf die Straße.

Excel ist nicht konsistent im Umgang mit leeren Zellen. In den meisten Funktionen wird eine leere Zelle als 0 interpretiert. Aber eben halt nicht immer. Gestern habe ich mich mal wieder geirrt.

Ich wollte die Funktion HÄUFIG mit der Funktion ZÄHLENWENNS nachbauen – wollte die Bereiche definieren.

Mit der Funktion HÄUFIGKEIT (als Matrixfunktion) kann man berechnen, wie viele Daten in den entsprechenden Klassen vorhanden sind:

=HÄUFIGKEIT(B2:K11;M2:M7)

Also baue ich nach:

=ZÄHLENWENNS($B$2:$K$11;">"&M1;$B$2:$K$11;"<="&M2)

Die erste Zelle wird falsch berechnet – klar – weil in der Zelle Text steht:

Also lösche ich die Überschrift:

Das Ergebnis ändert sich nicht.

Klar, denn der Formelteil

">"&M1

wird nicht ausgewertet als >0, sondern nur als >.

Also doch: eine 0 einfügen – dann klappt es:

2 comments

  • Petra K.

    Hallo Herr Martin,

    da mich die Null und die fehlende Überschrift stören würden, wie wäre es mit: „>“&max(0;m1) ?

    Bei dieser Gelegenheit ein großes Dankeschön an Sie für diese fantastische Website !

    LG Petra

    • Medardus

      Hallo Petra,

      stimmt: MICH würde es auch stören – ich hätte auch erwartet, dass Excel die leere Zelle als 0 und nicht als „“ interpretiert – aber klar: ich verkette die Texte – deshalb wird leer als leerer Text interpretiert.
      Dein Vorschlag ist gut – ich würde sicherlich auch eine andere Formel verwenden …

      LG :: Rene

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.