Es gibt eigentlich nur drei Dinge, die man fürs Skifahren lernen muss: wie man die Skier anzieht, wie man bergab fährt und wie man einen Krankenhausflur entlangläuft. (Lord Mancroft)

Guten Morgen zusammen, vielleicht könnt Ihr mir helfen

Ich habe für meine Masterarbeit Wetterdaten bekommen und würde jetzt gerne aus den Zahlen für die Windrichtung den Text „Nord“, bzw. „Ost“ usw. generieren. Dabei ist

0<=x<45 => „Nord“

45<=x<135 => „Ost“

135<=x<225 => „Süd“

225<=x<315 => „West“

315<=x<380 => „Nord“

Dafür hab ich folgende WENN-Funktion verwenden wollen:

=WENN(0<=A2<45;“Nord“;WENN(45<=A2<135;“Ost“;WENN(135<=A2<225;“Süd“;WENN(225<=A2<315;“West“;WENN(315<=A2<380;“Nord“;“x“)))))

Wie Ihr auf dem Screenshot sehen könnt, zeigt mir Excel aber nur das „alternative“ x an… Ich kann mir aber nicht erklären warum?

Excel kennt kein „zwischen“. Du darfst nicht schreiben

0<=A2<45

sondern mit UND:

=WENN(UND(0<=A2;A2<45);“Nord“;WENN(UND(45<=A2;A2<135);“Ost“;WENN(UND(135<=A2;A2<225);“Süd“;WENN(UND(225<=A2;A2<315);“West“;WENN(UND(315<=A2;A2<380);“Nord“;“x“)))))

6 comments

  • Heinz-Jürgen Ladberg

    Ski fahren kann ich zwar nicht, aber für ein bischen EXCEL reicht es. Es gibt auch (mindestens) noch eine andere Möglichkeit, und zwar mir WAHL. Das würde dann so aussehen:
    =WAHL((A2>=0)*1+(A2>=45)*1+(A2>135)*1+(A2>225)*1+(A2>315)*1+(A2>360)*1;“Nord“;“Ost“;“Süd“;“West“;“Nord“;“x“)

    • Medardus

      danke für den Hinweis.
      Ich weiß: es gibt clevere Lösungen als meine.
      Ich wollte das Denken desjenigen, der gefragt hat, aufgreifen und „in Form“ bringen und zeigen, wie er das ZWISCHEN umsetzen kann.
      LG :: Rene

      • Medardus

        Nachtrag: WAHL ist eine sehr gute Wahl!
        Ich hätte formuliert:
        =WENNFEHLER(WAHL(GANZZAHL((A2+45)/90)+1;“Nord“;“Ost“;“Süd“;“West“);“x“)

    • Heinz-Jürgen Ladberg

      Noch etwas einfacher wird die Formel, wenn man den REST-Befehl nimmt. Dadurch werden Werte kleiner 0 beziehungsweise größer 360 automatisch in den Bereich von 0 bis 360 umgerechnet und auf das „x“ kann verzichtet werden.

      Formel 1 (mit N, O, S, W):

      =WAHL(GANZZAHL(REST(A2+45;360)/90)+1;UNIZEICHEN(8595)&“ Nord“;UNIZEICHEN(8592)&“ Ost“;UNIZEICHEN(8593)&“ Süd“;UNIZEICHEN(8594)&“ West“)

      Formel 2 (mit N, NO, O, SO, S, SW, W, NW):

      =WAHL(GANZZAHL(REST(A2+22,5;360)/45)+1;UNIZEICHEN(8595)&“ Nord“;UNIZEICHEN(8601)&“ Nordost“;UNIZEICHEN(8592)&“ Ost“;UNIZEICHEN(8598)&“ Südost“;UNIZEICHEN(8593)&“ Süd“;UNIZEICHEN(8599)&“ Südwest“;UNIZEICHEN(8594)&“ West“;UNIZEICHEN(8600)&“ Nordwest“)

      Der Befehl UNIZEICHEN(xxxx) zeigt zusätzlich zum Text auch noch ein Symbol für die Windrichtung an. UNIZEICHEN ist ab Excel 2013 verfügbar. In manchen Fällen ein sehr nützlicher Befehl.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.