Tag Archives: zählenwenn

Für Mädchen ist es besser nicht zu heiraten, aber Junx brauchen jemanden zum Putzen.

Ein Vortrag von Martin Weiß über Bedingte Formatierungen auf den Excellent Days. Er zeigt, wie man mit der Funktion ZÄHLENWENN alle Zahlen einfärben kann, mehr als drei mal vorkommen. Die Formel in der Bedingte Formatierungen lautet:

=ZÄHLENWENN($A$3:$O$32;A3)>3

Alle machen brav mit. Mein Nachbar wundert sich, warum bei ihm keine Zelle rot eingefärbt wird. Er schaut in den Manager für Regeln zur Bedingten Formatierung und wundert sich über die Formel:

=ZÄHLENWENN($A$3:$O$32;XEQ1048550)>3

Der Grund ist einfach: Er hat den Bereich von rechts unten nach links oben markiert. Deshalb wird ein relativer Bezug A3 in der Zelle A3 umgesetzt in: 30 Zeilen nach oben und 15 Spalten nach links. So kommt XEQ1048550 zustande.

Damit so etwas Nervendes nicht passiert, schlage ich ein anderes Vorgehen vor:

Ich beginne im ersten Schritt mit einer Zelle, beispielsweise A3 (oder O32) und aktiviere dort die Bedingte Formatierung:

Im zweiten Schritt aktiviere ich erneut den Regelmanager (Start / Bedingte Formatierung / Regeln verwalten) und dehne nun den Bereich aus:

Das klappt:

Okay – ein Schritt mehr – aber ich bin auf der sicheren Seite. Damit Excel nicht mehr nervt!

 

In den 10 Minuten bevor meine Mutter zu Besuch kommt, schaffe ich mehr Hausarbeit als in einer Woche.

Hallo René

Ich möchte die Rückläufer auswerten

Ich habe vor alle blätter in eine mappe zu kopieren

Dann mit =ZÄHLENWENN(‚ANFANG:ENDE‘!B16;“Ja“) auszuwerten

Ich bekomme #WERT! Zurück

Geht zählenwenn nicht über mehrere Arbeitsblätter nicht?

Ich habe es mit INDIREKT(„‚ANFANG:ENDE‘!B16“;TRUE) … versucht; dann bekomme ich #BEREICH!

Ich weiß, wir hatten das am Stammtisch und du hast auch was gesagt, geschriebenes finde ich nicht

Liebe Grüße

Stefan

Hallo Stefan,

schau mal, was ich vor einem Jahr veröffentlicht habe:

http://www.excel-nervt.de/die-stille-zeit-ist-zu-ende-jetzt-wird-es-wieder-ruhig-karl-valentin/

Also doch anders …

Liebe Grüße

Rene

;-(

Ich brauche EXCELlent DAYS zur Weiterbildung

Viele Grüße

und Danke

Stefan

Meditieren ist immer noch besser, als rumsitzen und nichts tun.

Heute in der Excelschulung. Ich zeige den Teilnehmer das „Leerzeichenproblem“: Manchmal geben Anwender und Anwenderinnen am Ende eines Textes Leerzeichen ein, das man nicht sichtbar machen kann. Das ist fatal beim Sortieren, bei Pivottabellen, die Funktionen WENN, ZÄHLENWENN, SUMMEWENN rechnen vermeintlich falsch … Man kann solche Leerzeichen mit der Funktion RECHTS ausfindig machen, man kann sie mit GLÄTTEN entfernen, … All das zeige ich. Weise darauf hin, dass man (zugegeben: sehr schlecht!) die Leerzeichen sichtbar machen kann, wenn man die Texte rechtsbündig formatiert:

Eine Teilnehmerin meldet sich und fragt, warum bei ihr die Texte am Ende KEINE Lücke aufweisen, obwohl sie ein Leerzeichen eingefügt hat:

Die Antwort: Wenn am Ende eines Textes sich ein Leerzeichen befindet, wird es unterdrückt, wenn ein Textumbruch eingeschaltet ist !?!

Die Sünde ist der beste Teil der Reue

Schon seltsam.

Eine Liste enthält Texte und Zahlen. Ich möchte herausfinden, wie viele Zellen gefüllt sind. Ich versuche ZÄHLENWENN. Wir wissen, das zwei Anführungszeichen innerhalb eines Textes als ein Anführungszeichen interpretiert wird. Also versuche ich:

=ZÄHLENWENN(C2:C15;“<>“““““)

Es scheitert!

Obwohl die Bedingung <>““ korrekt arbeitet, muss man die Bedingung folgendermaßen formulieren:

=ZÄHLENWENN(C2:C15;“<>“)

Analog werden die Anzahl der leeren Zellen ermittelt:

=ZÄHLENWENN(C2:C15;“=“)

Dann klappt es.

Beim nächsten Mal verwende ich wieder:

=ANZAHL2(C2:C15)

oder:

=ZEILEN(C2:C15)-ANZAHLLEEREZELLEN(C2:C15)

Ich kann 3 stimmig singen … laut, falsch und mit voller Begeisterung

Heute im Excel-Coaching in einer Rechtsanwaltskanzlei.

Die Aufgabe: Aus einer Liste von Prozesskosten soll eine Übersicht erstellt werden, wir oft Kosten im Bereich 0 – 10.000 Euro, 10.000 – 20.000 Euro 20.000 – 30.000 Euro und so weiter vorhanden sind. Ich überlege: ZÄHLENWENN oder HÄUFIGKEIT? Ich entscheide mich für eine Pivottabelle. Schnell erstellt, schnell gruppiert – aber: padautz!

„Kann den markierten Bereich nicht gruppieren.“

Dieser Satz hat kein Subjekt. Und auch keine Begründung. Versuche es mehrmals, ziehe, schiebe, lösche … geht nicht. Bis ich ans Ende der Pivottabelle schaue:

Da hat doch tatsächlich jemand Zahlen falsch eingegeben: 49,240.8 oder 11,593.00. Und hat auch noch einige Texte eingetragen: „to be added“, bzw. „t.b.a.“ Also doch ZÄHLENWENN …

Hatte Kribbeln im Bauch … dachte schon bin verliebt … aber war doch nur Hunger …

Schon mal probiert?

Eine Datei greift mit einer Formel auf eine zweite Datei zu. Kein Problem.

Doch: ist ein Problem – nämlich, wenn es sich bei der Formel um SUMMEWENN, ZÄHLENWENN & co handelt. Dann muss nämlich die Quelldatei offen sein, damit kein Fehler angezeigt wird. Sehr erstaunlich!

Ich bin sehr wohl spontan … wenn man mir früh genug Bescheid sagt

Eigentlich unterscheidet Excel zwischen Text und Zahl. Eigentlich. Sicherlich kennen Sie folgendes Phänomen:

Eine Spalte ist als Text formatiert:

In einer anderen Spalte stehen ZAHLEN. Diese werden mit der Funktion SVERWEIS als #NV (nicht vorhanden) quittiert:

Das habe ich schon mehrmals beschrieben – beispielsweise in: „Sverweis funktioniert nicht“
Ebenso werden sie bei der Überprüfung auf Gleichheit

{=ODER(K2=$G$2:$G$22)}

(als Matrixformel) korrekt als unterschiedliche Werte erkannt:

Verwendet man statt dem Gleichheitsoperator „=“ jedoch die Funktion IDENTISCH werden die Texte und Zahlen als gleich(wertig) eingestuft:

{=ODER(IDENTISCH(K2;$G$2:$G$22))}

Ebenso übergeht ZÄHLENWENN diesen Unterschied:

Auch hier gilt mal wieder – schade, dass Excel an so vielen unterschiedlich ist, beziehungsweise einfach nicht konsequent. Kein Verlass auf gar nichts!

Ich brauche keinen Mittelfinger, ich kann das mit den Augen.

Heute in der Excel-Schulung. Ein Teilnehmer zeigt mir seine Lösung, wie er die Anzahl der Zahlen im 90er-Bereich ermittelt hat: Er berechnet die Differenz zweier ZÄHLENWENN-Funktionen:

=ZÄHLENWENN(C8:C37;“<100″)-ZÄHLENWENN(C8:C37;“<90″)

Ich zeige seinen Ansatz der Gruppe. Mit dem Funktionsassistenten rufe ich Zählenwenn auf:

Schritt 1

Schritt 1

Normalerweise trägt Excel im Funktionsassistenten um die Bedingung <100 automatisch die Anführungszeichen ein. Jedoch ein Klick in die Bearbeitungsleiste lehrt mich eines Besseren:

Schritt 2

Schritt 2

Ich fahre fort: tippe ein Minus und rufe erneut den Funktionsassistenten auf:

Schritt 3

Schritt 3

Der Blick in die Bearbeitungsleiste zeigt mir, dass die Anführungszeichen in der ersten Funktion fehlen. Und richtig: Das Bestätigen der Funktion wird mit einer Fehlermeldung quittiert:

Schritt 4

Schritt 4

Schade – denn gerade der Funktionsassistent nimmt Anwendern und Anwenderinnen, die mit Formeln noch nicht so sehr geübt sind, die Arbeit an vielen Stellen ab …

Also doch: Ich zeige dem Teilnehmer ZÄHLENWENNS, die ihm sehr gut gefällt …

Gestern bei offenem Fenster geschlafen. 10.569 Mücken gefällt das.

Hallo Herr Martin,
ich habe eine Liste, bei der ich Auswertungen erstellen soll. Es geht dabei um eine Gewichtung. Folgender Schlüssel liegt der Tabelle zugrunde:

20160912gewichtung01

Ich erstelle eine Formel:

=ZÄHLENWENN(C5:C70;“*x*“)*1+ZÄHLENWENN(C5:C70;“*P*“)*2+ZÄHLENWENN(C5:C70;“*EG*“)*3+
ZÄHLENWENN(C5:C70;“*En*“)*4+ZÄHLENWENN(C5:C70;“*Ew*“)*5+ZÄHLENWENN(C5:C70;“*Ek*“)*2+
ZÄHLENWENN(C5:C70;“*Em*“)*3+ZÄHLENWENN(C5:C70;“*B*“)*4+ZÄHLENWENN(C5:C70;“*A*“)*4+
N(„ZÄHLENWENN(C5:C70;““*Aw*““)*4″)+ZÄHLENWENN(C5:C70;“*K*“)*1+ZÄHLENWENN(C5:C70;“*V*“)*1+ZÄHLENWENN(C5:C70;“*U*“)*1

Vielleicht nicht clever – aber nachvollziehbar. Der Wert „Aw“ wurde auskommentiert – deshalb die Funktion „N“. Allerdings – an einer Stelle rechnet er nicht richtig – ich finde den Fehler nicht:

20160912gewichtung02

Die Antwort: Man muss schon genau hinschauen. Sie haben in die Matrix weitere Informationen eingetragen. Bei Frau Weiß finden sich die beiden Texte SPX. Dort wird das „x“ natürlich auch mitgezählt. Diese Texte dürfen Sie nicht in die Tabelle schreiben.

20160912gewichtung03

Vier von drei Leuten können nicht rechnen.

Heute in der Excel-Schulung. Eine Teilnehmerin zeigte mit eine Datei. Mit fiel auf, dass der Filter (hier: Black-Mitglieder) eine andere Zahl lieferte als die Funktion ZÄHLENWENN. Eine Pivottabelle lieferte das gleiche Ergebnis wie der Filter. Die Ergebnisse von ZÄHLENWENN waren um 1 zu groß.

Kann Excel nicht bis drei zählen?

Kann Excel nicht bis drei zählen?

Ich gestehe – ich habe eine Weile gesucht. Bis ich entdeckt hatte, dass über der Tabelle einige Zellen ausgeblendet waren. Und: richtig – dort stand die Liste, die als Bereich für die Datenüberprüfung verwendet wurde. Da ZÄHLENWENN die ganze Spalte zählte … Tja – halt einer zu viel.

Und hier wurde der Übeltäter versteckt.

Und hier wurde der Übeltäter versteckt.

Neugier ist die erste Stufe zur Hölle.

Ich will das auch sehen. Wenn mein Kollege die Funktion ZÄHLENWENN verwendet, sieht er bereits im Dialog das Ergebnis:

Das Ergebnis der Formel wird angezeigt.

Das Ergebnis der Formel wird angezeigt.

Bei mir jedoch nicht:

Hier nicht!

Hier nicht!

Erst wenn ich den Assistenten mit OK bestätige, steht das richtige Ergebnis in der Zelle. Warum bei mir nicht?

Die Antwort: Ihr Kollege sucht den Ort, indem er dort bereits die Anführungszeichen setzt. Sie haben keine Anführungszeichen eingegeben – de Text – hier Ulm – wird noch nicht als Text erkannt. Erst beim Bestätigen interpretiert der Funktionsassistent die drei Buchstaben Ulm als Text und ermittelt dann das richtige Ergebnis (und schreibt die Anführungszeichen in die Formel).

Ohne einen einzigen Feiertag

Warum klappt das nicht? Ich habe versucht – genau wie im Internet erklärt – einen Kalender zu erstellen. Ich habe die Feiertage berechnet und versuche auf meinem Kalender die Feiertage mit der Funktion ZAEHLENWENN anzeigen zu lassen. Aber er tut es nicht. Nicht einen einzigen Feiertag!

Die bedingte Formatierung funktioniert nicht.

Die bedingte Formatierung funktioniert nicht.

Die Antwort: Sie haben statt ZÄHLENWENN ZAEHLENWENN geschrieben. Erstaunlicherweise übergeht die bedingte Formatierung Tippfehler in den Funktionsnamen und – liefert gar nichts!

Mit ZÄHLENWENN funktioniert es!

Mit ZÄHLENWENN funktioniert es!

 

Zählenwenn rechnet nicht

Warum rechnet die Funktion ZÄHLENWENN (übrigens auch SUMMEWENN) manchmal nicht?

ZÄHLENWENN rechnet nicht.

ZÄHLENWENN rechnet nicht.

Schauen Sie die Funktion genau an. ZÄHLENWENN (und auch SUMMEWENN) verlangt als Reihenfolge zuerst WO wird etwas gesucht und anschließend WAS wird gesucht. Wenn Sie die Reihenfolge vertauschen, zählt er, wie oft der Bereich in der einen Zelle vorkommt und liefert kein Ergebnis.

Die Reihenfolge ist hier falsch.

Die Reihenfolge ist hier falsch.

ZÄHLENWENN zählt zu wenig

Warum ermittelt die Funktion ZÄhLENWENN (und SUMMEWENN) nicht die richtige Zahl?

Zähelnwenn zählt falsch ?!

Zählenwenn zählt falsch ?!

Man muss sich die einzelnen Daten ansehen. In der Bearbeitungsleiste stellt man fest, dass in einigen der Texte noch weitere Informationen („München“) stehen (sie wurden übrigens weiß formatiert). Man hätte auch durch ein Ändern der Ausrichtung auf rechtsbündig feststellen können, dass hinter dem angezeigten Text noch etwas steht.

Die Bearbeitungsleiste liefert das Ergebnis

Die Bearbeitungsleiste liefert das Ergebnis

Oder man formatiert die Zellen rechtsbündig.

Oder man formatiert die Zellen rechtsbündig.

Übrigens: =ZÄHLENWENN(D2:D10;“Rene Martin*“) hätte die korrekte Anzahl ermittelt.