Tag Archives: WENN

Ich weiß, du hast recht – aber meine Meinung gefällt mir besser.

Hallo Herr Martin,

ich befinde mich derzeit in einem Excel-Grundkurs und bin bei einer „verschachtelten Wenn-Funktion“ auf folgende Problematik gestoßen:
Excel rechnet nicht weiter, sobald der erste „Wahr“wert erreicht ist, was zu logischen Fehlern führt, sofern die Abfragewerte aufsteigend abgefragt werden.
Der „Sonst“Wert wird allerdings korrekt ausgegeben.
In meinem Beispiel habe ich dann die Abfragewerte 25% und 20% umgekehrt und es hat wie geplant funktioniert.
Wo liegt mein Fehler?
Haben Sie eventuell eine Idee zur Vereinfachung der Funktion?
Im voraus vielen Dank für Ihre Hilfe.
Mit freundlichen Grüßen
Jan

Hallo Herr S.,

Sie haben recht: Excel arbeitet Wenn-Funktionen baumartig ab. Also:

Wenn > 80% dann

wenn > 75% dann

sonst: Rest <= 75%

Sie können es aber auch „umbauen“:

wenn <= 75% dann

wenn <= 80% dann

Rest: sonst > 80%

Tipp: ich zeichne manchmal so eine Baumstruktur auf, um es besser zu verstehen.

Tipp 2: schreiben Sie 2 und 5 und nicht „2“ oder „5“. Sie möchten ja mit dem Zahle weiterrechnen. Sie können übrigens auch 2% und 5% verwenden

Hallo Herr Martin,

vielen dank für die schnelle Antwort.

Das ganze ist ja ganz schön verwirrend, gibt es dann noch eine andere Funktion die das Ziel einfacher erreicht?

Schöne Grüße

Jan

Hallo Herr S.

schauen Sie sich einmal die Funktion SVWEIS an – dort werden mehrere Fälle auf einer Ebene abgearbeitet.

Das Universum spielt nicht immer fair, aber dafür hat es einen höllischen Sinn für Humor

Hallo René,

und hier sende ich Dir die Datei mit meinen Hinweisen.
Aber warum nimmt Excel die neuen Zielumsätze (denen kein Umsatz vorausgegangen war) nicht ins Gesamtergebnis auf?
Ich berechne: Zielumsatz = WENN(Umsatz>0;Umsatz*110%;500)
Viele Grüße
Angelika

Hallo Angelika,

Ich weiß wo der Denkfehler – oder der Pivotfehler steckt:

Pivot rechet nicht Summe der einzelnen berechneten Werte, sondern: berechnet die Summe:

Also nicht (in deinem Beispiel 3.045,90 + 500,00 + 594,83 + 2.692,80), die ja berechnet sind: = WENN(Umsatz>0;Umsatz*110%;500)

sondern Pivot rechnet: 2.769,00 + 0,00 + 540,75 + 2.448,00. Wenn diese Summe (5.757,75) > 0;Umsatz*110%;500) -> also 5.757,75 + 1,1 = 6.333,53

Nervt Excel?

Liebe Grüße  ::  Rene

 

Aus Langeweile hätte ich eben fast gearbeitet. Man muss aber auch höllisch aufpassen.

Gestern in der Excel-Schulung. Wir üben die WENN-Funktion. Standard-Beispiel: eine Provisionsberechnung. Ein Teilnehmer ruft mich, weil er eine Fehlermeldung erhält:

Ich gestehe: ich habe drei Mal hinschauen müssen, bis ich es entdeckt hatte: das schließende Anführungszeichen bei dem Sonst-Zweig (Wert_wenn_falsch) fehlt.

Denken ist wie googeln – nur krasser.

Amüsiert war ich schon. In einer Firma sollte ich letzte Woche Excel-Formeln anpassen. Man erklärte mir, dass jeder Auditvorgang ein Revisionsdatum hat. Möglicherweise auch ein zweites und ein drittes. Wenn es ein drittes Datum gibt, gibt es auch ein zweites. Also: die Tabelle ist gefüllt: entweder 1. Datum oder 1. und 2. oder 1. und 2. und 3. oder alle vier Spalten sind mit einer Datumsinformation gefüllt.

20170129Anzahl

Ein Kollege hatte eine Formel erstellt:

=WENN(H2=““;1;WENN(I2=““;2;WENN(J2=““;3;4)))

Meine Aufgabe war es diese Formel für weitere Datumsangaben anzupassen. Ich war etwas irritiert.

=ANZAHL(G2:J2)

hätte das Gleiche getan. Und ist leichter anzupassen. Die Teilnehmer waren begeistert und glücklich.

Excel hält sich nicht an die Theoreme der Prädikatenlogik

Kennen Sie das: Ich benötige eine Liste, die sich dynamisch fortsetzt. In einer Zelle wird ein Wert eingetragen – die Nummer eines Zählers soll nur bis nur eingetragenen Nummer angezeigt werden.

Die Formel:

=WENN(A9=$B$4;A9+1;““)

funktioniert problemlos –

=WENN(A9=$B$4;““;A9+1)

jedoch nicht.

Einer geht und einer nicht.

Einer geht und einer nicht.

20160626weiter01

Der Grund ist offensichtlich. Befindet sich in einer Zelle ein leerer String („“), kann Excel zwar problemlos den Ausdruck

12 = „“

auswerte und FALSCH zurückgeben. Jedoch bei den Operatoren der Ungleichheit (<, >, <= und >=):

12 < „“

liefert Excel einen Fehler. Also aufpassen: man darf nicht immer einfach rumdrehen!

Wenn das Wörtchen WENN nicht wär‘ …

Sehr geehrter Herr Dr. Martin,

Wahrscheinlich haben Sie wesentlich schneller eine Lösung parat als ich, die ich nun schon stundenlang damit rummache und jetzt irgendwie aufgebe.

Es geht um dieselbe Tabelle, also diese Zeitberechnung.

Nun soll aber noch folgendes dazu berechnet werden.

Wenn die Stundenanzahl >= 6 Stunden sollen 0,5 Stunden abgezogen werden, wenn die Stundenanzahl >= 10 Stunden soll eine Stunde abgezogen werden.

Ich habe versucht, mich langsam heran zu tasten und habe sogar die > 6 Stunden und >10 Stunden einzeln herausbekommen. Allerdings bekomme ich nun beim besten Willen diese ganzen Schachteln nicht zusammengesetzt…(Das mit dem „=“ dazu hat auch nicht so funktioniert…)

Haben Sie eine (schnelle) Lösung oder eine passende Erklärung mit einem Link?

Die Tabelle mit meinen Versuchen ist angehängt. Wie ich gelesen hatte, muss man dazu die Uhrzeit wieder in eine normale Zahl formatieren, was ich getan habe.

Herzlichen Dank für Ihre Bemühungen.

####

Stundenberechnung

Stundenberechnung

Hallo Frau P.,

Ich denke, Ihr Problem resultiert aus Folgendem: Sie sollten sich einen Baum malen, der die verschiedenen Fälle auflistet: tagsüber gearbeitet oder nachts? In beiden Fälle: mehr als 10 Stunden – > ja: eine Stunde abziehen. Nein: – > wenn mehr als sechs Stunden: -> ja, 0,5 Stunden abziehen – sonst nichts.

Und so müssen Sie die Formel eingeben.

Kommen Sie damit klar?

####

Hallo Herr Dr. Martin,

Jetzt habe ich gesehen, dass Sie die Sachen ja alle schon richtig ausgefüllt haben.

Das Resultat ist in „Zahl“ formatiert. Ich glaube, es wäre auch mit der „Uhrzeit 37:…“ gegangen. Allerdings nicht mehr in dieser Version.

Ich kann es nur hinnehmen und Ihnen danken, dass Sie es eingerichtet haben. Vom Verständnis bin ich leider noch etliches entfernt.

Aber ich denke, meine Kolleginnen werden sich freuen, endlich eine funktionierende Zeitberechnung zu haben. Bleibt zu hoffen, dass ihnen nicht noch etwas Neues einfällt…

Also noch einmal: Herzlichen Dank!

Ich wünsche Ihnen noch einen schönen Tag.

####

Gerne, Frau Pojer,

wenn Sie es verstehen möchten, machen Sie Folgendes:

Klicken Sie auf eine Zelle mit einer Formel. Klicken Sie auf den Funktionsassistenten.

Sie sehen die Bedingung. Klicken Sie nun in die Bearbeitungszeile auf den Teil den Sie sehen möchten. So können Sie sich den Baum entlanghangeln:

Der Funktionsassistent

Der Funktionsassistent

Umgekehrt: gehen Sie an ein solches Problem mit einem Blatt Papier und einem Stift ran. Ich „mal gerne Bäume“. Sicherlich kennen Sie diese Ablaufdiagramme: sie helfen:

Ein kleines Diagramm - als Hilfe

Ein kleines Diagramm – als Hilfe

Da fehlt doch was!

Ein Kollege von mir hat mir eine Formel in Excel erstellt. Ich verstehe die Formel aber nicht. Im dritten WENN-Teil fehlt doch ein Teil, oder?

Fehlt da nicht etwas?

Fehlt da nicht etwas?

Die Antwort: Schauen wir uns die Formel mal genauer an:

=WENN(AJ2=““;““;WENN((AJ2)>14;“zu lang“;WENN(AJ2<=14;“ok“;)))

Der erste Teil ist klar (=WENN(AJ2=““;““): Wenn die Zelle AJ2 leer ist, dann bleibe ich selbst auch leer. Prima.

Im zweiten Teil wird überprüft, ob in AJ2 ein Wert größer als 14 steht:

WENN((AJ2)>14;“zu lang“

Wenn das erfüllt ist, so liefert die Formel den Text „zu lang“. Nun wollte der Kollege überprüfen, ob der Wert kleiner oder gleich 14 ist. Er hat dies mit einer weiteren WENN-Funktion realisiert. Das ist nicht falsch, aber überflüssig.

Ich würde die Formel folgendermaßen schreiben:

=WENN(AJ2=““;““;WENN((AJ2)>14;“zu lang“;“ok“))

Sie liefert das gleiche Ergebnis und ist viel kürzer.

So geht es auch - das ist sogar eleganter!

So geht es auch – das ist sogar eleganter!