Tag Archives: Uhrzeit

Ich gehe absichtlich nicht ins Fitnessstudio – ich möchte nicht so aussehen, als könnte ich irgendwem beim Umzug helfen !

Es ist schon verblüffend: In einer Datei stehen Uhrzeiten. Sie werden mit dem benutzerdefinierten Format „mm“ formatiert.

Speichert man die Datei, schließt sie und öffnet sie erhält man andere Angaben:

Ein Blick in das Format verrät, dass aus mm MM wurde:

Die Lösung: man muss sie mit [mm]. Dann übersteht dieses Format auch das Speichern:

Danke an meine Kollegin Angelika Meyer für die Frage und an meinen Kollegen Stefan Lau.

Ein Text ist ein Text ist ein Text

Was passieren kann, wenn man einen Text als Text formatiert – darauf habe ich schon hingewiesen. Auch was passiert, wenn man einen (langen) Text als Buchhaltung formatiert:

Amüsant ist dagegen auch folgendes Phänomen: Wenn man einen Text als Datum, Prozentwert oder Währung formatiert:

und dann mit der Funktion LÄNGE weiter rechnet – allerdings mit mindestens zwei Rechenoperationen (beispielsweise LÄNGE – 1 oder LÄNGE x 1), dann wird das Zahlenformat übernommen:

Erstaunlicherweise: FINDEN und SUCHEN liefern auch Zahlen – sie übernehmen jedoch nicht das Zahlenformat.

Ungeschoren bleiben ist der Wunsch aller Schafe

Sehr geehrter Herr Martin!

Ich verfolge begeistert Ihre V2B Kurse!

Ich bin Anfänger in Excel und habe für ein  spezifisches Problem bislang keine passende Lösung gefunden.

Wär fein, wenn Sie mir weiterhelfen können.

Ich möchte die negativen Stunden in Spalte F mit Vorzeichen „minus“ und in roter Farbe angezeigt bekommen. Formatiert als Zeit, so dass ich die Spalte summieren kann.

Rechenvorgang: D44-G44-E44 bzw. AZ IST minus AZ SOLL minus Mittagspause 30 Minuten (nur bei AZ IST größer als 6 Stunden, bis größer gleich 6 Stunden, keine Mittagspause).

Wäre nett, wenn Sie mir hier weiterhelfen können.

Vielen Dank im Voraus!

Mit freundlichem Gruß

######

Hallo Herr D.,

eigentlich geht das nicht.

Excel beginnt bei den Datumsangabe am 01.01.1900. Das heißt: 12:00 Uhr wird intern behandelt wir ein halber Tag seit dem 01.01.1900 – also 0,5. Wenn Sie nun -06:00 Stunden haben möchten, wird dies als 31. Dez. 1899 18:00 Uhr behandelt – das geht eigentlich nicht.

Und jetzt zum „eigentlich“:

Sie können in den Optionen /Erweitert den beginn auf 1904 „hochsetzen“ – dann haben Sie zwischen 199 und 1904 vier Jahre „Puffer, in denen Sie mit negativen Uhrzeiten rechnen können.

Ich rate allerdings davon ab, weil dann alle Datumsangaben in dieser Datei um vier Jahre verschoben werden. Und ich sehe in Ihrer Liste 28.05.2016

Alternative: Ich würde Hilfsspalten verwenden: +/- AZ pos:

=WENN(D8-G8-E8>0;D8-G8-E8;0)

+/- AZ neg:

=WENN(D8-G8-E8<0;ABS(D8-G8-E8);0)

Hilft Ihnen das?

######

Hallo Herr Martin!

Ja, so mach ich`s.

Vielen herzlichen Dank für Ihre Hilfe!

Schöne Grüße nach München!

Komische Uhrzeit

Ich wollte nur einen kleinen S-Bahn-Fahrplan erstellen. Da die S-Bahn alle 20 Minuten fährt, habe ich zwei Spalten mit den Uhrzeiten eingetragen, markiert und rübergezogen. Aber irgendwie will der nicht …

Komische Uhrzeiten

Komische Uhrzeiten

Die Antwort können Sie selbst erkennen: Sie haben keine Uhrzeiten eingetragen, sondern diese als Text gekennzeichnet (’05:11 statt 05:11). Deshalb erkennt Excel diese nicht als Uhrzeiten und zählt nur die „Zahlen“ weiter.

jetzt oder nie!

Das ist seltsam: Ich kenne die beiden Tastenkombinationen [Strg] + [.] und [Strg] + [:]. Damit wird das aktuelle Datum und die aktuelle Uhrzeit in die Zelle geschrieben. Was mich jedoch erstaunt ist, dass die erste Zelle als „Datum“ formatiert wird, die zweite „benutzerdefiniert“. Warum?

DatumUhrzeit20151014_1

Datum und Uhrzeit

Datum und Uhrzeit

Zugegeben: das ist ein bisschen verwirrend. Allerdings: Wenn Sie die Uhrzeit mit 14:00 eintragen, wie sie auch „benutzerdefiniert“ formatiert – in der Form „hh:mm“. Das Format „Uhrzeit“ setzt Stunde:Minute:Sekunde voraus. Wenn Sie es so eingeben, wird es als „Uhrzeit“ formatiert. Sonst eben „benutzerdefiniert“. Übrigens erhalten Sie auch das Zahlenformat „benutzerdefiniert“, wenn Sie ein Datum in der Form 24-12 oder 24.12 eintragen.

[Strg]+[,]

In der letzten Excel-Schulung habe ich gelernt, dass man mit der Tastenkombination [Strg]+[,] die Information von der darüber liegenden Zelle wiederholen kann. Bei „Hexachloral active sample 1“ und bei „30“ hat es prima geklappt – eine tolle Tastenkombination, die Kopieren und Einfügen spart. Allerdings – beim Datum und bei der Uhrzeit – sehr seltsam, was hier passiert. DAS steht bestimmt nicht drüber!

Informationen wiederholen

Informationen wiederholen

Die Antwort: Die leeren Zellen sind mit dem Zahlenformat „Standard“ formatiert. Wenn Sie nun das Datum und die Uhrzeit in diese so formatierte Zelle schreiben, übernimmt Excel leider nur den Wert – man muss die Zelle noch als Datum und Uhrzeit formatieren. Hier ist [Strg]+[,] gegenüber kopieren und einfügen sicherlich kein Gewinn.

Sie könnten entweder die Spalte als Datum, beziehungsweise Uhrzeit vorformatieren – dann klappt [Strg]+[,]. Oder Sie ziehen die obere Zelle mit gedrückter [Strg]-Taste am Rand herunter – mit Drag & Drop kann man sie auch kopieren.

Excel summiert Uhrzeiten nicht richtig

Doch. Aber Excel schafft den Sprung in den neuen Tag, also über die 24-Stunden-Grenze nicht.

Die Lösung: Sie müssen die Uhrzeit vom Typ [h]:ss formatieren. Oder in der Kategorie „Uhrzeit“ finden Sie ein Beispiel „37:30:50“. Das macht das Gleiche.

Stunden werden falsch formatiert.

Stunden werden falsch formatiert.

Die Summe ist korrekt; sie muss mit [h]:ss formatiert werden.

Die Summe ist korrekt; sie muss mit [h]:ss formatiert werden.