Tag Archives: Summe

Wer morgens kalt duscht, lügt auch den Rest des Tages

Irgendwie doof. Mal wieder nicht konsistent.

Kennen Sie das? Ich erstelle eine Liste mit Verkäufernamen, Monatsnamen und Umsatzzahlen. Über Formeln / Definierte Namen / Aus Auswahl erstellen werden die Spaltennamen und Zeilennamen zu Namen der entsprechenden Zeile und Spalte:

Nun kann man die Schnittmenge berechnen:

=Roth Umsatz

Leider kann man diese Werte nicht auslagern – das führt zu einem Fehler:

Das ist erstaunlich, denn folgende Formeln funktionieren problemlos:

=SUMME(INDIREKT(„C2:C7“))

=SUMME(INDIREKT(„Umsatz“))

Aber eben leider nicht:

=SUMME(INDIREKT(„Umsatz Roth“))

und auch nicht:

=SUMME(INDIREKT(„C2:C5 C3:C7“))

Schade, dass INDIREKT keine Schnittmenge verarbeiten kann.

Nachtrag: Danke an XLarium für den wertvollen Hinweis (⇓):

Es funktioniert mit:

=INDIREKT(„Umsatz“) INDIREKT(„Roth“)

und:

=SUMME(INDIREKT(„C2:C5“) INDIREKT(„C3:C7“))

Das Universum spielt nicht immer fair, aber dafür hat es einen höllischen Sinn für Humor

Hallo René,

und hier sende ich Dir die Datei mit meinen Hinweisen.
Aber warum nimmt Excel die neuen Zielumsätze (denen kein Umsatz vorausgegangen war) nicht ins Gesamtergebnis auf?
Ich berechne: Zielumsatz = WENN(Umsatz>0;Umsatz*110%;500)
Viele Grüße
Angelika

Hallo Angelika,

Ich weiß wo der Denkfehler – oder der Pivotfehler steckt:

Pivot rechet nicht Summe der einzelnen berechneten Werte, sondern: berechnet die Summe:

Also nicht (in deinem Beispiel 3.045,90 + 500,00 + 594,83 + 2.692,80), die ja berechnet sind: = WENN(Umsatz>0;Umsatz*110%;500)

sondern Pivot rechnet: 2.769,00 + 0,00 + 540,75 + 2.448,00. Wenn diese Summe (5.757,75) > 0;Umsatz*110%;500) -> also 5.757,75 + 1,1 = 6.333,53

Nervt Excel?

Liebe Grüße  ::  Rene

 

Auf diese Frage antworte ich mit einem entschiedenen Vielleicht.

Hi René,

ich kriege grad seit 2 h einen Vogel mit Pivot:

Habe unterschiedliche Mitarbeiter, die unterschiedliche Bonisätze bekommen sollen.

Die Bonitabelle liegt in anderem Tabellenblatt.

Damit ich in Pivot für jeden MA den richtigen Bonusbetrag anzeigen kann, habe ich mir mit SVerweis die Sätze in meine Ausgangstabelle geholt.

Und ein Feld berechnet. Soweit alles schön…

…nur, der Bonusbetrag ist um den Faktor 10 zu hoch!

Wer macht da was falsch : ich oder Excel?

Hiielfe! Kannst Du helfen?

Viele Grüße – Angelika

#####

Hallo Angelika,

der Knackpunkt in der Pivottabelle liegt im berechneten Feld. Das kann man leicht zeigen. Bau mal folgende Tabelle auf:

Setze eine Pivottabelle auf, gruppiere die Namen, summiere die Beträge:

Wenn du nun ein berechnetes Feld einfügst – Betrag * Provision – stellst du fest, dass die berechnete Provision doppelt so hoch ist, wie sie sein sollte:

Der Grund: die beiden Provisionssätze für Rene werden summiert (5% + 5% = 10%) und diese Zahl mit der Summe der Beträge multipliziert. Wenn du die Summe mit 5% multiplizieren möchtest, musst du den Provisionssatz (über einen SVERWEIS) reinholen und damit multiplizieren. Dann klappt es:

Ich spreche drei Sprachen: ironisch, sarkastisch und zweideutig.

Auf nichts ist mehr Verlass:

Ich trage einige Zahlen in Excel ein. Schalte den Autofilter ein, filtere die Daten. Unter der Liste ein Klick auf das Summen-Symbol – die Funktion TEILERGEBNIS mit dem Parameter 9 wird verwendet. Nur die gefilterten Daten werden summiert.

20170207Teilergebnis01

Ich markiere eine Zeile und blende sie aus:

20170207Teilergebnis02

Ich bin irritiert: Die ausgeblendete Zeile wird nicht summiert.

Irritiert deshalb, weil die Hilfe erläutert, dass der Parameter 109 die ausgeblendeten und gefilterten Daten nicht summiert, der Parameter 9 jedoch nur die gefilterten.

Ich schalte den Filter aus, blende die Zeile aus – sie wird JETZT nicht mitsummiert.

Das heißt: der Parameter 9 summiert Werte von ausgeblendeten Zeilen, wenn kein Filter gesetzt ist, summiert sie jedoch nicht, bei einem eingeschalteten Filter.

Da ist doch was faul!

Danke an Maximilian für den Hinweis.

Manchmal wäre ein bisschen weniger doch ein bisschen hilfreicher

Excel-Schulung. Ich erkläre die Funktion SUMME. Anschließend eine Übung. Unter der Spalte mit den laufenden Nummern soll die Summe der Preise gezogen werden. Die Preise befinden sich jedoch in einer anderen Spalte.

Ich schaue einer Teilnehmerin über die Schulter: Sie klickt auf die leere Zelle, in der sich die Summe befinden soll:

SUMME

SUMME

Der Vorschlag wird verworfen, indem sie auf der erste Zelle der Zahlenkolonne klickt:

Hier beginnt die SUMME

Hier beginnt die SUMME

Anschließend tippt sie einen Doppelpunkt:

SUMME bis ...

SUMME bis …

Und schaut mich nun erstaunt an, was Excel „tut“. Zugegeben: Excel schlägt eine Zelle vor bis zu der der Bereich ausgedehnt werden könnte. Jedoch ist die Anfängerin überfordert, weil nach der Eingabe eines Doppelpunktes etwas „anderes“ in der Formel steht.

Vielleicht wäre hier keine Hilfe besser gewesen.

Ist das nur boshaft oder schon bösartig?

Ich hätte es nicht geglaubt. Sehen Sie selbst:

In einer gestalteten Tabelle wurden mehrere Zellen verbunden – hier: die Zellen E1:E3:

20160902Verbinden01

Wählt man nun das Werkzeug „Format übertragen“

20160902Verbinden02

und klickt (aus Versehen?) auf andere Zellen. Am besten solche, in denen Zahlen stehen:

20160902Verbinden03

Die Zellen werden nun nicht zu einer Zelle verbunden, sondern der Inhalt der unteren Zelle wird lediglich ausgeblendet. Davon kann man sich mit einem Blick auf die Summe überzeugen – das Überschlagen der sichtbaren der Spalte G Zahlen kann niemals die Summe 5538 ergeben:

20160902Verbinden04

Der Grund: Deaktiviert man die Option „Zellen verbinden“:

20160902Verbinden05

so taucht die verborgene (die verborgenen) Zelle(n) wieder auf – sie waren niemals gelöscht, sondern nur ausgeblendet:

20160902Verbinden06

Auf dieses unglaubliche Phänomen hat mich Andreas Thehos aufmerksam gemacht – danke dafür!

mal links, mal oben

Ist Ihnen folgender erklärbarer, aber auf den ersten Blick verwirrender Algorithmus aufgefallen?

In einer Exceltabelle befindet sich ein Zahlenblock. Klickt man in der er ersten Zelle daneben auf das Summensymbol, schlägt Excel die Reihe links daneben als Bereich vor. Eine Zelle tiefer wird ebenfalls die Zeile daneben vorgeschlagen. In der dritten Zeile jedoch die beiden Zahl (also die Summen) darüber.

Summe20151113_01

Summe20151113_02

Summe20151113_03

Das Algorithmus, der dahinter steckt, ist klar: Excel überprüft zuerst die Zellen darüber. Befindet sich keine Zahlen darin, werden die Zellen links neben der aktuellen Zelle geprüft (F2). Bei F3 erkennt Excel die Summe darüber und schlägt die gleiche Formel erneut vor. Würde in der Zelle darüber keine Funktion, sondern eine Zahl stehen, würde diese vorgeschlagen werden. In der dritten Zelle F4 werden zwei Formeln über der aktuellen Zelle (mit Zahlen als Ergebnis) erkannt und nun diese vorgeschlagen.

Pivot – Anzahl statt Summe

Manchmal schlägt die Pivottabelle bei der Zusammenfassung von Zahlen die Funktion ANZAHL statt der Funktion SUMME vor. Natürlich kann man die Funktion über die Wertfeldeinstellungen umschalten – dennoch erstaunt das Verhalten. Wahrscheinlich liegt es daran, dass in den Daten leere Zellen gefunden werden und diese als Text interpretiert werden.

Anzahl statt Summe

Anzahl statt Summe

Pivot20150509_2

Sind die leeren Zellen die Ursache?

 

Summe rechnet nicht

Im Excel-Kurs habe ich gelernt, wie man eine Summe bildet. Aber bei mir funktioniert das nicht:

Warum rechnet die Summe nicht?

Warum rechnet die Summe nicht?

Die Antwort ist einfach. Sie haben eine englischsprachige Oberfläche. Sie müssen natürlich SUM statt SUMME eingeben, AVERAGE statt MITTELWERT, IF statt WENN, VLOOKUP statt SVERWEIS und so weiter …

Excel rechnet falsch

Manchmal stimmt die Summe nicht. Was ist los?

Die Summe rechnet falsch?!

Die Summe rechnet falsch?!

Der Blick in die Gruppe „Zahl“ auf das Zahlenformat „Zahl“ macht stutzig. Ein genauer Blick darauf, wie die Zelle formatiert ist und welcher Wert eigentlich in der Zelle steht, ergibt, dass die Zahl 0,6 ohne Dezimalstellen formatiert wurde. Die Lösung: Lassen Sie sich (mehr) Dezimalstellen anzeigen. Excel rechnet mit dem Wert, der sich in der Zelle befindet und nicht mit dem Wert, den Sie sehen.

0,6 ohne Nachkommastelle formatiert.

0,6 ohne Nachkommastelle formatiert.

Mehr Nachkommastellen!

Mehr Nachkommastellen!

AutoSumme funktioniert nicht

Ich habe es nun schon mehrmals versucht – die Autosumme geht nicht.

Auch wenn jede Formel und Funktion mit einem Gleichheitszeichen beginnt, auch wenn Sie bei den Grundrechenarten das Gleichheitszeichen per Hand eintragen müssen, so verlangt das Symbol AutoSumme jedoch NICHT, dass Sie das Gleichheitszeichen eintragen. Sie müssen entweder die Formel per Hand eintragen:

=SUMME(G2:G12)

oder Sie setzen den Cursor auf eine leere Zelle und klicken anschließend auf das Symbol AutoSumme. Dann funktioniert es.

Die AutoSumme funktioniert nicht.

Die AutoSumme funktioniert nicht.

SUMME rechnet nicht

Kann ich mit der Summe nicht mehrere getrennte Bereiche addieren?

Doch. Aber die Bereiche werden nicht mit einem Leerzeichen, sondern mit einem Semikolon (;) getrennt.

Also – nicht so:

=SUMME(G5:G18 G30:G42 G56:G71 G80:G93)

sondern so:

=SUMME(G5:G18;G30:G42;G56:G71;G80:G93)

Übrigens: das Leerzeichen hat auch eine Funktion – es bedeutet: Schnittmenge. Man könnte berechnen:

=SUMME(C5:H21 G5:G26)

Damit würde die Summe über die Zelle G1:G21 gezogen werden.

Meine Empfehlung – tun Sie das nicht – das versteht kein Mensch, was Sie da tun! Und: wenn die Schnittmenge leer ist, quittiert Excel dies mit der Fehlermeldung #NULL!

Summe rechnet nicht.

Summe rechnet nicht.

Richtige Schreibweise: ; statt Leerzeichen!

Richtige Schreibweise: ; statt Leerzeichen!

Leerzeichen bedeutet Schnittmenge!

Leerzeichen bedeutet Schnittmenge!

Das würde funktionieren; ist aber unverständlich!

Das würde funktionieren; ist aber unverständlich!

 

 

Excel summiert Uhrzeiten nicht richtig

Doch. Aber Excel schafft den Sprung in den neuen Tag, also über die 24-Stunden-Grenze nicht.

Die Lösung: Sie müssen die Uhrzeit vom Typ [h]:ss formatieren. Oder in der Kategorie „Uhrzeit“ finden Sie ein Beispiel „37:30:50“. Das macht das Gleiche.

Stunden werden falsch formatiert.

Stunden werden falsch formatiert.

Die Summe ist korrekt; sie muss mit [h]:ss formatiert werden.

Die Summe ist korrekt; sie muss mit [h]:ss formatiert werden.

Excel kann keine Stunden summieren

Ein Klick auf das Symbol „Autosumme“ und Excel weigert sich Stunden zu summieren. Dabei sind doch Uhrzeiten auch Zahlen – die muss er doch summieren können.

Die Antwort: Aus irgend einem Grund weigert sich Excel bei Uhrzeiten die Summe anzuwenden. Markieren Sie die Uhrzeiten – dann werden sie summiert. Keine Ahnung, warum er sich bei Uhrzeiten sträubt zu rechnen …

Excel weigert sich Stunden zu summieren.

Excel weigert sich Stunden zu summieren.

Komische Überschriften

Ups – plötzlich steht in der ersten Zeile statt A, b, C, … die Zahl 1, 2, 3. Was ist passiert?

Man kann diese Einstellung in den Optionen / Formeln wieder ausschalten. Sie heißt Z1S1-Bezugsart.

Übrigens würde Excel nun statt =C3 schreiben: =ZS(-9). Und statt =SUMME(G2:G30) steht nun in der Zelle: =SUMME(Z(-9)S(-3):Z(19)S(-3))

Z1S1 - US-amerikanische Schreibweise

Z1S1 – US-amerikanische Schreibweise

Summe rechnet falsch

Man braucht schon ein sehr gutes Auge, um auf Anhieb erkennen zu können, warum Excel hier falsch rechnet.

Ein Tipp: Wenn man mit den Mauszeiger über den Bereich streicht, fällt auf, dass er seine Gestalt bei der Zahl 3 ändert. Ein Klick darauf ertappt den „Bösewicht“: Auf der Zelle liegt ein weißes Textfeld, in dem die Zahl 3 steht. Darunter steht natürlich eine andere Zahl.

Warum rechnet die Summe nicht richtig?

Warum rechnet die Summe nicht richtig?

Der "seltsame" Mauszeiger gibt einen Hinweis.

Der „seltsame“ Mauszeiger gibt einen Hinweis.

Ein Textfeld ...

Ein Textfeld …

... und darunter eine andere Zahl.

… und darunter eine andere Zahl.

Excel rechnet nicht mehr, beziehungsweise rechnet falsch

Was ist los – Excel will nicht mehr rechnen. Am Anfang hat es funktioniert …

Schauen Sie in der Registerkarte „Formeln“ nach, ob die Berechnungsoptionen auf „manuell“ gestellt wurde. Wenn ja, so wird die Berechnung zwar beim Erstellen der Formel durchgeführt, aber beim Ändern der Werte nicht aktualisiert. Ändern Sie diese Option auf „automatisch“ oder aktualisieren Sie das Ganze mit der Funktionstaste [F9].

Excel will nicht mehr (richtig) rechnen.

Excel will nicht mehr (richtig) rechnen.

Die Lösung: Berechnungsoptionen

Die Lösung: Berechnungsoptionen

Summe rechnet falsch

Offensichtlich rechnet die Summe falsch. Man muss nicht gut kopfrechnen können, um das festzustellen.

Die Lösung: zwei Zeilen (18 und 19) sind ausgeblendet. Dort verbergen sich die Zahlen, die zu der falschen Summe führen.

Die Antwort: Alles markieren und alle Zeilen einblenden. Dann sieht man die Zahlen, mit denen Excel rechnet.

Die Summe rechnet falsch.

Die Summe rechnet falsch.

Man muss schon genau hinschauen, um die Quelle des Fehlers zu finden.

Man muss schon genau hinschauen, um die Quelle des Fehlers zu finden.

SUMME vs. + | PRODUKT vs. * | QUOTIENT vs. /

Ist Ihnen aufgefallen, dass der Rechenoperator + etwas anderes macht als die Funktion SUMME? Dass * anders rechnet als die Funktion PRODUKT? Dass die Funktion QUOTIENT etwas anderes berechnet als der Divisionsoperator / wird schnell klar – QUOTIENT liefert den ganzzahligen Anteil einer Division.

Bei Summe und +, beziehungsweise Produkt und * ist der Unterschied nicht ganz so offensichtlich:

Summe und Produkt übergeht Texte, während + und * einen Fehler (#WERT) liefern. Der Operator * interpretiert eine leere Zelle als Wert 0, während die Funktion Produkt diese übergeht.

Also Achtung: + ist nicht das Gleiche wie Summe in Excel, * nicht das Gleiche wie * und / schon gar nicht das Gleiche wie Quotient.

Übrigens – bei dem selten verwendeten Rechenoperator ^ rechnet Excel offensichtlich genauso wie mit der Funktion POTENZ.

Summe und +, beziehungsweise Produkt und * im Vergleich.

Summe und +, beziehungsweise Produkt und * im Vergleich.

Die dahinter liegenden Funktionen

Die dahinter liegenden Funktionen