Tag Archives: Leerzeichen

Jemand der etwas nicht möchte, findet Gründe! – Jemand der etwas möchte, findet Wege!

… und ich finde die Ursache …

Heute in der VBA-Schulung. Ein Teilnehmer fragt mich, wo der Fehler in der folgenden Codezeile ist:

ActiveWorkbook.Worksheets(„Filme“).Activate

warum?

warum?

Nein – ActiveWorkbook ist richtig – es war keine andere Datei offen. Jedoch hatte der Teilnehmer das Tabellenblatt „Filme “ benannt – mit einem Leerzeichen Ende …

Böses Leerzeichen!

Böses Leerzeichen!

Ich sehe was, was du nicht siehst …

Können Sie mir helfen? Ich dachte, ich hätte es gefunden. In den Optionen in Excel gibt es den Befehl „Steuerzeichen anzeigen“. Ich dachte, dass man damit die Leerzeichen (und Zeilenschaltungen) anzeigen lassen kann. Aber Pustekuchen – geht wohl doch nicht. Oder mache ich etwas falsch?

Steuerzeichen ?!?

Steuerzeichen ?!?

Nicht ganz. Normalerweise ist diese Option in Excel ausgeblendet.

Normalerweise so.

Normalerweise so.

Sie sehen sie nur, wenn Sie mit Schriften arbeiten, die von rechts nach links laufen: Arabisch, Hebräisch, Persisch und andere. Dann wird der Cursor angezeigt – mit einem Haken, der verdeutlicht, dass nun die Textlaufrichtung von rechts nach links eingestellt wurde. Die Leerzeichen kann man auch in Excel 2016 leider noch immer nicht sichtbar machen.

Steuerzeichen !

Steuerzeichen !

Leerzeichen finden

Hallo. Ich habe schon eine ganze Weile gesucht, bis ich herausgefunden habe, warum er die gallischen Tiere falsch zählt. Eigentlich müsste die Formel ANZAHL2 die Zahl 2 ergeben und nicht 4:

ANZAHL2 zählt falsch

ANZAHL2 zählt falsch

Die Antwort habe ich nach langem Suchen gefunden: In einigen Zellen habe ich aus Versehen ein Leerzeichen eingegeben. Klar – das sehe ich nicht; das wird als Text mitgezählt.

Die Wurzel des Übels

Die Wurzel des Übels

Aber nun meine Frage: Wenn ich die Liste filtere – warum zeigt der Autofilter nicht an, dass einige Zellen Leerzeichen enthalten?

Die Antwort: Ja – Sie haben recht – der Autofilter übergeht zum Glück (oder leider?) die Leerzeichen. Der Vorteil: „Asterix“ und „Asterix “ (mit einem Leerzeichen am Ende) werden vom Filter als gleicher Text behandelt. Der Nachteil: Der Filter hilft nicht diese Leerzeichen, die an anderen Stellen Probleme verursachen, aufzufinden.

Der Autofilter übergeht Leerzeichen am Ende des Textes.

Der Autofilter übergeht Leerzeichen am Ende des Textes.

Man kann die Texte mit Suchen ([Strg]+[F]) auffinden. Oder mit Funktionen:

=LÄNGE(C2)

=WENN(LINKS(C2;1)=“ „;“x“;““)

Oder mit [Strg]+[↓] können Sie den Cursor nach unten versetzen; er springt nun zur ersten Zelle, in der etwas steht; stoppt also auch bei den Zellen, die mit einem Leerzeichen gefüllt sind.

Summe funktioniert nicht

Sehr geehrter Herrn Martin,

In der Excel Tabelle die im Anhang beigefügt ist, bekommen wir Daten von unsere EDV (sehe Sheet 1 vor Verarbeitung). Ich gehe dann in „DATA“ und „Text to Columns“ und spalte diese Tabelle so dass sie nach diese Schritte wie im 2. Sheet (Daten nach Verarbeitung) aussieht.

Das Problem liegt indem einige Zahlen immer noch so erscheinen „1 150,000“ und keine weitere Formatierung möglich ist. Da ich auch eine Summe daraus ziehen möchte.

Wie kann man diese Problem Lösen ?

Originaldaten

Originaldaten

Daten nach dem Trennen

Daten nach dem Trennen

Die Antwort: Dummerweise liefert Ihr System die Spalte E so, dass nach dem Tausenderwert als Tausendertrennzeichen ein Leerzeichen verwendet wird. Diese müssen Sie löschen. Ich würde die Spalte (hier E) markieren und dann mit Home / Find & Replace (ganz rechts) das Leerzeichen (einfach ein Blank eintippen) durch nichts ersetzen.

 

SUMME rechnet nicht

Kann ich mit der Summe nicht mehrere getrennte Bereiche addieren?

Doch. Aber die Bereiche werden nicht mit einem Leerzeichen, sondern mit einem Semikolon (;) getrennt.

Also – nicht so:

=SUMME(G5:G18 G30:G42 G56:G71 G80:G93)

sondern so:

=SUMME(G5:G18;G30:G42;G56:G71;G80:G93)

Übrigens: das Leerzeichen hat auch eine Funktion – es bedeutet: Schnittmenge. Man könnte berechnen:

=SUMME(C5:H21 G5:G26)

Damit würde die Summe über die Zelle G1:G21 gezogen werden.

Meine Empfehlung – tun Sie das nicht – das versteht kein Mensch, was Sie da tun! Und: wenn die Schnittmenge leer ist, quittiert Excel dies mit der Fehlermeldung #NULL!

Summe rechnet nicht.

Summe rechnet nicht.

Richtige Schreibweise: ; statt Leerzeichen!

Richtige Schreibweise: ; statt Leerzeichen!

Leerzeichen bedeutet Schnittmenge!

Leerzeichen bedeutet Schnittmenge!

Das würde funktionieren; ist aber unverständlich!

Das würde funktionieren; ist aber unverständlich!

 

 

Seltsamer Ausdruck

Ich habe mich einmal gewundert, weshalb bei einer Dame eine kleine Tabelle immer sehr stark verkleinert wurde. Oder umgekehrt – warum bei ihr immer so viele Leerseiten gedruckt wurden. Bis ich dahinter kam, dass sie Daten nicht mit der Taste [Entf] gelöscht hat, sondern, indem sie die Leertaste gedrückt hat. Somit stand in einer Zelle – ziemlich weit rechts außen – immer ein Leerzeichen, das man (fast) nicht mehr findet. Auf alle Fälle nicht mehr sieht!

Fazit: Tun Sie so etwas bitte nicht!

Die Originaltabelle

Die Originaltabelle

Seitenansicht I Anpassen auf eine Seite

Seitenansicht I
Anpassen auf eine Seite

Seitenansicht II Keine Anpassung - 11 Seiten werden ausgedruckt!

Seitenansicht II
Keine Anpassung – 11 Seiten werden ausgedruckt!