Tag Archives: Index

SVERWEIS ist eine Erfindung des Teufels !!!!!!!!!!!!!!!!!!!!!

Hi Rene,

wahrscheinlich wirst du jetzt von mir das CALC Zeugnis zurück verlangen, aber mich macht der SVERWEIS noch wahnsinnig in EXCEL2016.

Es ist eine völlig simple Datei, aber trotzdem verweigert SVERWEIS den Dienst.

Ich hab dir die Datei im Original angehängt. Schau dir mal meine SVERWEIS Formal an und zeig mir bitte den Fehler. Die Boulesche Variable hab ich auch in allen Variationen ausprobiert à IMMER #NV.

Die Formel:

=SVERWEIS(A2;$I:$K;1)

Hi Jo,

SVERWEIS sucht immer in der ersten Spalte einer Liste.

Dein Pin steht aber in der dritten Spalte.

Du kann es lösen mit den Funktionen INDEX und VERGLEICH:

=INDEX(J:J;VERGLEICH(A2;K:K;0))

Hilft das?

LG aus Hamburg

Rene

Stirb nicht als Jungfrau, sonst erwarten dich im Himmel nur Terroristen.

Schon irgendwo doof. Zumindest ein bisschen.

Ich erstelle eine Pivottabelle. In der zweiten Spalte befindet sich eine ID. Diese ID soll mit INDEX- und VERGLEICHS-Funktionen in einer anderen Tabellen gefunden werden und weitere Informationen geliefert werden, beispielsweise die Gesellschafterin und die Geschäftsbezeichnung Spalte A und B):

Filtert man die Pivottabelle werden jedoch die Zeilen außerhalb der Pivottabelle nicht ausgeblendet. Das bedeutet: ich erhalte eine Reihe Fehlerwerte:

Und nein – ich kann und will die anderen Daten nicht zu den Daten der Pivottabelle hinzufügen. Und ja: natürlich habe ich anschließend diesen Fehler mit WENNFEHLER abgefangen.

Schon irgendwie seltsam: ein Filtern der Pivottabelle wirkt sich nicht auf die Zeilen außerhalb aus. Anders als beim „normalen“ Filtern mit Autofilter.

Schützt die Bäume – esst mehr Biber!

Manchmal stolpert man (ich) über seine eigenen Füße.

Heute. Excelschulung. Ich erkläre die Funktion INDEX. Ich verweise mit INDEX vom zweiten Tabellenblatt auf das erste Blatt „Diäten“. Ich ziehe mit der Maus den Bereich auf. Bei den ersten beiden Spalten lautet die Formel:

=INDEX(Diäten!A1:B24

füge ich die Spalte C hinzu lautet die Formel jedoch:

=INDEX(Diäten

Schließe ich Spalte D ein finde ich nun folgende Formel:

=INDEX(Diäten!A1:D24

Ich grüble eine Weile über das seltsame Phänomen, bis ich dahinter komme, dass ich ja den Bereich A1:C24 benannt habe: er heißt „Diäten“.

Man sollte nicht Tabellenblätter so beschriften wie die Namen, die in der Datei vergeben wurden. Das führt zu Chaos!