Tag Archives: Daten

Habe heute mal wieder Sport gemacht. Ritter Sport. Zwei Tafeln.

Amüsante Fehlermeldung. Dabei wollte ich doch nur ein weiteres Feld in eine Pivottabelle einfügen:

Aber die Ursache ist schnell gefunden: Neben der Pivottabelle befand sich eine Formel. Excel kann nicht eine Spalte einfügen, verschiebt also nicht die Tabelle, sondern überschreibt die Formel:

Die Frage bleibt: Hätte man nicht „Tabelle2 enthält bereits Daten“ etwas anders formulieren können?

Wenn du nach den Sternen greifst, solltest du die Achselhaare rasieren.

Ich öffne eine PivotTabelle. Erstaunlich: Neben den Monatsnamen befinden sich auch die Zahlen der Monate als Vorschlag. Aber beim Einblenden wird nichts angezeigt:

Auch in der Ursprungsliste befinden sich diese Werte nicht. Ein Blick auf die Datenherkunft zeigt, dass in der Liste eine Formel steht:

=WENN(ISTZAHL(A2);TEXT(DATUM(JAHR(A2);MONAT(A2);1);“MMM“);““)

Wahrscheinlich wurde eine alte Formel, wie beispielsweise:

=WENN(ISTZAHL(A2);MONAT(A2);““)

durch diese Formel ersetzt.

Ein Aktualisieren der Pivottabelle nützt nichts, um die alten, nicht mehr vorhandenen Werte, zu löschen. Auch ein Entfernen der Spalte „Monat“ nützt nichts. Man muss beides machen: das Feld entfernen, aktualisieren und erneut einfügen. Dann sind die „überflüssigen“ Werte weg:

Filtern klappt nicht

Seltsam – ich könnte schwören, dass Kunden aus München in dieser Liste stehen. Die Liste des Autofilters zeigt allerdings keinen an.

Der Grund ist: es wurde bereits ein Filter eingeschaltet (hier: in der Spalte „Name2“). Möglicherweise sind zufällig alle Münchner Daten auf diese Art weggefiltert. Hier sieht man den gesetzten Filter zufälligerweise – es könnte jedoch sein, dass die Spalte, in der der Filter gesetzt wurde, außerhalb des Bildschirms steht.

Tipp: Dann werfen Sie einen Blick in die Registerkarte „Daten“ – wenn dort das Symbol „Löschen“ aktiv ist, so ist noch irgendwo ein Filter gesetzt.

Wo sind die Kunden aus München?

Wo sind die Kunden aus München?

Schalten Sie zuerst den einen Filter aus und dann den zweiten Filter ein.

Schalten Sie zuerst den einen Filter aus und dann den zweiten Filter ein.

Hier gibt es schon Daten. Möchten Sie diese ersetzen?

Eine merkwürdige Fehlermeldung, die auftritt, wenn Sie den Assistenten „Text in Spalten“ verwenden, den Sie im Register „Daten“ finden. Er kann zwei Ursachen haben:

1. Einige der Texte haben mehrere Trennzeichen und würden tatsächlich Daten überschreiben (hier im Beispiel „Peter J. Krebs“, dessen Nachname in der Spalte „Position“ stehen würde.

2. Es befinden sich Formatierungen in den Zellen, beispielsweise in Zeile 1 – die lila Hintergrundfarbe. Das genügt für Excel um von „Daten“ auszugehen.

Tipp: Wenn Sie unsicher sind, kopieren Sie die Spalte auf ein leeres Tabellenblatt und trennen dort die Daten. Schauen Sie sich dann das Ergebnis an.

Der Assistent "Daten / Text in Spalten"

Der Assistent „Daten / Text in Spalten“

Er würde Daten überschreiben.

Er würde Daten überschreiben.

Oder Formate werden als Daten identifiziert.

Oder Formate werden als Daten identifiziert.

Seltsame Zahlen

Ein Teilnehmer hat mich gefragt, warum nach der Eingabe der Zahl 7 in einer Zelle der Wert 0,07 steht. Aus 14 macht er 0,14 und so weiter.

Ich musste eine Weile suchen, bis ich die Lösung gefunden hatte: Man kann in den Optionen einstellen:

„Dezimalkomma automatisch einfügen“

Ich frage mich – wer braucht denn diese Option – sie führt doch nur zu Fehlerquellen!

Aus 7 macht Excel 0,07

Aus 7 macht Excel 0,07

Dezimalkomma automatisch einfügen - bitte nicht einschalten!

Dezimalkomma automatisch einfügen – bitte nicht einschalten!

Plötzlich stehen andere Zahlen in der Zelle

Ich schreibe eine Zahl in eine Zelle, beispielsweise 500. Plötzlich steht eine andere Zahl in der Zelle. Warum passiert das manchmal?

Die Antwort ist leicht: in der Zelle hat sich schon etwas befunden; beispielsweise ein Datum. Wenn Sie die Taste [Entf] drücken, wird zwar der Inhalt gelöscht, nicht aber die Formatierung. Man kann es erkennen, indem man auf die Registerkarte „Start“ wechselt und einen Blick in die Gruppe „Zahlen“ wirft. Dort steht das Zahlenformat. Schwierig wird es allerdings, wenn im Kombinationsfeld „Benutzerdefiniert“ steht. Das kann alles mögliche bedeuten. Wurde beispielsweise 2.5 eingegeben, so interpretiert Excel dies als benutzerdefiniertes Datum bestehend aus Tag und Monat. So wird nun 500 dargestellt – als 500. Tag seit „Beginn von Excel“ – seit dem 01. Januar 1900.

Sie bekommen das weg, indem Sie aus dem Kombinationsfeld das Zahlenformat „Standard“ wählen. Oder „alles löschen“  dann wird Inhalt und Format gelöscht.

Die Zelle ist als Datum formatiert.

Die Zelle ist als Datum formatiert.

Das hat Auswirkungen auf die Eingabe der Zahl 500.

Das hat Auswirkungen auf die Eingabe der Zahl 500.

Die Zelle ist benutzerdefiniert formatiert.

Die Zelle ist benutzerdefiniert formatiert.

Das hat Auswirkungen auf die Eingabe der Zahl 500.

Das hat Auswirkungen auf die Eingabe der Zahl 500.

Die Lösung: Entweder alles löschen oder als "Standard" formatieren.

Die Lösung: Entweder alles löschen oder als „Standard“ formatieren.

 

Text oder Zahl?

Eigentlich müsste man es sofort sehen: Texte stehen in Zellen am rechten Rand; Zahlen linksbündig. Wenn man sich vertippt, beispielsweise den Buchstaben „O“ statt die Ziffer „0“ oder den Buchstaben „l“ statt der Ziffer „1“ eingibt, kann Excel mit diesen Texten nicht rechnen.

Warum machen Menschen so etwas? Es gab einige Schreibmaschinen, auf denen gab es keine Ziffer „0“ oder keine Ziffer „1“. Dort musste man auf die Buchstaben „O“, beziehungsweise „l“ zurückgreifen.

Bitte kein "O" statt der Ziffer "0"; bitte kein "l" statt der Ziffer "1" eingeben.

Bitte kein „O“ statt der Ziffer „0“; bitte kein „l“ statt der Ziffer „1“ eingeben.