Category Archives: Fehlermeldungen

Hatte Kribbeln im Bauch … dachte schon bin verliebt … aber war doch nur Hunger …

Schon mal probiert?

Eine Datei greift mit einer Formel auf eine zweite Datei zu. Kein Problem.

Doch: ist ein Problem – nämlich, wenn es sich bei der Formel um SUMMEWENN, ZÄHLENWENN & co handelt. Dann muss nämlich die Quelldatei offen sein, damit kein Fehler angezeigt wird. Sehr erstaunlich!

So ist es gut – komm auf die dunkle Seite der Macht!

Wollt ihr wissen, wie man Excel zum Absturz bekommt? Man muss die Funktion AGGREGAT in einem Namen verwenden und diesen in einem Diagramm.

Das Ganze geht so:

Eine Tabelle holt sich Werte aus einer anderen Liste. Da einige Werte nicht gefunden werden, werden diese als #NV angezeigt. In einem Diagramm werden die entsprechenden Kategorien verwendet:

Unschön, denke ich mir. Die Jahreszahlen, die keinen Wert haben, sollen ausgeblendet werden. Und lege vier Namen an: „Bau“, „IT“, „Verwaltung“ und „sonstiges“. Sie haben die Form:

=BEREICH.VERSCHIEBEN(Tabelle1!$D$2;1;0;1;AGGREGAT(2;6;Tabelle1!$D$3:$J$3))

AGGREGAT deshalb, weil es die Fehlerwerte übergeht.

Ich versuche nun den Namen im Diagramm einzufügen, das heißt aus der ersten Datenreihe

=DATENREIHE(Tabelle1!$C$3;Tabelle1!$D$2:$J$2;Tabelle1!$D$3:$J$3;1)

wird ein:

=DATENREIHE(Tabelle1!$C$3;Tabelle1!$D$2:$J$2;Tabelle1!Bau;1)

Das Ergebnis: ABSTURZ!

Die Lösung ist simpel: Man lagert die Funktion AGGREGAT in eine Zelle aus (hier: L3). Man gibt ihr einen Namen – beispielsweise AGGREGAT.

Und ändert nun die Namen in:

=BEREICH.VERSCHIEBEN(Tabelle1!$D$2;1;0;1;AGGREGAT)

Nun kann der Bereich geändert werden:

=DATENREIHE(Tabelle1!$C$3;Tabelle1!$D$2:$J$2;Tabelle1!Bau;1)

Wer dies ausprobieren möchte, kann die Dateien herunterladen: AGGREGAT und AGGREGAT02.

 

Habe heute mal wieder Sport gemacht. Ritter Sport. Zwei Tafeln.

Amüsante Fehlermeldung. Dabei wollte ich doch nur ein weiteres Feld in eine Pivottabelle einfügen:

Aber die Ursache ist schnell gefunden: Neben der Pivottabelle befand sich eine Formel. Excel kann nicht eine Spalte einfügen, verschiebt also nicht die Tabelle, sondern überschreibt die Formel:

Die Frage bleibt: Hätte man nicht „Tabelle2 enthält bereits Daten“ etwas anders formulieren können?

Wer morgens kalt duscht, lügt auch den Rest des Tages

Irgendwie doof. Mal wieder nicht konsistent.

Kennen Sie das? Ich erstelle eine Liste mit Verkäufernamen, Monatsnamen und Umsatzzahlen. Über Formeln / Definierte Namen / Aus Auswahl erstellen werden die Spaltennamen und Zeilennamen zu Namen der entsprechenden Zeile und Spalte:

Nun kann man die Schnittmenge berechnen:

=Roth Umsatz

Leider kann man diese Werte nicht auslagern – das führt zu einem Fehler:

Das ist erstaunlich, denn folgende Formeln funktionieren problemlos:

=SUMME(INDIREKT(„C2:C7“))

=SUMME(INDIREKT(„Umsatz“))

Aber eben leider nicht:

=SUMME(INDIREKT(„Umsatz Roth“))

und auch nicht:

=SUMME(INDIREKT(„C2:C5 C3:C7“))

Schade, dass INDIREKT keine Schnittmenge verarbeiten kann.

Nachtrag: Danke an XLarium für den wertvollen Hinweis (⇓):

Es funktioniert mit:

=INDIREKT(„Umsatz“) INDIREKT(„Roth“)

und:

=SUMME(INDIREKT(„C2:C5“) INDIREKT(„C3:C7“))

Aus Langeweile hätte ich eben fast gearbeitet. Man muss aber auch höllisch aufpassen.

Gestern in der Excel-Schulung. Wir üben die WENN-Funktion. Standard-Beispiel: eine Provisionsberechnung. Ein Teilnehmer ruft mich, weil er eine Fehlermeldung erhält:

Ich gestehe: ich habe drei Mal hinschauen müssen, bis ich es entdeckt hatte: das schließende Anführungszeichen bei dem Sonst-Zweig (Wert_wenn_falsch) fehlt.

Wer morgens zerknittert aufsteht, hat am Tag die besten Entfaltungsmöglichkeiten!

Ich trage in einer Zelle die Funktion =exp(1) ein, da ich die Konstante e benötige. Ich benenne die Zelle e:

20170206e06

Ich schreibe nun die Formel

=Sin(e) in eine andere Zelle – die Konstante, das heißt: der Name, wird erkannt:

20170206e02

Nach Schließen der Klammer wird die Formel bestätigt:

20170206e03

Das Ergebnis verblüfft; aber des Rätsels Lösung ist schnell gefunden:

AutoKorrektur heißt der Bösewicht!

AutoKorrektur heißt der Bösewicht!

Ich brauche keinen Mittelfinger, ich kann das mit den Augen.

Heute in der Excel-Schulung. Ein Teilnehmer zeigt mir seine Lösung, wie er die Anzahl der Zahlen im 90er-Bereich ermittelt hat: Er berechnet die Differenz zweier ZÄHLENWENN-Funktionen:

=ZÄHLENWENN(C8:C37;“<100″)-ZÄHLENWENN(C8:C37;“<90″)

Ich zeige seinen Ansatz der Gruppe. Mit dem Funktionsassistenten rufe ich Zählenwenn auf:

Schritt 1

Schritt 1

Normalerweise trägt Excel im Funktionsassistenten um die Bedingung <100 automatisch die Anführungszeichen ein. Jedoch ein Klick in die Bearbeitungsleiste lehrt mich eines Besseren:

Schritt 2

Schritt 2

Ich fahre fort: tippe ein Minus und rufe erneut den Funktionsassistenten auf:

Schritt 3

Schritt 3

Der Blick in die Bearbeitungsleiste zeigt mir, dass die Anführungszeichen in der ersten Funktion fehlen. Und richtig: Das Bestätigen der Funktion wird mit einer Fehlermeldung quittiert:

Schritt 4

Schritt 4

Schade – denn gerade der Funktionsassistent nimmt Anwendern und Anwenderinnen, die mit Formeln noch nicht so sehr geübt sind, die Arbeit an vielen Stellen ab …

Also doch: Ich zeige dem Teilnehmer ZÄHLENWENNS, die ihm sehr gut gefällt …

Nett kann ich auch – bringt aber nix!

Microsoft hat in Excel 2013 das Analysewerkzeug „Inquire“ eingeführt, das in Excel 2016 nicht geändert wurde. Damit erspart man sich die umständlich Suche, ob es Verknüpfungen, ausgeblendete Zeilen, Spalten, Blätter gibt, ob Zahlen als Text formatiert wurden, wo Formeln stecken, die einen Fehler liefern, wo Zirkelbezüge zu finden sind, …

Inquire

Inquire

Damit ist Microsoft auf dem richtigen Weg. Für alle, die fremde Dateien analysieren möchten („Was hat der Kollege denn da gemacht?“) oder die zwei Dateien miteinander vergleichen möchten – ein richtiger Schritt in die richtige Richtung. Jedoch mir fehlen:

  • eine Anzeige für „Genauigkeit wie anzeigen“
  • Überhaupt einige Optionen, die Anwender zur Verzweiflung bringen können: „in Zellen mit Nullwerten eine Null anzeigen“, „anstelle der berechneten Werte Formeln anzeigen“, „Dezimalkomma automatisch einfügen“, „1904-Datumswert, „Iterative Berechnung aktivieren“, „manuelle Arbeitsmappenberechnung“ und einige andere hübsche Optionen
  • ausgeblendete Zeilen und Spalten zu finden ist klasse – was aber, wenn die Zeilenhöhe auf 0,1 pt gesetzt wurde?
  • zu schmale Spalten – Zahlen werden mit dem Zahlenzeichen ########## dargestellt.
  • zu viele oder widersprüchliche bedingte Formatierungen
  • Rundungsfehler bei Zahlenformaten
  • Unsinnige Zahlenformate (beispielsweise 0,0 „%“). Allerdings: Wer entscheidet, was unsinnig ist?
  • Zahlenformate wie ;;
  • Zellen mit Leerzeichen
  • Zellen, die Text enthalten mit einem Leerzeichen am Ende: „Rene Martin“ ist etwas anderes als „Rene Martin „
  • Und schließlich: Objekte: Diagramme, die auf ein Pixel verkleinert wurden, Bilder, die auf Zellen liegen und so aussehen, als wären es Elemente der Zelle oder auch weiße Rechtecke, die auf einer Zelle liegen:
Wird leider nicht vom Inquire gefunden

Wird leider nicht vom Inquire gefunden – unter dem Rechteck befindet sich die Zahl 3000

Fazit: Guter Ansatz, muss jedoch erweitert werden. Wenn Microsoft mich fragen würde – ich könnte Ihnen viele Dinge nennen, die Anwendern Probleme verursachen.

Und: ein dankeschön an Stefan, der mir geholfen hat, das Teilchen auseinanderzunehmen.

Excel hält sich nicht an die Theoreme der Prädikatenlogik

Kennen Sie das: Ich benötige eine Liste, die sich dynamisch fortsetzt. In einer Zelle wird ein Wert eingetragen – die Nummer eines Zählers soll nur bis nur eingetragenen Nummer angezeigt werden.

Die Formel:

=WENN(A9=$B$4;A9+1;““)

funktioniert problemlos –

=WENN(A9=$B$4;““;A9+1)

jedoch nicht.

Einer geht und einer nicht.

Einer geht und einer nicht.

20160626weiter01

Der Grund ist offensichtlich. Befindet sich in einer Zelle ein leerer String („“), kann Excel zwar problemlos den Ausdruck

12 = „“

auswerte und FALSCH zurückgeben. Jedoch bei den Operatoren der Ungleichheit (<, >, <= und >=):

12 < „“

liefert Excel einen Fehler. Also aufpassen: man darf nicht immer einfach rumdrehen!

Humor ist der Knopf, der verhindert, dass uns der Kragen platzt. (Joachim Ringelnatz)

Nicht jede Formel darf sein!

Ich gestehe: Es ist mir lange Zeit nicht aufgefallen. Wahrscheinlich deshalb, weil ich die Symbole der Bedingten Formatierung in Excel nicht besonders schätze. Während man bei den Hintergrundfarben, Schriftfarben und Zellrahmen beliebige Formeln verwenden darf, ist dies bei den Skalen, Datenbalken und Symbolsätzen eingeschränkt. Genau:

Werte sind kein Problem

Werte sind kein Problem

Den Inhalt einer Zelle mit einem festen Wert abzugleichen ist kein Problem.

Absolute Bezüge geht auch

Absolute Bezüge geht auch

Den Wert auszulagern und mit einem absoluten Bezug darauf zuzugreifen ist auch kein Problem.

HEUTE() funktioniert

HEUTE() funktioniert

Auch Formeln wird HEUTE() stellen kein Problem dar.

Relative Bezüge leider nicht.

Relative Bezüge leider nicht.

Das Erstaunen ist groß, wenn man relative Bezüge verwendet. DAS ist verboten. Noch einmal hinschauen – das Kombination bietet „Formel“ an und nicht „Formel mit absolutem oder keinem Bezug“.

Okay – wahrscheinlich eine Kurzschreibweise …

kon·se·quent [ˌkɔnzeˈkvɛnt]

Nein, konsequent ist Excel nicht. An einigen Stellen muss man bei Texten Anführungszeichen eintragen, bei einigen kann man an anderen Stellen wiederum darf man nicht.

Ich habe im Artikel

Die bedingte Formatierung funktioniert nicht

darauf hingewiesen. Bei der Funktionseingabe ist Excel auch inkonsequent:

Während man bei Tippen einer Funktion immer die Anführungszeichen eingeben muss, muss man es im Funktions-Assistenten nicht. Das Wort Achtung wird beim Verlassen des Textfeldes umgewandelt in „Achtung“. Jedoch: Wenn man im Funktionsassistenten eine innere Funktion einträgt, beispielsweise

und(B2=Fotografie;G2>100)

wird dies mit einer Fehlermeldung quittiert. Nicht konsequent, oder?

Manchmal muss man, manchmal muss man eben nicht.

Manchmal muss man, manchmal muss man eben nicht.

Meine Empfehlung: Wenn Sie nicht wissen, ob man muss oder nicht: Tragen Sie die Anführungszeichen ein.

Was denn Excel zusammengefügt hat, soll ein Mensch nicht scheiden.

Hallo. Ich brauche einen Tipp. Ich erhalten einige Male im Jahr eine Tabelle mit vielen Zahlen. Da die Zeilen keine eindeutige ID haben, habe ich mit der Funktion VERKETTEN mehrere Felder konkateniert (zusammengefasst), so dass ich eine ziemlich eindeutige ID habe. Ich wollte diese Formel weiter runterziehen, weil sich die Liste ab und zu erweitert. Jedoch – Excel zeigt in den leeren Zeilen Fehler. Das verstehe ich nicht: leer & leer & leer müsste doch leer sein, oder?

VERKETTEN - klappt gut, aber irgendwann mit Fehler

VERKETTEN – klappt gut, aber irgendwann mit Fehler

Die Antwort: Sie haben die Tabelle in eine „intelligente Tabelle“ verwandelt (Einfügen / Tabellen / Tabelle). Die Formel in der Zelle lautet:

=VERKETTEN(Tabelle1[@ProdH];Tabelle1[@[BG Cd]];Tabelle1[@[BD / BU]];Tabelle1[@[Main Hier. Name]];Tabelle1[@[Sold-to party]];Tabelle1[@[MAT15 Nbr]];Tabelle1[@[DQ Conf]])

also: Tabellenname Tabelle1[Spaltenname]. Das impliziert: gleiche Zeile wie Formelzelle.

Allerdings befindet sich keine Tabelle neben den neuen Zellen unterhalb der Tabelle. Wenn es Sie stört, können Sie um die Funktion die Formel WENNFEHLER bauen, also:

=WENNFEHLER(VERKETTEN(Tabelle1[@ProdH];Tabelle1[@[BG Cd]];Tabelle1[@[BD / BU]];Tabelle1[@[Main Hier. Name]];Tabelle1[@[Sold-to party]];Tabelle1[@[MAT15 Nbr]];Tabelle1[@[DQ Conf]]);““)

Oder Sie schreiben den Zellbezug „per Hand“ in die Formel:

=VERKETTEN(B1;C1;D1;G1;J1;L1;T1)

Dann erhalten Sie auch keine Fehler.

Mein Gedächtnis ist schlecht. – Wie schlecht? – Wie schlecht ist was?

Ich verstehe es nicht. Kennen Sie einen Rat?

Ich habe eine Tabelle mit Abteilungsnummern. Da einige Abteilungen in der Form 4.2.2 oder 3.1.5 vorliegen, muss ich sie als Text formatieren oder ein Apostroph voranstellen. Soweit so gut.

Da ich das Apostroph nicht mag, ignoriere ich den „Fehler“ (es ja kein Fehler).

Fehler: ignorieren!

Fehler: ignorieren!

Sieht prima aus:

klasse!

klasse!

Allerdings: Sobald ich die Abteilungsnummer ändere – beispielsweise von 4.1.1 zu 4.1.5 – erscheint das grüne Eck von Neuem. Ich wollte doch den Fehler ignorieren:

hallo - ich bin wieder da!

hallo – ich bin wieder da!

Die Antwort: Excel hat nur die globale Einstellung: „Fehlerüberprüfung nicht aktivieren“ in den Optionen oder kann lokal einen Fehler zu ignorieren. Sobald der Inhalt geändert wird, wird die Fehlerüberprüfung wieder aktiviert. DAS kann man leider nicht abstellen – das heißt: es gibt keine Option HIER bitte nicht mehr fragen. Das heißt: Sie müssen sich leider für eine der beiden Varianten entscheiden: IMMER deaktivieren oder lokal ausschalten, und wenn die Informationen geändert werden, dann erneut ausschalten.

Geld ist nichts. Aber viel Geld, das ist etwas anderes. (Georg Bernard Shaw)

Es ist schon ein seltsames Ding um Excel. Trägt man in eine Zelle den Text WAHR ein und multipliziert diese Zelle (genauer: den Wert dieser Zelle) mit 1, so erhält man 1. Bei FALSCH lautet das Ergebnis 0. Das bedeutet, dass WAHR = 1 und FALSCH = 0.

Eben. In vielen Funktionen, die die beiden Parameter 0 oder 1 verlangen, kann man auch WAHR und FALSCH eingeben. Und umgekehrt.

Beispielsweise SVERWEIS. Oder RMZ. Analog: ZINS, ZZR, BW.

Jedoch: =KUMZINSZ(2,5%/12;12*10;50000;1;10;1) berechnet korrekt -901,01. Allerdings liefert =KUMZINSZ(2,5%/12;12*10;50000;1;10;WAHR)

einen Fehler. Bei KAPZ und ZINSZ darf ich bei dem Parameter F die beiden Werte 1 oder WAHR (beziehungsweise 0 oder FALSCH) eintragen. Muss ich das verstehen?

Kann INDIREKT keine Tabellen?

Hallo. Ich habe eine Frage. Ich weiß, dass Excel nicht alles kann. Aber fragen kann man ja mal.

Ich habe für meinen Chef eine Liste in Excel erstellt. Habe über Erstellen / Tabelle eine Tabelle daraus gemacht. So weit, so gut.

Die Tabelle

Die Tabelle

Ich klicke in eine andere andere Zelle nebenan und erzeuge eine Summe:

Eine Spalte wird summiert.

Eine Spalte wird summiert.

Die Formel lautet:

=SUMME(Tabelle1[April])

Über ein Dropdownfeld kann man die Monate auswählen:

Die Monatsliste

Die Monatsliste

Und nun meine Frage. Eigentlich liebe ich die Funktion INDIREKT. Eine prima Sache. Aber kann sie nicht diese Formel zusammenbauen? Etwas so:

=SUMME(„Tabelle1[„&INDIREKT(„O2″)&“]“)

INDIREKT liefert einen Fehler.

INDIREKT liefert einen Fehler.

Die Antwort: Nein – nicht ganz – Sie müssen die Anführungszeichen anders setzen und INDIREKT VOR den gesamten Text stellen. Wenn Sie Formel wie folgt zusammenbauen, dann klappt es:

=SUMME(INDIREKT(„Tabelle1[„&O2&“]“))

Natürlich kann INDIREKT das.

Natürlich kann INDIREKT das.

 

Wir haben ein Problem bei dieser Formel festgestellt.

Das ist schön, dass Excel ein Problem bei dieser Formel feststellt – aber das hilft mir leider nicht weiter. Haben Sie eine Erklärung?

Fehlermeldung

Fehlermeldung

Hierfür kann es sicherlich mehrere Ursachen geben. Dummer Tipp: Versuchen Sie es noch einmal! Vielleicht haben Sie einfach [Enter] gedrückt oder mit der Maus auf [OK] geklickt ohne etwas einzugeben, beziehungsweise zu markieren:

Eine mögliche Lösung

Eine mögliche Lösung

TE – und ich erhalte kein Teilergebnis

Hallo zusammen,
Wenn ich eine Formel (per Tastatur) eingeben will, z. B. =Teilergebnis(…), dann zeigt mir Excel nach zwei Buchstaben auch schon die richtige Formel in einem Feld an, die ich dann mit den Coursor-Tasten auswählen kann. Wie kann ich diese Auswahl dann aber übernehmen (ohne Maus wohlgemerkt). Wenn ich nach =Te die ENTER drücke, weil dich die richtige Formel ausgewählt habe, speichert Excel nur eben =Te und erkennt es als Namen, den es natürlich nicht gibt, Ausgabe in Zelle : #Name? wie kann man denn per Tastatur die richtige Formel auswählen und bestätigen?
Nur TE und kein Teilergebnis

Nur TE und kein Teilergebnis

Die Antwort: Drücken Sie nicht die [Enter]-Taste, sondern die Tabulatortaste. Dann übernimmt Excel diese Funktion. Von Andreas Theos stammt noch der Tipp: „…und nach dem TAB noch STRG + A für den Formeldialog ;-)“ – danke!

Seltsame Funktion

Eine Kollegin von mir hat einen tollen Kalender erstellt. Wenn ich ihn mir jedoch genauer ansehe, dann finde ich dort seltsame Funktionen (_xlfn.ISOWEEKNUM). Sie sind nicht in einem Add-In vorhanden, hat mir die Kollegin gesagt. Ich finde die Funktionen auch nicht im Funktionsassitenten. Was passiert denn hier?

Seltsame Funktion

Seltsame Funktion

Die Antwort: Mit jeder Excel-Version kommen einige, wenige, neue Funktionen hinzu. Da Excel seit der Version 2007 das (fast) identische Dateiformat XLSX unterstützt, haben Sie ein kleines Problemchen. In Excel 2013 wurde beispielsweise die Funktion ISOKALENDERWOCHE eingeführt. Diese Funktion gab es in Excel 2007 und 2010 noch nicht. Wenn nun das entsprechende Servicepack auf Ihrem Rechner installiert ist oder wenn Excel 2013 installiert ist, kann diese neue Funktion verwendet werden, obwohl sie eigentlich gar nicht auf Ihrem Rechner installiert wird. Leider wird nicht der Name ISOKALENDERWOCHE angeziegt, sondern: _xlfn.ISOWEEKNUM.

#ZAHL!

Manchmal – wenn auch recht selten – erhalte ich die Fehlermeldung #ZAHL! Wann passiert denn das?

Vor allem bei mathematischen Funktionen kann dieser Fehler auftreten. Es gibt einige Funktionen, die lassen nur einen bestimmten Wertebereich zu – sonst können sie nicht rechnen, weil sie im reellen nicht definiert sind. Beispielsweise verlangt Wurzel, Logarithmus und Fakultät eine positive Zahl, Arcsin und Arccos sind für Zahlen im Bereich [-1;+1] definiert. GGT und KGV sind nur für positive, ganze Zahlen definiert.

Erhalten sie negative Werte (beispielsweise WURZEL(-1) so ist #ZAHL! das Ergebnis.

Ebenso wachsen einige Funktionen sehr schnell. Mit FAKULTÄT(171) sprengt die Grenzen von Excel – Fakultät(170) ergibt 7,2574 x 10306. Mehr geht nicht. Auch mit der Funktion Potenz kommt man an die Grenzen von Excel.

Formel rechnet nicht

Ich habe eine Datei erhalten, die angeblich bei meinem Kollegen richtig rechnet. Bei mir sehe ich jedoch nur Fehler. Was habe ich falsch gemacht?

Fehler statt Formelergebnis

Fehler statt Formelergebnis

Sie haben alles richtig gemacht. Ein genauer Blick auf die Formeln zeigt, dass auf einem anderen Rechner mit der Funktion Ostersonntag gerechnet wurde. Diese Funktion gibt es nicht in Excel. Wenn Ihr Kollege sagt, dass diese Formel bei ihm funktioniert, kann es zwei Gründe haben:

1. Entweder er hat ein Add-In programmiert (oder programmieren lassen) oder zumindest installiert, das diese Formel (Ostersonntag) zur Verfügung stellt. Zwar rechnet die Formel korrekt auf seinem Rechnern, aber wird nun die Datei weitergegeben, rechnet die Funktion nicht mehr richtig auf einem anderen Rechner.

2. Er hat in einem anderen Programm gearbeitet, beispielsweise in openOffice.org oder in libreOffice. Dort existiert diese Funktion (einige der wenigen Funktionen die es in ooo oder libreOffice, aber nicht in Excel gibt). Die Datei kann als *.XLS gespeichert und weitergegeben werden. Beim Öffnen – Fehlermeldung!

Die Lösung: Sie müssen entweder das Add-In installieren oder die Formel auf Ihrem Rechner nachprogrammieren.

SVERWEIS rechnet nicht

Seit einer Weile arbeite ich mit dem SVERWEIS. Ich habe ihn schon recht gut verstanden. Aber manchmal rechnet er nicht richtig. Warum?

SVERWEIS rechnet nicht richtig.

SVERWEIS rechnet nicht richtig.

Dazu muss man sich die Formel genau ansehen:

=SVERWEIS(K2;$A$1:$A$32;3;FALSCH)

Sie suchen den Wert, der in der Zelle K2 steht in der Spalte A – genauer in den Zellen A1 bis A32. Soweit so gut. Sie möchten den Wert der dritten Spalte (3), also den Last Name wissen. Sie müssen den Bereich ändern: Es ist richtig – Sie suchen zwar in A1:A32, aber in der Spalte A steht nicht der Wert den Sie haben möchten. Sie müssen in der Matrix (in der Informationstabelle, in der die Daten gesucht werden), auch den Bereich einschließen, in dem sich die Daten befinden, also Spalte C. Sie können dabei gerne übers Ziel schießen, beispielsweise:

=SVERWEIS(K2;$A$1:$H$32;3;FALSCH)

Dann funktioniert es.

#BEZUG!

Ich weiß nicht mehr, was ich gemacht habe. Ich sollte in einer Tabelle einer Kollegin die Formel für den Unterstützungsbeitrag unserer Firma anpassen. Irgendwann entdecke ich jedoch in einer Zelle die Fehlermeldung #BEZUG! Kann ich den Fehler lokalisieren? Oder die Formel wieder auf eine korrekte Form bringen?

#BEZUG!

#BEZUG!

Die Antwort: Leider nein! Wahrscheinlich haben Sie irgendwo etwas gelöscht (beispielsweise eine Zeile), die an anderer Stelle noch verwendet wurde. Menschen rechnen oft kreuz und quer in Excel; schreiben irgendwelche Konstanten in irgendwelche Zellen. Fremde Tabellenblätter zu analysieren ist schwierig und mühsam:

Tipp 1: Speichern Sie die Originaldatei unter einem anderen Namen ab.

Tipp 2: Bevor Sie etwas löschen, von dem Sie denken, dass es nicht mehr benötigt wird – überprüfen Sie mit der Spur zum Nachfolger, ob irgendwo eine andere Formel mit dieser weiter rechnet.

Excel rechnet nicht

Excel rechnet nicht. Warum?

Warum rechnet Excel nicht?

Warum rechnet Excel nicht?

Ein Blick in die Statuszeile hätte genügt: Dort steht, dass in D3 ein Zirkelbezug steht. Und wenn man sich die Formel genauer anschaut, wird klar, dass D3 auf D5 zugreift, D5 jedoch wiederum auf D3. Das darf nicht sein!

Der Zirkelbezug ist ausfindig gemacht.

Der Zirkelbezug ist ausfindig gemacht.

Meine Empfehlung: Zirkelbezüge sind schwierig zu finden. Wenn Sie einen Zirkelbezug haben, erhalten Sie immer eine Fehlermeldung. Unterbrechen Sie die weitere Arbeit und machen sich auf die Suche nach der Quelle. Denn sonst resultieren weitere Fehler aus dem Zirkelbezug.

Die Zirkelbezugsfehlermeldung

Die Zirkelbezugsfehlermeldung

#BEZUG!

Warum erhalte ich manchmal den Fehler #BEZUG! ?

Das kann verschiedenen Ursachen haben:

1. Entweder Sie kopieren eine Formel an eine Stelle wo sie nicht mehr „richtig rechnen kann“. Beispielsweise findet die Summe keine drei Zellen oberhalb und kann deshalb nicht drei Werte summieren:

Summe nicht möglich

Summe nicht möglich

2. Eine Formel greift auf eine Zelle zu (beispielsweise auf Zelle C1). Wird nun die Spalte C gelöscht, dann „findet“ die Formel keinen Wert mehr und meldet #BEZUG!

#BEZUG!

#BEZUG!

Das heißt: #BEZUG! wird immer dann angezeigt, wenn man eine Formel so kopiert oder verschiebt, dass sie nun nicht mehr rechnen kann. Oder eine Spalte so löscht oder einfügt, dass eine Formel nicht mehr „erkennen“ kann, wi der Wert liegt, mit dem sie ursprünglich gerechnet hat.

Kompatibilitätsprüfung

Warum erhalte ich eine Meldung nach der Kompatibilitätsprüfung?

Kompatibilitätsprüfung

Kompatibilitätsprüfung

Wenn eine Datei im Format *.xls (also in Excel 2003) erstellt wurde und Sie diese Datei im gleichen Format speichern möchten, müssen Sie ein paar Dinge beachten:

Excel unterstützt im Format *.xls nicht alle Funktionalitäten, die in *.xlsx vorhanden sind. Dazu gehören:

  • Farben
  • Tabellenformatvorlagen
  • Bedingte Formatierungen
  • Formeln mit einer bestimmten Länge
  • Formeln mit einer bestimmten Tiefe
  • Bestimmte Formeln (SUMMEWENNS, ZÄHLENWENNS, WENNFEHLER, …)
  • Maximal Anzahl der Spalten und Zeilen (65.536 Zeilen x 255 Spalten)
  • Pivottabellen
Die Meldung ist eindeutig!

Die Meldung ist eindeutig!

Mein Tipp: Werfen Sie einen Blick in die Liste der Dinge, die verloren gehen würden. Vor allen Formeln werden unwiderruflich gelöscht!

Diese Formel bereitet Schwierigkeiten.

Diese Formel bereitet Schwierigkeiten.

Würden Sie diese Datei in Excel 2003 öffnen, wäre die Formel weg!

Excel 2003 kann nur acht Ebenen verschachteln.

Excel 2003 kann nur sieben Ebenen verschachteln.

Nach dem Öffnen der Datei sieht die Wenn-Funktion folgendermaßen aus.

Nach dem Öffnen der Datei sieht die Wenn-Funktion folgendermaßen aus.

 

Warum funktioniert ODER nicht in Wenn-Funktionen?

Die Funktion

=WENN((G2>180)ODER(I2=“Platinum“);G2+20;G2+10)

wird mit einer Fehlermeldung quittiert. Alle Kunden, die entweder Platinum-Mitglieder sind oder jetzt schon mehr als 180 Euro bezahlen, sollen demnächst 20 Euro mehr Jahresbeitrag bezahlen – die übrigen erhalten eine Erhöhung von 10 Euro.

Die Antwort: UND und ODER sind in Excel keine Verknüpfungsoperatoren (wie beispielsweise in Programmiersprachen), sondern Funktionen. Und Funktionen müssen immer VOR den Argumenten geschrieben werden, also so:

=WENN(ODER(G2>180;I2=“Platinum“);G2+20;G2+10)

beziehungsweise:

=WENN(UND(G2>180;I2=“Platinum“);G2+20;G2+10)

So funktioniert ODER nicht.

So funktioniert ODER nicht.

#DIV/0

Was bedeutet #DIV/0?

Entweder haben Sie durch eine Zelle geteilt, in der sich kein Wert befindet oder in der der Wert Null steht. Die Division durch 0 ist nicht erlaubt – in Excel nicht und in der Mathematik auch nicht.

Nicht nur bei der Division taucht dieser Fehler auf, auch bei einigen anderen Funktionen, beispielsweise MITTELWERT. Befinden sich noch keine Werte im Eingabeformular, dann rechnet MITTELWERT = SUMME (0) / ANZAHL (0) und liefert 0 / 0 = #DIV/0. Mann kann dies mit der Funktion WENNFEHLER abfangen. Bis Excel 2003 musste man die Funktion WENN(ISTFEHLER(… hierfür verwenden.

#DIV/0 - meist wurde eine falsche Zelle ausgewählt.

#DIV/0 – meist wurde eine falsche Zelle ausgewählt.

#DIV/0 liefern einige Funktionen, wenn noch keine Daten vorhanden sind.

#DIV/0 liefern einige Funktionen, wenn noch keine Daten vorhanden sind.

Man kann es mit WENNFEHLER abfangen.

Man kann es mit WENNFEHLER abfangen.

Excel multipliziert nicht

Warum klappt die Multiplikation nicht?

Auf manchen Tastaturen sieht das Multiplikationszeichen über dem Zahlenblock auch wie der Buchstabe „x“. Sie dürfen eine Formel jedoch nicht in der Form

=F8xE8

eingeben, weil Excel das „x“ als Buchstaben interpretiert.

Richtig:

=F8*E8

Übrigens: Auch die Division wird mit dem Schrägstrich „/“ durchgeführt und nicht mit einem Doppelpunkt, wie wir es in der Schule gelernt haben.

Excel multipliziert nicht.

Excel multipliziert nicht.

SUMME rechnet nicht

Kann ich mit der Summe nicht mehrere getrennte Bereiche addieren?

Doch. Aber die Bereiche werden nicht mit einem Leerzeichen, sondern mit einem Semikolon (;) getrennt.

Also – nicht so:

=SUMME(G5:G18 G30:G42 G56:G71 G80:G93)

sondern so:

=SUMME(G5:G18;G30:G42;G56:G71;G80:G93)

Übrigens: das Leerzeichen hat auch eine Funktion – es bedeutet: Schnittmenge. Man könnte berechnen:

=SUMME(C5:H21 G5:G26)

Damit würde die Summe über die Zelle G1:G21 gezogen werden.

Meine Empfehlung – tun Sie das nicht – das versteht kein Mensch, was Sie da tun! Und: wenn die Schnittmenge leer ist, quittiert Excel dies mit der Fehlermeldung #NULL!

Summe rechnet nicht.

Summe rechnet nicht.

Richtige Schreibweise: ; statt Leerzeichen!

Richtige Schreibweise: ; statt Leerzeichen!

Leerzeichen bedeutet Schnittmenge!

Leerzeichen bedeutet Schnittmenge!

Das würde funktionieren; ist aber unverständlich!

Das würde funktionieren; ist aber unverständlich!